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Pokročilé 3D editace



Chyby polygonální sítě

non-manifold edges
Hrany, které jsou součástí 
více než dvou polygonů. 
Řešením je vymazání 
nadbytečné facety nebo 
přidání objemu a propojení 
s objektem.

non-manifold vertices
Vrcholy, které jsou 
součástí více polygonů 
(anebo modelů), ale 
nesdílení své hrany.

intersecting faces
Protínající se polygony.

internal facets

Vnitřní facety. Řešením 
je odstranění facet.



Chyby polygonální sítě

obrácené normály díry v modelu 
Pro 3D tisk je nutný uzavřený 
model, jehož polygonální síť 
přesně vymezuje prostor. 
Řešením je uzavření díry v síti a 
doplnění objemu.

„loose geometry“
Přítomnost vrcholů a hran, 
které nedefinují facetu.



Svobodný a otevřený software pro modelování a vykreslování 
třírozměrné počítačové grafiky a animací s využitím různých technik. 

Blender

o editace a tvorba polygonálních modelů a jejich prvků

o virtuální modelování

o tvorba a editace textury

o animace

o tvorba statických a dynamických náhledů

o zvuk, střih a efekty

o na poprvé trochu moc...



Blender – základní orientace a navigace

Navigace:

MMB – rotace

scroll – ZOOM

MMB + Shift – posun

Num , – přiblížení okna na 
aktivní model

pracovní okno

přepínání mezi Object
mode a Edit mode

Outliners – seznam 
prvků projektu

volby nástrojů a 
objektů



Blender – zákadní módy

Sculpt mode a 
nástroje pro 
virtuální sochařství

Object mode a nástroje 
pro změnu polohy, 
orientace a velikosti 
modelu

Edit mode a nástroje 
editaci prvků 
polygonální sítě

přepínání módů



Blender – import modelu

volba split (v případě obj), 
zadaná defaultně, s 
některými modely 
nefunguje

importované soubory v 
pracovním okně

importované 
soubory ve 
stromu projektu

File > Import > ...volba podle typu souboru... > 
...vyhledání souboru... > Import 



Blender – export modelu

Podstatné volby při exportu

Selection only – vyexportuje pouze
aktivní/vybraný model. Pokud není 
zatrženo, exportuje vše do jednoho 
souboru. 

File > Export > ...volba podle typu 
souboru... > ...vyhledání umístění... >
Export 

(je potřeba vybrat ve stromu 
projektu předem model pro export)

OBJ

Include UVs a White Materials – pokud 
je zatrženo, vyexportuje také .mtl
soubor. Pokud ne, vyexportuje se 
pouze soubor obj.



Blender – pokročilé úpravy – edit mode

o mód pro většinu editací polygonální sítě, prostřednictvím editací jednotlivých prvků sítě

o přepínání 
mezi módy

o přepínání 
mezi editací 
bodů, hran 
nebo facet

o přepínání 
průhlednosti 
(možnost 
označit vše v 
dané oblasti 
bez ohledu na 
směr 
pohledu)

Výběr prvků:
LMB – jednotlivě
ctrl + RMB – laso
L – propojené prvky

Posun vybraných prvků:
stejně jako v edit mode (G, R, S, T)

Odstranění vybraných prvků:
delete >

odstraní

spojí zbývající 
prvky



Blender – snížení počtu polygonů

modifikátor Decimate

nastavení příslušného 
módu

nastavení podílu 
zachovaných vrcholů

zajištění triangulace 
výsledných facet

Decimate Geometry

nastavení podílu 
zachovaných vrcholů

V základu je možné pro snížení počtu polygonů modelu využít modifikátor Decimate, anebo 
nástroj Decimate geometry (Edit mode)



Blender – odstranění izolovaných fragmentů

Edit mode

1) výběr jednoho prvku sítě 
(LMB)

2) výběr všech prvků této sítě 
(ctrl + L)

3) obrácení výběru (ctrl + i)

4) smazání vybraných fragmentů



Blender – výběr prvků polygonální sítě

Výběr s pomocí lasa bez průhlednosti a s průhledností

Ctrl + RMB (Edit mode)
v kombinaci se zapnutou průhledností dovolí tento nástroj vybrat všechny prvky, které jsou v označené 
oblasti, tj. včetně těch skrytých.



Blender – odstranění prvků modelu – Delete

Delete vertices – odstraní 
všechny vrcholy, včetně 
hran a facet, které 
definují. Odstraní tedy víc 
povrchu, než je označeno.

Delete faces – odstraní 
facety a zbývající volné 
hrany a body

o odstranění vybraných prvků (Del + výběr z menu; Edit mode)

Only Faces – odstraní 
pouze facety. Ponechá 
vrcholy a hrany.



nástroj Knife (klávesa K, Edit mode)
Rozdělí facety novými hranami. V kombinaci s rozdělením polygonální sítě podél nově 
vzniklých hran (Mesh > Split > Faces by Edges) je možné použít pro hladké, komplexní ořezání 
jedné vrstvy polygonální sítě.

1) aktivace nástroje stiskem k
2) při stisknutém LMB definujeme řez sítí
Současným stiskem Shift zajistíte, že nové hrany budou přesně v dráze kurzoru, bez něj lnou k blízkým 
prvkům. Dobré je taky zapnout X-ray náhled               , aby se rozdělily i případné odvrácené fasety.

Blender – odstranění prvků modelu – Knife



nástroj Knife (klávesa K, Edit mode)

3) Mesh > Split > Faces by Edges – rozdělí síť podél vzniklé hrany. Její části je pak možné označit 
samostatně (l + LMB) a odstranit. Je nutné nechat vybranou původní hranu tak, jak je vybraná po 
použití knife. Nástroj knife někdy nefunguje dobře, v místech se složitou geometrií. Pokud jsou sítě i 
nadále propojené a nejdou označit a vymazat, je potřeba problematické místo vyhledat spojení sítí 
přerušit.

vzniklý hladký řezoznačení oddělné 
části sítě (l + LMB)

podoba řezu po prostém 
odstranění vybraných 
částí sítě

Blender – odstranění prvků modelu – Knife 2
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Blender – vyplňování děr v polygonální síti – Clean Up > Fill Holes

nástroj Fill Holes (Mesh > Clean Up > Fill Holes; Edit mode)
Pro správnou funkci musí být vybrána alespoň ta část sítě, která díru obsahuje (výběr nemusí být omezen 
jen na prvky na okraji díry). Nástroj také dovoluje definovat maximální množství hran zaplňovaných děr. 
Nástroj vyplní díry v polygonální sítě jednou, mnohostěnnou facetou. 

1) Výběr části sítě s dírou nebo 
celého modelu (klávesa A)

2) zaplnění facetou (Mesh > Clean Up > 
Fill Holes)

nastavení maximálního 
počtu facet  – výchozí jsou 
pouze 4 hrany, většinou je 
potřeba toto číslo navýšit 
(v levé dolní části 
pracovního prostoru)
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nástroje Fill a Grid Fill (Face > Fill, Ctrl + F nebo Face > Grid Fill; Edit mode)
Nástroje vyplní díry v polygonální sítě novými facetami – pro organické tvary je mnohem 
vhodnější než předchozí nástroj. Je ale potřeba vybrat pouze hrany obkružující díru v síti.

1) Výběr hran okolo díry v síti 
(Shift + Alt + LMB výběr hrany; 
Edit mode)

2) zaplnění novými facetami 
(Face > Grid Fill)

3) případná triangulace 
nových facet (Ctrl + T)

Blender – vyplňování děr v polygonální síti – Face > Grid Fill
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Ukázka okrajové facety, která může bránit 
výběru okraje díry a zaplnění díry.

Ukázka facety, při jejíž odstranění se změní 
lichý počet facet tvořících okraj díry v sudý.

Nastavení nástroje Grid fill.

Blender – vyplňování děr v polygonální síti – ovlivnění počtu okrajových hran
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Je potřeba vybrat pouze hrany, které obkružují díru v síti.

1) Výběr hran okolo díry v síti 
(Shift + Alt + LMB výběr hrany; 
Edit mode)

2) zaplnění novými facetami 
(Face > Fill, Alt + F)

vs.

Fill Grid fill

pro správnou funkci je nutné, 
aby okraj díry ohraničoval sudý 
počet facet!!! 

Blender – vyplňování děr v polygonální síti – Face > Fill



Blender – zobrazení směřování normál

Overlays > Face orientation

oblast facet s 
obrácenými normálami

Overlays > Normals (Edit mode)



Blender – změna směřování normál

1) výběr editované oblasti (Edit Mode, Ctrl + RMB)
2) Normals > Recalculate ouside (Edit Mode)



Blender – add-on 3D print

Add-on se aktivuje 
zaškrtnutím políčka vedle 
názvu

nástrojové 
okno v pravém 
menu, 
zobrazené 
kliknutím na 
šipku v pravém 
horním rohu 
pracovního 
okna

Add-ony jsou přídavné, úzce zaměřené skripty programu Blender, které se
musejí před použitím aktivovat anebo instalovat. Aktivace a deaktivace je
možná v menu Edit > Preferences > Add-ons.

Add-on 3D print je vhodný pro kontrolu modelu a výběr problematických
prvků.



Blender – add-on 3D print informace o obsahu povrchu 
sítě a jejím objemu

nastavení kontrolovaných 
parametrů

Check All – spuštění kontroly 
sítě podle nastavených 
parametrů

v Edit mode je možné 
nelzené prvky kliknutím 
vybrat

volba pro rychlou opravu

Nástroj Make Manifold ale není vhodný 
pro větší defekty, jako jsou například velké 
díry v síti. Je málo kontrolovytelný

Pro kontrolu je možné vybírat jednotlivé 
prvky v okně Result, zobrazit je a v případě 
potřeby odstranit, nebo opravit.



Blender – Modifikátory

Modifikátory jsou výkonné nástroje, které například mění vlastnosti modelu jako 
celku (jeho topologii nebo tvar) nebo na jeho základě vytvářejí nové modely.

dialogové okno 
modifikátorů 
(Object mode)

nabídka Modifikátorů

dialogové okno modifikátoru –
pro změnu modelu je nutné 
zadat Apply v rozevíracím 
seznamu 



Blender – modifikátor Remesh – Smooth

původní model Smooth Remesh, Octree Depth 6 Smooth Remesh, Octree Depth 8

Výsledný model při různém nastavení Octree depth.



Smooth Remesh, Octree Depth 8
Scale 0.9

Smooth Remesh, Octree Depth 6
Scale 0.6

Smooth Remesh, Octree Depth 8
Scale 0.4

Blender – modifikátor Remesh – Smooth

Výsledný model při různém nastavení Scale.



Voxel Remesh, Voxel size 0.3,
Adaptivity 0

Voxel Remesh, Voxel size 0.9,
Adaptivity 0

Voxel Remesh, Voxel size 0.9,
Adaptivity 0.1 

Blender – modifikátor Remesh – Voxel

Výsledný model při různém nastavení Adaptivity.



MeshLab – čištění polygonálních modelů

Nástroje pro odstranění redundantních dat a defektů sítě jsou součástí nabídky Filters > Cleaning and Repairing.

1) V okně Layer Dialog napravo od pracovního okna aktivujte model, který chcete editovat (LMB)

2) Následně aplikujte nástroje z nabídky Filters > Cleaning and Repairing…

…> Remove Duplicated Vertex – odstraní zdvojené vrcholy

…> Remove Duplicate Faces – odstraní zdvojené polygony

…> Remove Zero Area Faces – odstraní nulové polygony

…> Remove Unreferenced vertex – odstraní vrcholy, které nejsou součástí žádného polygonu (samostatné body)

Další defekty je možné odstranit kombinací nástrojů k výběru non-manifold prvků a jejich následného odstranění.
Výběrové nástroje jsou součástí nabídky Filters > Cleaning and Repairing…

… > Select Self Intersecting Faces – označí sebeprotínající se vrcholy

… > Select non Manifold Edges – označí hrany, které nejsou stranou žádné facety

… > Select non Manifold Vertices – označí vrcholy, které nejsou součástí facety



Změna polohy modelu nastavení náhledu není změna polohy, pouze pohyb kamerou

aktivovaný nástroj 
Move

gizmo pro 
posun

šipky – posun 
podél dané osy

plošky – posun 
rovnoběžně s 
rovinou

střed – posun 
kolmo na pohled

zkratky

G – aktivace posunu

G > x, y nebo z –
specifikace osy posunu



Rotace modelu

aktivovaný nástroj 
Rotate

gizmo pro 
rotaci

vnitřní kružnice – rotace 
kolem osy

vnější – rotace kolem osy 
náhledu

zkratky

R – aktivace posunu

R > x, y nebo z –
specifikace osy posunu



Změna středu rotace (Origin)

3D kurzor specifikuje bod, se 
kterým různé nástroje pracují –
Shift + RMB 

specifikace počátku 

3D Cursor – otáčení 
kolem 3D kurzoru

většina ostatních –
otáčení okolo středu 
soustavy souřadnic 
modelu 

Změna počátku soustavy modelu –
různé možnosti, nejintuitivnější asi 
Center of mass. 



Export modelu

Podstatné volby

Selection only – vyexportuje pouze 
aktivní model. Pokud není zatrženo, 
vybere vše. 

File > Export > ...volba podle 
typu souboru... > 
...vyhledání umístění... >
Export 

(je dobré vybrat předem 
model pro export)

Include UVs a White Materials – pokud 
je zatrženo, vyexportuje také .mtl
soubor. 



Blender – změna velikosti modelu – volnou rukou

aktivovaný nástroj 
Scale

gizmo pro změnu 
velikosti

vnější kružnice – izometrická 
změna velikosti

plošky – změna velikosti 
podél dané plochy

konce os – změna velikosti 
podél dané osy

zkratky

S – aktivace změny velikosti

S > x, y nebo z – specifikace 
osy změny velikosti



Změna velikosti modelu – zadáním koeficientu

šipka pro 
vytažení 
záložek koeficient

zvětšení

rozměry při 
aplikovaném 
Scale menu pro aplikaci 

transformací na geometrii



Blender – Virtual sculpting

o vyberte model, který 
chcete editovat

o přepněte do sochařského 
módu (Sculpt mode) 

nabídka 
sochařských 
nástrojů

modelování probíhá 
LMB na povrch modelu



Důležité volby

Nástroj Mask umožňuje 
označit oblasti modelu, 
které nemají být editovány 

Blender – Virtual sculpting



vlastnosti 
aktivního nástroje

Radius – rozsah editované plochy

Strength – síla nástroje

Direction – přidávání (Add) nebo 
ubírání (Substract) hmoty/masky atd.

Symmetry – defaultně 
je nastaveno zrcadlení 
editace, je potřeba jej 
odznačit

Acumulate – při jednom „tahu“ akumuluje 
změnu geometrie

Front Faces Only – edituje pouze ty facety, 
které jsou přivráceny k uživateli

Blender – Virtual sculpting – důležité volby



MeshLab – odstranění částí modelu

K označení polygonů a vrcholů pro jakoukoliv editaci 
slouží nástroje:

„Select vertexes“ a „Select
Faces in Rectangular
region“ – výběr vrcholů, 
resp. facet rámečkem

„Z-Painting“
freehand výběr prvků sítě

„Select connected
component“ –
výběr celé 
navazující 
polygonální sítě

„Select
faces/vertices in… “ 
– výběr prvků 
pomocí mnohostěnu



1) aktivujte nástroj Select Faces/Vertices in 
polyline area

2) LMB nebo RMB vyznačte polygon 

3) stiskem Q vyberte prvky v mnohostěnu; 
stiskem W by jste naopak prvky v oblasti 
mnohostěnu z výběru odstranili

při aktivovaném nástroji dále
T – přepíná mezi výběrem bodů a facet
BACKSPACE – zruší poslední bod mnohostěnu

MeshLab – odstranění částí modelu – výběr s pomocí mnohostěnu



1) aktivujte nástroj Z-painting

2) v dialogovém okně vyberte nástroj výběru

3) tahem se stisknutým LMB přidáte danou oblast do výběru
tahem při stisknutém RMB odebíráte oblast z výběru

další volby v dialogovém okně
backfaces – při aktivaci nástroj vybírá i facety, které 
jsou lícovou stranou natočeny k nám rubem
hidden polygons – při aktivaci vybírá i facety, které 
nejsou vidět, například proto, že jsou kryté jinými 
částmi modelu
…. dobré pro dočištění… !

MeshLab – odstranění částí modelu – výběr s pomocí Z-painting



odstraní všechny vrcholy a 
všechny facety, které označené 
vrcholy definují – nebude 
fungovat, pokud jsou vybrány 
pouze facety!

odstraní všechny facety 
– nebude fungovat, 
pokud jsou vybrány 
pouze vrcholy (mohou 
zůstat vrcholy)

odstraní všechny facety a 
vrcholy, které je definují

MeshLab – odstranění částí modelu – odstranění prvků



MeshLab – automatické vyplňování děr

o pro automatické vyplňování děr 
slouží nástroj Filters > Remeshing, 
Simplification and Reconstruction >
Close holes

Max size to be closed – nastavení maximální 
velikosti zaplněné díry v jednotkách počtu facet 
jejího okraje

Close holes with selected faces – uzavře pouze díry, 
u nichž je vybrán alespoň jeden jejich okrajový 
prvek

Prevent creation of selfintersecting faces –
neuzavře díru, pokud by tím vznikla sebeprotínající
se faceta


