WebSphere Integration Developer — Business Process

Before the lab:

* Logon to Windows: pi-eadmin / passwOrd
¢ Run the WebSphere Integration Developer (WID), you can use icon on your Desktop
* Inthe WebSphere Integration Developer, start the WebSphere Process Server 6.2

1. Process Overview
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2. Create a Library Project (for Common Artifacts)

To create the BankLib library project, complete the following steps:
1. Switch to the Business Integration perspective.

2. Click the File > New... menu item, select Library, name it BankLib.
3. Click Finish.

3. Develop the Web Service (bottom up) — CreditRatingService



1) Dynamic Web Project

1. Switch to the Java EE perspective. To switch to the Java EE perspective, select Window >
Open Perspective > Other from the Menu. In the Open Perspective dialog, select Java
EE and click OK.

2. Inthe Enterprise Explorer view, right-click the canvas.

From the pop-up menu, select New > Dynamic Web Project. The New Dynamic Web

Project window opens.

In the Project name field, enter CreditRatingService.

For Project contents, keep the default setting.

Select WebSphere Process Server v6.2 as the Target Runtime.

Select 2.4 for the Dynamic Web Module version.

Select <custom> for the Configuration.

Make sure Add project to an EAR is selected. Leave the default value

(CreditRatingServiceEAR).

10. Click Finish.

11. If the Open Associated Perspective dialog appears, click Yes.
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2) Create a Java Bean implementation of the Web Service

1. Inthe Enterprise Explorer view, right-click CreditRatingService.

2. From the pop-up menu, select New > Class.

3. Inthe Package field, enter bpc.samples.invoker.

4. Inthe Name field, enter CreditRatingService.

5. Click Finish.

6. Complete the implementation of CreditRatingService by adding the following method:

public int getCreditRating(String personld, String firstName, String
| ast Nane) ({

Systemout.println("GetCreditRating");

int rating = 0;

if ("1001".equal s(personid)) {
rati ng = 200;
} else if ("1002".equal s(personld)) {

rati ng = 400;
} else if ("1003". equal s(personlid)) {
rati ng = 600;

} else if ("1004".equal s(personld)) {
rating = 800;

} else if ("1005". equal s(personlid)) {
rati ng = 1000;

}

Systemout.println("Rating is: " + rating);



return rating;

7. On the toolbar, click the Save button H.

3) Generate a Web Service for a Java class

8. Inthe Enterprise Explorer view, expand CreditRatingService > Java Resources >
bpc.samples.invoker.

9. Right-click CreditRatingService.java.
10. From the pop-up menu, select Web Services > Create Web service.
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The Web Service window opens.

11. In the Web service type section, make sure Bottom Up Java bean Web Service is
selected.

12. Accept all other values.
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13. Click Next.

14. On the Service Endpoint Interface Selection page, accept the default values.
15. Click Next.

16. On the Web Service Java Bean Identity page, accept the default values.

17. Click Next.

18. Wait for the Web Service publishing to finish.

19. On the Web Service Publication page, accept the default values.

20. Click Finish.



4) Import the Web Service interface to the BankLib library

To import the CreditRatingService interface to the BankLib library, complete the following

steps:

1.
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9.
10.

Switch to the Business Integration view.

Find out your current workspace directory by clicking File > Switch Workspace. You may
copy this path for later use into your clipboard, then click Cancel.

In the navigation tree, expand BankLib and right-click Interfaces.

From the pop-up menu, select Import.

Expand Business Integration and select WSDL/Interface as input source.
Click Next. The WSDL/Interface Import page opens.

In the Input from field, paste the name of your workspace directory.
Browse to the CreditRatingService web project, choose folder
CreditRatingService/WebContent/WEB-INF/wsdl. Click OK

Select CreditRatingService.wsdl.

Click Finish.

4. Create a Process

1) Create a new module

1.

6.
7.

In the Business Integration view, click the link under Projects to add a business
integration project.

The New Business Integration Project window opens. Make sure Create a module is
selected.

Click Next.

In the Module Name field, enter OpenBankAccount.

Click Finish. The module will be created. Wait until the automatic build process has
finished.

Double-click on Dependencies under the project OpenBankAccount.

In the Dependencies editor, in the Libraries section, add the BankLib library project.

2) Define a data type (for input)

To create a data type, complete the following steps:

1.
2.
3.

In the business integration view, right-click Data Types.

From the pop-up menu, select New > Business Object.

In the New Business Object window, enter values for Name, Folder, and Namespace.
See the table below for the name of the Business Object and namespace, use
bpc/samples/flow for the folder.



4. Click Finish.
To add an attribute to a business object, complete the following steps:

1. Inthe business object editor, click the Add Attribute button 9

2. To edit the name, click the name in the business object figure. See the table below for

the name and type.

3. To edit the type, click the type in the business object figure, then select a type from the

list.

In the folder bpc/samples/flow, create the business object that is listed in the following table:

| Business Object | Namespace ‘Attribute Name ‘Attribute Type
|AccountRequestData |http://bpc/samp|es/f|ow ‘personld ‘string
| | ‘firstName ‘string
| | ‘IastName ‘string

| | ‘dateRequested ‘date

To save your changes, click the Save button on the toolbar.

3) Define a data type (for output)

Repeat the same steps as in the previous part for the following table:

|Business Object | Namespace | Attribute Name ‘Attribute Type
|Account|nfo |http://bpc/samp|es/f|ow |accountCreated ‘boolean
| | |reason ‘string

| | |accountSavingsNo ‘string

| | |accountCheckingNo ‘string

4) Define an interface

To create an interface, complete the following steps:

1. Inthe business integration view, right-click Interfaces.
2. From the pop-up menu, select New > Interface.

3. Inthe Create a new interface panel, use the default mechanism for the Namespace and

use bpc/samples/flow as the Folder; as the Name of the interface, use
OpenBankAccount.
4. Click Finish.



To add a request response operation to an interface, complete the following steps:

1. Inthe interface editor, click the Add Request Response Operation button #

2. To edit the name of the operation, click the operation name. See the table below for the
operation name.

3. Each new request response operation contains one input message by default. To add an
additional input message, select the operation and click the Add Input button .

4. To edit the name of an input message, click the message name. See the table below for
the message name.

5. To edit the type of an input message, click the message type, and select a type from the
list. If you want to assign a custom business object that is not already included in the list
as the type, select Browse. In the Data Type Selection dialog, browse for and select a
business object. See the table below for the type.

6. Each new request response operation contains one output message by default. To add
an additional output message to an operation, select the operation and click the Add
Output button g

7. Repeat steps 4 and 5 to edit the name and type of the output message.

In the folder bpc/samples/flow, create the interface that is listed in the following table:

Interface Namespace Operation | Mess Name Type
Name age
OpenBank |http://bpc/samples/flo openAccount |Input |accountRequest AccountRequestD
Account w/OpenBankAccount ata
t
?u Py bankResponse |Accountinfo

To save your changes, click the Save button \=lon the toolbar.

5) Develop the business process

To create a new business process, complete the following steps:

1. Switch to the Business Integration view.
2. Inthe navigation tree, right-click OpenBankAccount > Integration Logic.
3. From the pop-up menu, select New > Business Process.




1= Business Integration 3 =t Physical Resources | =m
= | = 1T —
= #BE o 5

Integration Solutions =

Projects =

= bl:' OpenBankAccount

%5 Assembly Diagram
= )

-5 Dependencies
B Integration Logic £
- 2 Data Types Mew ¥ Project »
-2 Interfaces .

& Mapping

| ¥ Business Process
Tow, - = T
EE] 4 Mediation Flow

%} Mediation Subflow

M Cslet 4] Human Task
The New Business Process window opens.

Accept the default value for the namespace.

In the Folder field, enter bpc/samples/flow.

In the Name field, enter OpenBankAccountProcess.

Click Next.

In the Select a Business Process Type panel, select Long-running process.
Click Next.

. In the Select an Interface panel, select Select an interface.

. Click Browse. The Interface Selection window opens.

. Select OpenBankAccount, then click OK.

. Select Operation openAccount.

. Click Finish.

. Add component Scope from the palette to the canvas.

. Move activities Receive and Reply to the scope, so the diagrams looks like in the

picture.
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17. Examine the properties of both activities.
18. Click on the empty space of the process to see its properties. In the properties, set
Automatically delete the process after completion to No.
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6) Add the created web service (CreditRatingService) to the process

1. Create four variables (on the right side of the screen). Names and data types of these
variables are in the table below.

Attribute Name Attribute
Type
|person|d ‘string
|firstName ‘string
|IastName ‘string
|dateRequested ‘date
|creditRating ‘int
|accountConfirmed ‘boolean

2. Drag the Assign activity from the palette to the flow so it looks like it is displayed in the
picture.



w

as displayed in the picture.
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Rename the Assign activity to Assign variables. We are setting the display name.
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5. Drag the CreditRatingInterface from the BankLib project to the empty area of the scope
activity. The reference partner (right side of the screen) has been added.

6.

On the right side, expand CreditRatingService reference partner, then

CreditRatingService web service. Finally expand getCreditRating operation and drag it
into the Scope container.

process now looks like this.

Rename the task from Invoke to Get Credit Rating. We are setting the display name. The




8. In the properties of the Get Credit Rating activity, set the input and output variables,

like displayed in the picture.
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7) Add another activities to the process - Snippets

Follow these steps to add snippets to the Scope activity:

1. Click the snippet icon on the palette.
2. Click the empty area of the scope activity. The snippet will be added.
3. Inthe name field of the activity, enter the name. See the table below for the name.

Activity Name

Display Name Activity Type ‘Symbol |




|SetAnswerReject ‘Set Answer Reject |Snippet ‘ [
|OpenSavingsAccount ‘Open Savings Account |Snippet ‘ 1
|SetAnswerConfirm ‘Set Answer Confirm |Snippet ‘ [
|OpenCheckingAccount ‘Open Checking Account |Snippet ‘ 1

The Scope Activity figure now looks like this:
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To implement a snippet activity, complete the following steps:

1. Inthe business process editor, click the snippet.
2. Inthe Properties view, click the Details tab.
3. Select Java.
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4. If the Question dialog appears, click Yes.
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5. Inthe text area, enter the Java code.
6. On the toolbar, click the Save button El.

Complete the implementation of the following snippet activities:
SetAnswerReject

System out. println("Set Answer Rej ect");
bankResponse. set Bool ean("account Created", false); //rejected

bankResponse. set Stri ng("reason", "Your request to open an account was
rejected.");

OpenSavingsAccount

System out. println("OpenSavi ngsAccount");
java.util.Randomrand = new java. util.Randon();
int num = rand. nextlnt (10000);

bankResponse. set Stri ng("account Savi ngsNo", (new
I nteger(nun)).toString());



OpenCheckingAccount

System out . printl n(" CpenChecki ngAccount");
java.util.Randomrand = new java. util.Randon();
int num = rand. nextlnt (10000);

bankResponse. set Stri ng("account Checki ngNo", (new
I nteger(nun)).toString());

SetAnswerConfirm

System out. println("Set Answer Confirni');
bankResponse. set Bool ean("account Created", true); //confirned
bankResponse. set Stri ng("reason”, "Your request has been accepted.");

8) Create a human task

Human task will be used by bank officers. We will only involve people in this process when the score is in
the middle range (400-700).

1. Asdiscussed in 4.4, create an interface ConfirmBankAccount in the project
OpenBankAccount regarding the next table. This interface will serve as interface of the
new Human Task.

i M
Interface Namespace Operation essd Name Type
Name ge
ConfirmBa |http: les/fl firmA A tR tD
onfirmBa p//t?pc/samp es/flo |confirmAcco Input |accountRequest ccountReques
nkAccount |w/ConfirmBankAccount |unt ata
| ‘ ‘ |Input ‘creditRating |int
| ‘ ‘ |Output ‘confirmed |boo|ean

2. Drag Human task activity to the Scope task.
3. In the dialog, choose ConfirmBankAccount as an interface.
4. Rename the task from OpenBankAccountProcessTaskl to Confirm Bank Account.

9) Add control links between activities

Because we now want multiple branches in the process, we substitute the Scope task with the
Parallel Activities task and connect the activities in appropriate way.

1. Move Parallel Activities to the process
2. Move activities from Scope to Parallel Activities




Put cursor over an activity, you will see orange circle. Click on the circle and drag the
connection to another task. Repeat this task, so the overall process looks like similar as

the picture below.
Use Context menu > Arrange Parallel Activities Contents to organize paths between

activities.
Delete empty Scope activity

O
(o

T Parallelactivities
=

o | Receive

l

= Assign Yariables

l

& Get Credit Rating

(% Confirm Bank Account

k3

Lé Set Answer Confirm Lé Set Answer Reject

l l

[ Open Checking Account (% Open Savings Account
|

| Reply

|



6. Add conditions to some of the paths (together 5 conditions), so that:

The accounts are automatically created when the score is 700 or more.
Human task is used when the score is >= 400 and < 700.

The request is automatically rejected for scores 0 to 399.

After the human task, the accounts are created only if it is approved by the
officer (based on the value of accountConfirmed variable).

o0 oTo

Hint: To set the conditions, click on the connection between tasks and set the condition.
Here is an example picture:
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10) Module assembly

To finish the implementation of the process, you have to create the module assembly.
Complete the following steps:

1. Inthe Business Integration view, double-click OpenBankAccount > Assembly Diagram.
The assembly editor opens.

2. Inthe Business Integration view, expand OpenBankAccount > Integration Logic >
Processes > bpc/samples/flow.

3. Drag and drop the OpenBankAccountProcess process to the assembly editor.

4. Inthe Business Integration view, expand BankLib > Interfaces.

5. Drag the CreditReportService interface to the assembly editor. The Component Creation
window opens.

6. Select Import with Web Service Binding.



1)

12.
13.
14.
15.
16.

17.

4+ Component Creation |Z|@

Select the type to create:

II;L"‘.: Component with no Implementation Type
* Export with no Binding
-r-;i_-‘!'Export with Web Service Binding

= Impart with no Binding

A Import with Web Service Binding

7 [ QK ] [ Cancel

Click OK.
A new window CreditRatingServicelmportl Web Service Import... opens.
Select Use an existing web service port. Click Browse.

. From the popup, select CreditRatingService and click OK.
. When the Transport Selection for CreditRatingServicelmportl window appears click

OK.

Click OK.

The import is added to the editor.

In the assembly editor, click CreditRatingServicelmportl to select the new import
element.

Click again on the import element and overtype the default name
CreditRatingServicelmportl by CreditRatingService.

Wire the 1..1 section of OpenBankAccountProcess component and CreditRatingService
component.

On the toolbar, click the Save button =l

Test the business process in the integrated test
environment

Install the OpenBankAccountProcess process to the test environment

N

In the Servers view, click the Servers tab.

In the table, right-click WebSphere Process Server v6.2.

From the pop-up menu, select Add and Remove Projects. The Add and Remove
Projects window opens.

Click Add all.

Click Finish.



2) Run the sample using BPC Explorer

To run this sample, use the Business Process Choreographer Explorer.

To start BPC Explorer in the integrated test environment of your WebSphere Integration
Developer, follow these steps:

1. In WebSphere Integration Developer, switch to the Servers view.
2. Inthe table, right-click WebSphere Process Server v6.2.
3. From the pop-up menu, select Launch > Business Process Choreographer Explorer.
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In a web browser, open URL http://yourhost:yourport/bpc.
Note: yourhost has to be replaced with your server's internet address, yourport has to

be replaced with the port of your server's HTTP transport, for example
http://localhost:9080/bpc.

If security is enabled, the BPC Explorer opens with a login screen:



Welcome, please enter your information.

The page vou reguested is only available to registered users. Enter
wour username and password and click Login.

Uzer Mame: [gu:lrnin |

Password: [seses |

Login

1. Enter avalid User ID and Password. The default User ID is admin, password is admin.
2. Click Login.

The BPC Explorer opens:

Business Process Choreographer Explorer —

'l
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3) Start the sample business process

To start the invoker process, follow these steps:

1. Switch to the BPC Explorer.
2. Inthe Process Templates Section, click Process Templates.

The Process Templates view is displayed:

Business Process Choreographer Explorer
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Select OpenBankAccountProcess, then click Start Instance.
Fill in the name of the process, so you can identify it later.

Fill in the input. You can leave the dateRequested field empty.
Click Submit.
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Hint: Based on CreditRatingService implementation, use 1001, 1002, 1003, 1004, or 1005 values
as personlds. First name and last name can be whatever you like, the date does not need to be
filled. For clients with personlds 1002 and 1003, the human task is invoked.



4) Output messages

Inspect the SystemOut.log of your WebSphere Process Server or the Console within WebSphere
Integration Developer.

6. Final steps

* Remove all applications from WebSphere Process Server
e Stop WebSphere Process Server



