
Environment in Blender

Creating rocks, mountains, grass, fog, generate environment with Google maps, you need a Node

Wrangler add-on in most of these examples as we will play with nodes.

Making terrain from Google Maps:

1) Download Blender GIS Master add-on from Github by clicking ‘Code’ button on the right

(green_ then clicking #download Zip’.

https://github.com/domlysz/BlenderGIS

2) In Blender, go to Edit-> Preferences- Add-ons -> click Install button -> locate the file where

you downloaded the add-on and-> click on the zip you downloaded -> Install add-on button

-> tick box next to this new add-on in preference menu

3) In the drop-down menu next to the add-on, go to ‘Basemaps’ -> Cache folder -> click on the

folder icon and create a new folder called ‘Cache’, then choose that one as the output folder

and click ‘accept’ button in the bottom left.

4) Now you are done with the GIS add-on, while in the Add-on menu, make sure you also have

enabled the Node Wrangler Add-on

5) Now, in the viewport of Blender, you have a new ‘GIS’ button in the top left corner. You can

click it and choose ‘Web geodata’, where you choose a ‘Basemap’. Once you click that, you

can choose where you want the data from. Choose Google as a Source and Satellite in the

Layer window.

https://github.com/domlysz/BlenderGIS


6) When you click OK button, Google maps will open in your Blender viewport.

7) You can explore the map in Blender, or you can press the G and look for specific location.

8) In this example we searched for ‘Rysy’, a mountain range in the High Tatras with some lakes

and cool rocks.

9) When you have the desired region in the viewport, press E, which will cut out this area.

10) The plane in the viewport already has this 3D texture mapped on it.

11) With your coloured plane selected (in Object mode), click the GIS button (on the top left

corner) -> Web Geodata -> Get elevation SRTM



12) A new window will pop-up, the click OK.

13) Wait a bit…
14) Blender will import the height data onto the texture straight from the satellite😊

15) In the Edit Menu (bottom right), go to modifiers list and you can see that the elevation

information was added as a ‘Displacement Modifier’. In the bottom right window of the

modifier, you can adjust the strength if you increase the number above 1, which is there by

default.



16) You can add more details to your height map by clicking into Edit Mode (which will make it

flat again), selecting it, clicking right mouse button, and subdividing it a few times. The

subdivisions will help you create nicer shadows and rock formations.

17) This might give you a jaggedy effect if you look closely.

18) In that case, go to your Displacement modifier and click a little texture button .

19) Then scroll down to ‘Image’ -> ‘Sampling’ and in the drop-down menu clcik the box

‘Interpolation’. Doing this throwns you from Modifiers tab into Texture Properties tab in the

Edit Menu.

20) After you enable interpolation, go back to Modifiers list in Edit Menu and firstly apply the

Subsurf modifier (with a circle) and then the Displacement modifier. (to apply modifiers you



need to be in the Object mode).

21) In Edit mode, select everything by pressing A, then extrude along Z-axis down (E +Z).

22) You can flatten out the bottom by pressing S +Z+ 0

23) Check your Face Orientation (top right corner -> rick Face Orientation) and you may see that

your mountain range is red. The normals are flipped. In that case, you need to select

everything (while in Edit mode) by pressing A, and press Alt + N-> Flip (or F3 and search for

flip normals). Then if you check your Face orientation it should be blue:

24) As you know, HDIR maps have light information. You can import an HDIR map through

Shader tab (top ribbon menu) or through Edit Menu -> World Settings -> Colour ->

Environment Textures -> choose a downloaded HDIR Map



25) Switch to Cycles😉

26) Under Render Settings in Edit Menu , go to Colour Management and you can change

the contrast.

27) Under Film drop=down menu you can tick the ‘Transparency’ box to make the HDIR

disappear, just leave the light data in



28) OPTIONAL: To tweak some of the materials, go to your Shader Editor (top ribbon menu).

Your nodes look something like this:

29) Adda Bump Node by pressing Shift + A -> Vector -> Bump, then connect the colour of the

broen texture node into the Bum node’s Height point.

30) Scale down your mountain model to about a quarter of its size to make it more managable.

The n back in Shader editor, connect the Bump’s normal output to normal output on the

BDSF principled shader.

31) You can play around with the Strength and Distance sliders in the bump node. This Bump

node business has a subtle effect but effects things like trees on the mountains.

32) You can add a little bit more definition to the mountains by adding the ‘Ambient Occlusion

node’ (Shift +A-. Input-> Ambient Occlusion), crank up the distance value to about 50. (This

will make your mountains white).

33) Add in a Math node (Shift + A-> Convertor -> Math), change Add to ‘Power’ in the

drop-down menu and change the value to 25. (This will add black ridges to your mountains).

34) Then add a Mix RGB node (Shift + A-> Color-> MixRGB), which you will drop between the

texture and BDSF principled shader noodle. Change the ‘Mix’ to ‘Multiply’ from drop=down

menu. Now connect the Power math node into the MixRGB node into color2. Play with Fac

to see which value you like: this is to make your mountains stand out/ more defined (just a

little bit)



35) Decrease Specular in your BDSF principled shader to make the mountains less shiny

36) You can add a different material to the sides of your model. Just click ‘New’ in the Shader tab

to create a new material. Or in Edit Menu in Material Tab, click + then ‘New’ which pops in a

BDSF Principled shade in the Shading tab.

37) Now in Edit Menu with face selection selected, Alt+ L click on the side of the mountain (will

select the side loop.

38) Now you assign the chosen material to it in the Edit Menu.



39) Done:

Sources:

https://www.youtube.com/watch?v=Mj7Z1P2hUWk&t=305s

Rock (from default cube)

1) Add subdivision surface modifier to your cube. Increase the Levels Viewport and render to

4-5.

2) Add a Displacement modifier and in Texture, click ‘New’

3) Go to Texture tab within the Edit Modifier and change the texture Type to Voronoi.

This will do funky things to your object, fear not:

https://www.youtube.com/watch?v=Mj7Z1P2hUWk&t=305s


4) Decrease the Intensity and increase the size. For example to 0.8 and 1.2. Play around with it

to get what you like!

5) Don’t forget to Shade Smooth😉
6) Back in the Modifiers tab, if you click the Edit Mode button on the Displacement modifier,

you can then pull individual vertices in Edit mode to give the rock different shape.

7) Make sure your Node Wrangler Node is on-> go to the Shading tab, press Ctrl+Shift+ T and

add in a whole bundle of PBR textures at once. Textures can be downloaded here:

https://ambientcg.com/view?id=Rock020

https://ambientcg.com/view?id=Rock020


8) Yay, this rocks!

Source: https://www.youtube.com/watch?v=4EqLyGsu3AA

Other ways of creating rocks:

1) Shift+ A -> Mesh ->



Fog

1) Bring in a cube and ‘box’ the area that you want to be foggy and increase its size to cover the

objects.

2) With the box selected, go into Shading tab (top ribbon menu). Delete the BDSF Principled

Shader and bring in a Principled Volume Node. Connect the two volume points with a

noodle. Here, you have created a fog effect. But in the next step will add some more nodes

to control the fog.

3) Bring the Density on the Principled Volume Node down to 0. We will control the Density

with a slider on a colour ramp with a Colour Ramp node we will bring in.

4) Bring in the Color ramp node and the Noise Texture node. Connect the Fac to Fac on these

two nodes.

5) Connect the color of Colour ramp to Emission strength of Principled volume.

6) At this point you can stop and play with the nodes to have the fog you want. By playing on

the Colour Ramp slider, you will have less or more fog.

7) For more control, click on the Noise Texture node and press Ctrl+ T (this uses the node

wrangler add-on), and 2 more nodes appear, the Texture Coordinate and the Mapping

nodes.



8) Unselect the connection between Generated and Vector and connect Object and Vector on

the two new nodes.

9) Add a Gradient Texture node and connect its vector point to the vector points of the

Mapping node (it will have two noodles in it now).

10) Bring in MixRGB node and lace it between the ColorRamp node and the Noise Texture.

11) Now take the GradientNoise Texture node from colour point and connect it to the Colour 2

on Mix RGB texture point.

12) Add a Bright Contrast node between Colour ramp and Principled Voume node.

13) The whole shebang looks like this and you have the ultimate control over your fog with the

help of the 9 nodes:



14) In the Mapping node, change rotation of the Y axis to -90 so the fog is rising from the ground

and disperses up. Or any other rotation and fog ‘entrance’ you desire.

15) In The Bright Contrast node you can slide the Bright slider and change the brightness.

16) You can change the fog thickness with a Fac slider in the Colour Mix Shader.

17) Change the colour of the fog in the Principled Volume shader, with either of the colour

windows.

18) With the slider on the Colour ramp, you control how much fog is there, probably the most

visible change in fog.

Source: https://www.youtube.com/watch?v=4NrOXReR3Dk

Generated Landscapes

1) Edit -> Preferences -> Add-ons -> Add Mesh: ANT Landscapes -> tick box



2) Shift + A -> Mesh -> Landscape (new option because of the add-on).

3) Click on it and a terrain will appear in your viewport. At the bottom left of the viewport a

new menu will appear. That’s where you control the generated landscape.

4) Click on the pop-up menu, be careful, once you click out of it there’s no going back and you

would have to import a new landscape to manipulate.

5) In the menu, you can choose the Noise type from a variety of noises that affect the

landscape and give you different types of mountain shapes, these are pre-set and can be

adjusted to your liking. Otherwise you can play with settings such as the Depth and Height-

the higher you put the value the higher the mountains will be. Equally if you have negative

values, your mountains will become cracks or rifts in the ground. Play around with the Falloff

which is responsible for how far away from the edge the mountain will ‘end’. You can control

all axis sides. You can also try Random seed which generates maps. AT the very top you have

Operator Presets where you can choose ready terrain models, including rock, volcano, gully,

river, planet, flat stones and many more.

Source: https://www.youtube.com/watch?v=IZXDDrXjwMA



Grass (quick, using particle system)

1) Shift + A-> Mesh -> Plane

2) In Edit Menu, go to Particle Settings

3) Click on the + sign on the right

4) Switch from the Emission button to the ‘Hair’ button

5) Under ‘Emission’, change the hair length to desired length and increase the Number

6) Under the Hair button you clicked, tick the box ‘Advanced’ and scroll down to ‘Physics’ ->

Forces -> Change the Brownian value for example 0.3, which will give you messy look.

7) Add material… presumably green-ish but choose whatever you want

Source: https://www.youtube.com/watch?v=27IY1JJ4G8o



Rain

1) Bring in a plane

2) Bring in an Ico Sphere

3) Select your plane, click into Edit mode, select all, right click and subdivide the plane 60 times.

This is to add detail to the water surface when droplets fall onto the water surface/ puddle/

lake

4) Shade Smooth the plane😉 (in object mode, right click -> shade smooth)

5) Add in another plane and make sure it is the exact same size as the first one. Grab it by the z

axis and move it directly above the first plane.

6) With the bottom plane selected, go to Edit Menu and click Physics Properties . Now

choose the Dynamic Paint

7) Under Type, choose Canvas from the drop-down menu.

8) Press Add Canvas button which will open a new menu underneath.

9) Under Surface, choose the Waves from the drop-down menu under Surface Types

10) Click on the top plane, which will be sky, got to Physics Properties in Edit Menu -> Dynamic

Paint and under ‘canvas type’ choose ‘Brush’

11) Click Add Canvas button

12) Under Source, click Mesh Volume and from the menu choose Particle System

13) Go to Particle System tab at the side of the Edit Menu. Click the + sign on the right side.

14) Scroll to Render and in Render As, choose Object



15) Under Object, choose the pipette and pick the Ico Sphere in the viewport.

16) Go back to the Physics Particles tab .

17) Under Source -> Particle Systems -> pick Particle Settings

18) If you press the Spacebar, your physics simulation will begin

19) Back in the Particle Properties tab , you can go into Emission to control the effects, such

as the number of particles falling.

20) Change the material of the water by changing the colour to blueish, taking down the

roughness to 0, you can give it some subsurface colour.



Source: https://www.youtube.com/watch?v=35bbyAJodEQ

Sapling Tree Add-On add-on

free add-on included in Blender. allows you to add in and customise a tree

This includes an option of adding an armature and wind animation onto the tree

More tutorials

Swamp tutorial: https://www.youtube.com/watch?v=KXRBE3dsJRk

- shows you how to make weeds, use those as particles (including some weight painting), Eevee

City Tutorial: https://www.youtube.com/watch?v=NW_djQS_N8U

- creating accurate height maps of cities in Blender using Google Maps

Another city Tutorial: https://www.youtube.com/watch?v=JjnyapZ_P-g

Scatter tool addon: https://blenderdaily.xyz/articles/nature-creation

- using free add-on that comes with blender to create a forest scenes with mushrooms

https://www.youtube.com/watch?v=7e2FUeuhldE&ab_channel=BlenderSecrets

https://www.youtube.com/watch?v=NW_djQS_N8U
https://www.youtube.com/watch?v=JjnyapZ_P-g
https://blenderdaily.xyz/articles/nature-creation

