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_ntroduction to SPSS for Windows

This warkbook is based upon the personal computer version of PSS, SPSS for Windows, One
if the advantages of using the Windows version of 5PS5 is that many of the features will be
_amiliar bo users of other programs which operate in 2 Windows environment, such as the
wordprocessing package Woerd for Windows or the spreadsheet package Excel for Windaws,
5PS5 is a computer software package that is specifically desigred to perform stabistical
perations and Facilitate data analysis and is by far the most pepular statistical package used
2y social scientists, [V is worth pointing oub al this stage that one of the best sources of
informgation and help about 5PSS and its various functions is lberally ab your Grgertips, and can
he acgessed through the camprehensive Telp menu within the SPSS program. Some of the
mpodant features of this Help menu include:

The Cwline Tetorinl i

This provides @ good introduction to the program and adopts a clear step-by-step approach to
the varicus features of SPSS,

The Stifistics Coach

“This provides same basic assistance with many of the statistical procedures available in 5PSE.
“or more detailed statistical explanations you are advised to consull the SPS5 applicalions

puide or any good introductory statistics text.

The Conlextual Help System

This provides infarmation on specific features of 3PS5, Pointing the mouse ab the specific
“harticular fzature or conlral you want e know maore about and clicking the right mouse key

help facility.

activates H

Getting started on SPSS

_The 5PE5 program (assuming, of course, that it is installed on your computer] is accessad by
Aicking ar the Start bufton situated on the bottom left-hand side of the compuler sereen and
selecting SPSS For Windows from the Programs menu,
tou should note that the menu system may be conbigured slightly differently cn the
—computer you are using and therefore the location of SF5S may not be idectical to that
MNustrated¥n Figure O.1a)
¢ This will start 5P3S {the 5F55 icon will appear in the Windows Task bar al the bottom of
the screen) and the Data Bditor window will apen up autormatizally.
Once opened, there are a number of ways to bepin using the SPS5 package. The apening
dialog box (shown in Figure 0.1b) offers five options and you can proceed by clicking on the
sequived option butten and then an OK.

QORIEMTATION 13

Figure ©.1a  Starling PSS
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Start butlan Task bar

It is worth pointing out that this dialog box may not always appear when you open SPES (for
example, if the previous user has clicked on the ‘Dan‘t show this I box in the future’
option). Fortunately, all of the aplions available in the opening dialog box can be accessed
through the SF5S menu system,

The apening dialog box can also be removed by clicking on Cancel and, as we want bo Fake
a closer look at the Data Editor windaw, you can do this naw.

The Data Editer window is blank at this stage and contains no data (see Figure (.2). You
will need to became Familiar with the windaw in Figure 0.2 i you are to navigate .,_ﬂ._.__.__..._. SF5S
successlully. Some of its main features are cxplained below. h .

(1) The Title bar

The top section of the window is knawn as the Title bar and by clicking and dragging on this
¥ou can reposition the window anywhere on the screen. On the right-hand sicle of the Title bar
are three small squares:
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Figure 0,1k SP33 for Windows ‘opening dialog box’

SP55. for Windows

trel

[y Documerts\5P25 BOOENSPSS Data Filsz |
_u””_uh_um_m_._.._.n_.nw...m PS5 Angisty sy
R D it Y

O The first is the Minimize button and clicking on this reduces the window to an icon in the
Windows Tasl bar ab the boltorn of the screen, Try this, but don’t panic when the window
disappears. This window is still open and you simply click on the SPSS icon in the
Windows Task bar to restore it to ik original size.

O The setnd squars represents the Maximize button and IF you click on this the Data
Ecditor window will &l the sereen. To restore the window to its original size click on this
button again.

O Clicking on the third square in the top right hand corner of the Data Editer windaw closes
the 5PS5 program down altogether, I you have made any chenges to the delasel or
produced any autput you will be asked if you want to Save them {there will be more on
saving SPS5 fles later in this chapter].

Lyl

_D_N._.m MTATION 13

Figure 0.2 Blank Dala Editnr window (Data View) Close

{11 Title bar (2} Menu bar  {3) Tool bar

Maximize —
Minimize ____

o

= Untitled =-5P55 Data Editor. 25 5

Y ESe e
] ;

Tilalseas] o
ey SFES Plocessor is teady

Information area

“fou can also resize the Data Editor window by clicking and dragping the sides or the enmers
of the windew.

(2) The Menn bar

Underneath the Title bar you will find the Menu bar which is the primary means of getting
SPES to carry oulb the tasks you reguire.

As can be seen from Figure 002, the Menu bar conlaing ten broad menu headings,
heginning with File and ending with Help. If you click the mouse on any of these headings a
vasiety of options relating to this bopic will appear in a drop-down menu. Figure 0.3, far
instance (p. 17), displays the Edit drop-down menu. Ta get rid of the drap-down menu simply
click anywhere outside i,

A brief summary of some of the main functions associated with cach of these ten menus is
appropriate ot this stage.
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File — The File menu includes Facilities for creating. opening, closing, saving and print-
ing Ales.

Edit ~ The Edit menu is used if you want ba cul, copy or paste items, either within SP3S or
fram 5F55 to other programs such as Word,

View — The View menu allows you to alter various features of what vou see in the
window. Far example, in the Data Editor window you are given the option of displaving
value labels rather than number codes or removing grid lines,

Data g The Data menu allows you lo manipulate the dataset in various ways. You can
.}..wmm_.m. the datasct, insert additional variables or merge bwa datasets Logether via this menu.
Alsa Available in this menu is the facility for selecling out a subset of the data.
Transform — The Translorm menu contains faclities for transforming and medifying the
datazet, including Recode, Compute-and Count {these data modification procedures are
explained in detail in Madule 3). 3
Analyze — The Analyze menu is where the various forms of statistical analysis available in
SF5S are located. We will be examining many of these statistical procedures in the course of
this workbaok.

Graphs — The Graphs menu provides a range of faclitivs to enable you to create various
charts and graphs.

Utilities ~ The Utilities meru includes a nember of wseful tools including facilities for
creating smaller subsets of the dats, Complete information about all the variables in the
dataset can also be accessed through the Utilities menu.

Window - The Window menu allows you te swilch between different windows {for
example between the Dala Bditor window and the Viewer windaw).

Help = The Help menu provides a comprehensive range of information and help on
various aspecls of the SPE5 package (see abowe for a brief summary of some of the main
features of the Help menu).

{3 The Toal bar

The Tool bar in SF55 is located just below the Menu bar and, like the Tool bar in ather
Windows-based applications, pravides a number of sharteuts for commonly used procedures or
tasks. For instance, the first three icons in the Data Editer Tool bar perform the functions of
apening a fle, saving a file and printing a file. If you place the mouse pointer on any of the
icons in the Tool bar a brief description of the function it performs will appear directly under-
neath the jcon {and alse in the information area ab the bottom left-hand side of the screen).

i

Do wat efick Hhe mguse unless yon wanf fo carey ond Hae procedure in juestion!

Pt

Some minor adjustments to SPSS

Befors we proceed any further there are 2 couple of changes that we recommend you make to
the defenlf options in SPE5, Youw will And that resetling these options has two main advantages:
(1) variables will be much easier to locate; (2) the results af your analysis will be labelled more
fully, Mareover, you should Tind this workbook easivr bo follow if your SP55 settings are

identical ko ours.

Lk
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Resetting wearialle lsts

Before you carry oub any kind of analysis in SPSS you need bo select the wariables yon are
paleresteed in froms a list of all the variables in your datasel. This selection process is much eas
if the variables are displayed afpliebetically, using wariille moes rather than variable labels,
Hewwever, in order to achieve This we need Lo change the Yariable Lists default options.

_ _ﬁr__mr on .m_.m: te apen up the Edit drop-down menu {ses Figure 00.3) and select Options by
clickiog o It

Figure 0.3 Edit drop-down menu

[ BSACAIMER - 5P55 Dala Edilap::
on - Anie - frapta

This will apen up the Options dialog box shown in Figure 0.1, Click on the General b to
ensure thal the Variable Lists options are displayed and then selact Alphabetical and
Display names by dicking an them, Finally click an O B

These changas will be implemented the next fime you open a dala fle (this is coversd in the
fullawing section, "Loading a Data File’) and their effect can be abserved in Fi sure £09 (p 22,
You will notice in Figure 009 thal wmicble nanes, rather than variable labels, appear in the
varille list and that this is ordered alphabetically (see Module © for more detzils an the dis-
inction bebween variable names and variable lahels),

Resetting outpul lnbels

The secand change we want to make o the SPSS default seblings relates ta the outoutf ar resills
of our analysis. In general, we wanl our results te cantain as much information as pozsible about
the variables we used. We therefore need Lo change the outpul settings in SP55 so that our oul-
put includes the variable names and labels and alsa the gibevony codes fvalues) and their Tabele,

Click on Bdit to open up the Edit drop-down menu (see Figure 0.3 again) and select
Options 25 before,

This time, hawever, we need to dick on the Cutput Labels tab in the Orptions dialog box
and then change the seftings in the four baxes to either Names and Labels or Values and
Labels (see Figure (0.5),

These adjustments ko the output labels will take effect immediately, and when you come to
produce your first frequency table (see Badule 2) your cutpul should contain not just Hye



Houndsmill, Palgrave.

ts

is

ial Scient

SPSS for Soc

MILLER, Robert L. et all. 2002.

[

18 SPSS _un__u.,.mcﬁt..__. SCIEMTISTS L

Flgure 0.4 Edit Options: General dalog box

Click on General
Click on Alphabetical and Display names

|

S| Cuitency - || seils:
- DraitViewsi ' | -Outgut Labels |- Chale Inkeractive

wariable names and category codes, but also a description of what these represent (ie. variable
and value labels).

Loading a data file

S far wetinve been looking at a Data Editor window which contains no data! There are two
main ways of rectifying this siluation. The Frst is to create a data Ale by inputting your own
data (this process will be examined in detail in Module 1), while the alternative option is to
open a previously created SPSS data file. Here we will go through the steps far opening an

already existing SPSS data file, the Crime dataset.
First, click on File from the Menu bar and then on Open from the drap-down menu that

appears (see Figure 0u6). This will give you the option of opening different types of files. As
we want to open a data file, click on Data.

. ORIEMTATION 19

Figure 0.5  Edit: Options: Output Labels dialog box
Click an Output Labels

Selact Names and Labels! Values and Labels

: )it Dale : Cumency - . w Scripts
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This will bring up the Open File dialog box (see Figure 0.7). You now need to select the
appropriate location of the SPSS file you wish to open (the relevant drive and falde),

For example, | have saved the British Social Attitudes Crime dataset (BSACrime) in a falder
entitled SPS5. To open this dataset T simply locate the SPSS folder and double click an
BSACrime, as illustrabed in Figure Q.7

After a few moments the Data Bditor window will reappear, but this ime complete with. the
Crime data from the British Social Allitudes Survey (see Figure O.8). It is impartant to note
that the Data Editor provides bwo different views of the data, the Data View and the Variable
WView, The Data View displays the actual data values {or value labels) in a spreadsheet format,
while the Variable View displays variable information including variable and value labels, level -
of measurement and missing values (see Module 1 for more details on thesel. You can switch
belween these bwa views by clicking the Data View and Variable View buttons at the bot-
tam left-hand corner of the screen (see Figure (0.8).



