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Manual pro analyzu dat v softwaru STATISTICA

Software STATISTICA je produkt StatSoft, Inc. (www.statsoft.com, www.statsoft.cz). STATISTICA je
dostupné v ramci MU z https://inet.muni.cz/auth/login (login stejny jako do www.is.muni.cz, seznam
dostupnych softwar( Ize najit v oddilu Provozni sluzby).

Nacteni datového souboru

File -> Open -> vybrat datovy soubor -> Open -> Import selected sheet to a Spreadsheet -> vybrat list
Excelovského souboru -> OK -> nechat zatrzené Get variable names from first row -> OK -> Import as
Text Labels

UlozZeni datového souboru
File -> Save -> zadame néazev souboru -> Save

Zapnuti automatického filtru

Oznacit vsechny sloupce (napi. pomoci CTRL+A nebo kliknutim do levého horniho rohu tabulky) ->
Data -> Auto Filter -> Auto Filter

1. Vizualizace dat
Vytvareni graf( pomoci zalozky Graphs.

Kolacovy graf

Graphs -> 2D Graphs -> Pie Charts -> zvolit proménnou (napr. Gender) (v zaloZce Advanced je mozné
zvolit, jakou legendu, typ a tvar grafu chceme (Pie Legend, Type, Shape) -> OK

Po dvojim kliknuti na graf se nam ukaZe okno Graph Options, kde Ize libovolné ménit barvu grafu i typ
a tvar grafu a dalSi parametry

Sloupcovy graf (na ose y pocty lidi)
Graphs -> Histograms -> Variables -> zvolit proménnou (nap¥. Group) -> OK -> zrusit zatrZeni Fit type:
Normal -> na zaloZce Advanced zatrhnout Breaks between columns -> OK

Sloupcovy graf (na ose y procenta)

Graphs -> Histograms -> Variables -> zvolit proménnou (napf. Group) -> OK -> zrusit zatrZeni Fit type:
Normal -> na zalozZce Advanced zatrhnout Breaks between columns -> na zalozce Advanced zménit u
Y axis hodnotu N na % -> OK

Histogram (na ose y procenta)

Graphs -> Histograms -> Variables -> zvolit proménnou (napf. Age) -> OK -> na zaloZce Advanced
zménit u Y axis hodnotu N na % (lze napf. si vypsat i zdkladni popisnou statistiku zatrhnutim
Descriptive statistics) -> OK

Krabicovy graf (s vykreslenim odlehlych hodnot)

Graphs -> 2D Graphs -> Box Plots... -> Variables -> zvolit proménnou (napr. Age) jako Dependent
variable -> OK -> OK

Krabicovy graf (s minimem a maximem)

Graphs -> 2D Graphs -> Box Plots... -> Variables -> zvolit proménnou (napr. Age) jako Dependent
variable -> OK -> na z&loZce Advanced -> u Whisker zvolit Min-Max -> u Outliers zvolit Off -> OK
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2. Priprava dat pro analyzu

Nastaveni formatu u MMSE na double
Dvakrat kliknout na Sedé policko s ndzvem proménné -> nastavit Type na Double -> nastavit Display
format na Number -> OK

Nastaveni formatu u scan_date na datum
Dvakrdt kliknout na sedé policko s ndzvem proménné -> nastavit Display format na Date -> vybrat
format 17/03/10 -> OK

Identifikace a odstranéni duplikaci

Data -> Data Filtering/Recoding -> Filter Duplicate Cases -> Input: Variables -> ID -> OK -> u Output
zatrhnout Create duplicates spreadsheet -> OK

Je patrné, Ze se vZdy zachovad prvni zdznam a druhy zdznam je vyrazen bez ohledu na datum porizeni
skenu. Pokud chceme, aby byl vZdy odstranén zdznam se starsim datem, je nejprve nutné data serfadit
podle data pofizeni skenu (sestupné) pomoci: Data -> Sort -> oznacit 1-ID -> Add Var(s) -> oznacit
30-scan_date -> Add Vars(s) -> Descending -> OK -> Include Formatting

Novy datovy soubor bez duplikaci uloZit.

Odstranéni chybéjicich a chybnych hodnot

Data -> Subset -> Cases -> zatrhnout Enable Selection Condition-> do By expression napsat v4="" OR
v4>110 OR v7=""-> 0K -> OK

Novy datovy soubor bez chybéjicich a chybnych hodnot uloZit.

Rekddovani proménné Gender, aby obsahovala pouze hodnoty Fa M

1. zplsob — ruéné: Vyfiltrovat si Faddek s hodnotou FF a hodnotu FF prepsat na F

2. zplGsob — vytvorenim nové proménné: Oznacit proménnou za proménnou Gender -> Insert -> Add
Variables -> Name -> zadat ndzev nové proménné (napf. Gender_rek) -> do Long name napsat
=iif(v3="FF","F",v3) -> OK

Rekdédovani proménné Group, aby obsahovala pouze hodnoty 1 (CN), 2 (MCI) a 3 (AD)
Oznacit proménnou za proménnou Group -> Insert -> Add Variables -> Name -> zadat nazev nové
proménné (napr. Group_3Kkat) -> do Long name napsat =iif(v2=3;2;iif(v2=4;3;v2)) -> OK

Jiny zplsob pomoci Data -> Recode...

Vytvoieni textovych popiski u kvalitativni proménné
Dvakrat kliknout na Sedé policko s ndzvem proménné -> Text Labels...-> zadat textové popisky a jejich
prislusné c¢iselné hodnoty -> OK -> OK

3. Popisna sumarizace dat
Popisna sumarizace dat pomoci Statistics -> Basic Statistics/Tables. Obecny popis dialogového okna
pro sumarizaci dat, vizualizace a dalSi analyzy je uveden na Obr. 1.

Popisna sumarizace kvalitativnich dat — frekven¢ni tabulka
Statistics -> Basic Statistics/Tables -> Frequency tables -> Variables -> zvolit proménnou (napr. Group)
-> OK -> Summary

Popisna sumarizace kvantitativnich dat

Statistics -> Basic Statistics/Tables -> Descriptive statistics -> Variables -> zvolit proménnou (napfr.
Age) -> OK -> na zalozce Advanced zatrhnout Median, Coefficient of variation, Lower & upper
quartiles -> Summary
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Obr. 1. Popis dialogového okna slouziciho pro sumarizaci, vizualizaci a dal$i analyzy dat.

Popisna sumarizace Kkvantitativnich dat — zapnuti filtru (vyfiltrovani poslednich 20
pacientii)

Statistics -> Basic Statistics/Tables -> Descriptive statistics -> Variables -> zvolit proménnou (napfr.
Height a Height_cor) -> OK -> Select Cases -> Enable Selection Conditions -> Specific, selected by: ->
do “or case number” zadat 814-833 -> OK -> na z&loZce Advanced zatrhnout Median -> Summary

4. Transformace dat

Logaritmicka transformace

Oznacit proménnou za proménnou, kterou chceme logaritmovat -> Insert -> Add Variables -> Name ->
zadat ndzev nové proménné (napr. Weight_log) -> do Long name napsat =Log(v9) (Pozor, v softwaru
STATISTICA je pfirozeny logaritmus oznacen jako Log(X) misto Ln(x)!) -> OK

Standardizace dat
Oznacit proménnou za proménnou, kterou chceme standardizovat -> Insert -> Add Variables -> Name

-> zadat ndzev nové promenné (napf. Age_st) -> do Long name napsat =v6 -> OK -> Data ->
Standardize... -> OK
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Centrovani dat

Oznacit proménnou za proménnou, kterou chceme centrovat-> Insert -> Add Variables -> Name ->
zadat ndzev nové proménné (napf. Height centr) -> do Long name napsat =v9-174.15 (pramér
vypocitany pomoci Descriptive statistics) -> OK

Kategorizace

Oznacit proménnou za proménnou, kterou chceme kategorizovat -> Insert -> Add Variables -> Name -
> zadat ndzev nové proménné (napr. Age_kat) -> OK -> Data -> Recode... (zkontrolovat si, Ze v zahlavi
je sprdvny ndzev proménné, jinak vybrat spravnou proménnou pomoci tlacitka Variable...) -> zadat
podminky a nové hodnoty (viz Obr. 2) -> OK

Recode Values of Variable 7: Age_kat @
Category 1 Mew Walue 1

Include If: - @ value: 1
C. |
W] MD code w

. Clearal
Category 2 MHew Walue 2 =ar 8
Include If: - @ value: 2 = Open.

wB=R0 AND wE< 70 MD code SaveAs...
Categony 3 Mew Walue 3 @ Yariahle. ..
Include If: - 9 value: 3
Other
wBr=70 AND wE< B0 MD code
If no conditions are met, s=t valuss to
Category 4 MHew Walue 4
— 7 MD code
Include If: - @ vale: 4
value:
wE»=R0 MD code

@ unchanged

-

Obr. 2. Ukazka kategorizace véku.

5. Intervaly spolehlivosti

Vypocet intervalu spolehlivosti a stiredni chyby pruméru (standard error)

Statistics -> Basic Statistics/Tables -> Descriptive statistics -> Variables -> zvolit proménnou (napf.
Age) -> OK -> na zaloZce Advanced zatrhnout Conf. limits for means a Std. err. of mean -> Summary

Vypocet kvantili Studentova rozlozeni

Statistics -> Probability Calculator -> Distributions... -> t (Student) -> zatrhnout Inverse -> jako p zadat
0.975 -> jako df (degrees of freedom — pocet stupfid volnosti) zadat 832 -> Compute (vypocitd ndm to
hodnotu t)

6. Uzite¢na nastaveni

Vypnuti automatického prekreslovani grafi

File -> Output Manager -> Graphs -> Settings -> Data Update prepnout na Locked -> zrusit zatrZzeni u
Update spreadsheet case states -> OK
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7. Vypocet velikosti vzorku a power analyza

Vypocet velikosti vzorku

Statistics -> Power Analysis -> Sample Size Calculation -> zvolit typ vypoctu podle typu naseho
experimentu, ktery budeme chtit provést (napf. Two Means, t-Test, Ind. Samples) -> OK -> nastavit
parametry a zvolit typ hypotézy (napf. viz Obr. 3 — Pozor! Zadavame typ nulové hypotézy, tedy
zadavame opak toho, co chceme prokazat!) -> OK -> Calculate N

Nl Independent Sample t-Test: Samp... @

Cluick | Settings [/0 | oK
Fixed Parameters
Mut: ss0 £
Mu2: o [
Aipha: s
Sigma: 500 El
Power Goal:  0.50 EI

Type of Hypothesis

1 2ailed { Mul = Mu2 )
1 14ailed ( Mul == Mu2 )
@ 14ailed ( Mul == Mu2 )

Obr. 3. Ukazka nastaveni parametrd u vypoctu velikosti vzorku.

Power analyza

Statistics -> Power Analysis -> Power Calculation -> zvolit typ vypoctu podle typu naseho experimentu,
ktery budeme chtit provést (napr. Two Means, t-Test, Ind. Samples) -> OK -> nastavit parametry a
zvolit typ hypotézy (napr. viz Obr. 4 — Pozor! Zadavame typ nulové hypotézy, tedy zaddvame opak
toho, co chceme prokazat!) -> OK -> Calculate Power

"

%Independent Sample t-Test: Power Calc. Parameters: Data_...| T || £3 |

Gluick | Settings [/0 |

oK
Fixed Parameters
mal: 6300 [4] =
Mz 7000 [
N 1o @ Type of Hypothesis
Ne 1o EI ) 2ailed { Mul = Mu2)
Apha: 005 (3] ) 14ailed ( MuT <= Mu2)
Sgma: 500 [ & 1sied (Mul 3= Mu2)

Obr. 4. Ukazka nastaveni parametrd u power analyzy.
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8. Statistické testy pro kvantitativni data — parametrické testy

Jednovybérovy t-test

Statistics -> Basic Statistics/Tables -> t-test, single sample -> OK -> zvolit proménnou (napr.
Hippocampus_volume (mma3)) -> OK -> Test all means against: 6575 -> na zalozce Options zatrhnout
Compute conf. limits -> Summary

Parovy t-test

Statistics -> Basic Statistics/Tables -> t-test, dependent samples -> OK -> zvolit proménné (napr.
Hippocampus_volume (mm3) jako First variable a Hippocampus_volume_24 (mm3) jako Second
variable) -> OK -> Summary

Dvouvybérovy t-test

Statistics -> Basic Statistics/Tables -> t-test, independent, by groups -> OK -> zvolit proménné (napfr.
Putamen_volume (mm3) jako Dependent variable a Gender_rek jako Grouping variable) -> na
zaloZce Options Ize zvolit Levene’s test (test homogenity rozptyld) a Cl for estimates -> Summary

Analyza rozptylu (ANOVA) a post-hoc testy — 1. zpiisob

Statistics -> Basic Statistics/Tables -> Breakdown & one-way ANOVA -> OK -> zvolit proménné (napr.
Hippocampus_volume (mm3) jako Dependent variable a Group_3kat jako Grouping variable) -> OK
-> OK -> na zaloZce ANOVA & tests kliknout na Analysis of Variance (vypiSe ANOVA tabulku); dale Ize
vypsat i vysledky testi homogenity rozptyli: Levene tests, Brown-Forsythe test -> na zaloZce Post-hoc
kliknout na Tukey honest significant difference (HSD) (v pfipadé vyrovnanych poctu subjekti ve
skupinach), Tukey HSD for unequal N (v pfipadé nestejnych poltiu subjekti ve skupindch) nebo
Scheffé test (pro stejné i nestejné pocty subjekti ve skupindch)

Analyza rozptylu (ANOVA) a post-hoc testy — 2. zpiisob

Statistics -> ANOVA -> One-way ANOVA -> OK -> zvolit proménné (napr. Hippocampus_volume (mm3)
jako Dependent variable a Group_3kat jako Categorical predictor (factor)) -> OK -> OK -> All effects
(vypise ANOVA tabulku; prvniho Fddku s interceptem si nevs§imdme) -> More results -> na zaloZce
Post-hoc kliknout na Tukey HSD (pro stejné pocty subjekti ve skupindch), Unequal N HSD (pro
nestejné pocty subjekti ve skupindch) nebo Scheffé (pro stejné i nestejné pocty subjekti)

9. Statistické testy pro kvantitativni data — neparametrické testy

Wilcoxontiiv test — jednovybérovy

STATISTICA neumoZiiuje pocitat jednovybérovy Wilcoxonuv test primo. Je nutné nejprve vytvorit
novou proménnou, kterd bude mit ve vsech rddcich hodnotu, se kterou chceme srovndvat nase data:
Insert -> Add Variables -> Name -> zadat ndzev nové proménné (napr. mmse_konst) -> do Long nhame
napsat =27,5 (hodnota konstanty, se kterou chceme srovnavat) -> OK

Poté muZeme pouZit pro vypocet pdrovy Wilcoxoniyv test: Statistics -> Nonparametric -> Comparing
two dependent samples (variables) -> OK -> zvolit proménné (napf. MMSE jako First variable a
mmse_konst jako Second variable) -> OK -> Wilcoxon matched pairs test

(Je mozZné vypocitat i znaménkovy test (Sign test), ktery je téZ neparametrickou alternativou parového
t-testu.)

Wilcoxoniiv test — parovy

Statistics -> Nonparametric -> Comparing two dependent samples (variables) -> OK -> zvolit
proménné (napf. MMSE jako First variable a MMSE_24 jako Second variable) -> OK -> Wilcoxon
matched pairs test
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(Je mozZné vypocitat i znaménkovy test (Sign test), ktery je téZ neparametrickou alternativou parového
t-testu.)

Manniv-Whitneyiiv test

Statistics -> Nonparametric -> Comparing two independent samples (groups) -> OK -> zvolit
proménné (napr. Hippocampus_volume (mm3) jako Dependent variable list a Gender_rek jako Indep.
(grouping) variable) -> OK -> M-W U test

KruskalGv-Wallisiv test

Statistics -> Nonparametrics -> Comparing multiple indep. samples (groups) -> OK -> zvolit proménné
(napr. MMSE jako Dependent variable list a Group_3kat jako Indep. (grouping) variable) -> OK ->
Summary (vypiSe vysledky Kruskalova-Wallisova testu) -> Multiple comparisons of mean ranks for all
groups (vypiSe vysledky post hoc analyzy)

10.0véreni predpokladu statistickych testi

Vykresleni Q-Q grafu pro jednotlivé skupiny

Graphs -> 2D Graphs -> Normal Probability Plots... -> zvolit proménnou (napr. Hippocampus_volume
(mm3)) -> By Group -> Grouping Variable(s) -> vybrat proménnou (napt. Gender_rek) -> OK ->
zatrhnout Output to a single folder -> pfepnout Sorting of Groups na Ascending -> OK -> Ize zatrhnout
Shapiro-Wilk test (test normality dat) -> OK

Ovéreni normality pomoci Basic Statistics/Tables pro jednotlivé skupiny

Statistics -> Basic Statistics/Tables -> Descriptive statistics -> Variables -> zvolit proménnou (napfr.
Hippocampus_volume (mm3)) -> OK -> na zaloZce Advanced zatrhnout Median (to ted’ neni nutné) ->
By Group -> Grouping Variable(s) -> vybrat proménnou (napf. Gender_rek) -> OK -> zatrhnout Output
to a single folder a Accumulate tabular results in a single spreadsheet -> OK -> pfepnout Sorting of
Groups na Ascending -> OK -> na zalozce Normality zatrhnout Shapiro-Wilk’'s W test -> Frequency
tables -> na zalozce Prob. & Scatterplots Ize nechat vykreslit Normal probability plot (tzn. Q-Q graf)

Ovéreni normality pomoci Histograms... pro jednotlivé skupiny

Graphs -> Histograms -> Variables -> zvolit proménnou (napf. Hippocampus_volume (mm3)) -> OK ->
na zaloZce Advanced zmeénit u Y axis hodnotu N na %, zatrhnout Shapiro-Wilk test a Kolmogorov-
Smirnov test -> By Group -> Grouping Variable(s) -> vybrat proménnou (napf. Gender_rek) -> OK ->
zatrhnout Output to a single folder a Accumulate tabular results in a single spreadsheet -> OK ->
prepnout Sorting of Groups na Ascending -> OK -> OK

11.Dalsi uzitecné prikazy

Vykresleni teckového grafu

Graphs -> Scatterplots -> zvolit proménné (napf. Hippocampus volume (mm3) jako X a
Hippocampus_volume_24 (mm3) jako Y -> na zaloZce Advanced mdiZeme zatrhnout Corr. and p
(linear fit) -> OK

Popisna sumarizace kvantitativni proménné podle kategorii kvalitativni proménné
Statistics -> Basic Statistics/Tables -> Descriptive statistics -> Variables -> zvolit proménnou (napr.
Hippocampus_volume (mm3)) -> OK -> na zalozce Advanced zatrhnout Median -> By Group ->
Grouping Variable(s) -> vybrat proménnou (napr. Gender_rek) -> OK -> zatrhnout Output to a single
folder a Accumulate tabular results in a single spreadsheet -> OK -> prepnout Sorting of Groups na
Ascending -> OK -> Summary
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Vytvoreni $ablony graft

Upravit si graf do finalni podoby -> 2x kliknout do grafu -> Styles... -> More -> 2x kliknout na Graph
(aby se cely ten strom zavrel) -> kliknout na tlacitko s tfemi teckami -> Save as -> pojmenovat graf ->
Save -> Close -> OK

Uprava grafu podle $ablony
2x kliknout do grafu -> Styles... -> More -> 2x kliknout na Graph (aby se cely ten strom zavrel) ->
otevrit rozbalovaci nabidku s typy grafu -> zvolit Sablonu -> Edit -> Close -> OK

12.Analyza kontingenc¢nich tabulek

Kontingen¢ni tabulka absolutnich ¢etnosti
Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napr. Group_3kat do List 1 a Age_kat do List 2)-> OK -> OK -> Summary

Kontingen¢ni tabulka procent

Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napr. Group_3kat do List 1 a Age_kat do List 2)-> OK -> OK -> na zéloZce Options zatrhnout
Percentages of row counts, Percentages of column counts nebo Percentages of total count ->
Summary

Kontingen¢ni tabulka — o¢ekavané cetnosti

Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napf. Group_3kat do List 1 a Age_kat do List 2)-> OK -> OK -> na zaloZce Options zatrhnout Expected
frequencies-> Summary

Pearsontiv chi-kvadrat test

Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napf. Group_3kat do List 1 a Age_kat do List 2)-> OK -> OK -> na zaloZce Options zatrhnout Pearson
& M-L Chi-square -> na zaloZce Advanced kliknout na Detailed two-way tables

Fishertv exaktni test

Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napf. Gender do List 1 a mmse_kat do List 2)-> OK -> OK -> na zaloZce Options zatrhnout Fisher
exact, Yates, McNemar -> na zaloZce Advanced kliknout na Detailed two-way tables

McNemaruv test

Statistics -> Basic Statistics/Tables -> Tables and banners -> OK -> Specify tables (select variables)
(napf. mmse_kat do List 1 a mmse24_kat do List 2)-> OK -> OK -> na zaloZce Options zatrhnout Fisher
exact, Yates, McNemar -> na zalozce Advanced kliknout na Detailed two-way tables
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13. Testy binomickych dat

Jednovybérovy binomicky test

Ptiklad: Mezi 50 pacienty s Alzheimerovou chorobou je 12 pacientli s MMSE skére nizSim neZ dana
hranice. Ovérte, zda podil pacientl s nizsim skdre je stejny jako v bézné populaci (v bézné populaci
uvazujte, Ze 5% lidi ma hodnoty nizsi nez hranice).

Statistics -> Basic Statistics/Tables -> Difference tests: r, %, means -> Difference between two
proportions -> zadat pravdépodobnosti a pocty subjekti (viz Obr. 5 vlevo) -> Two-sided -> Compute
(dostaneme p-hodnotu)

L Diference tests: 1, %, means: Data_neuro vycistena3 |- & [[ukm]| _<n Difference tests: r, % means: DMdata - final - do Statificy | & [sie]
Rk it Fot weh Conoche 1o Flscoet vad [ic ] Sand/prird rezults for each Compute bo Rleport vand [wEu-:dw:i
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e 1. - T r=y P 1.0000
2 000 B MZ10 =) BT A0 @ Tworsided 12 0,00 [:j HZ 10 i' @ Two-sided
Difference betawen tro eeans [romal dayibuation) Diffeterce batvesen lwo means [rermal distibubon)
| =l ) = i -l
M1 0 = BT (B M0 P 10000 | Compute | M1 0 Elﬁ'ﬂvl 1 EI'”'IE [= P 1.0000 Compule |
MZ O Hsovz EHuzw .';i One-sided MZ 0 [ sovaz 1 Huzo 4 Er-e:-jm
Single mean 1 v& populaion mean 2 A v eiied Single mean 1 v3 popubslion mean 2 8 Tonrarded
Ty e —— Diffetence batwsan hed propoetcns
Pt 2e000cfE nise Dine<ided | Compute | ) A AN 2 E 50 Ore-sided | Cofopnde |
P2 ool w2 wwr @° ® Two-sided P2 saofg w2 W S rersting
Co nejwltsi N2 Vypoitend p-hodnota Vypoftend p-hodnota

Obr. 5. Ukazka zadavani parametr( v jednovybérovém (vlevo) a dvouvybérovém binomickém testu
(vpravo).

Dvouvybérovy binomicky test

Ptiklad: Mezi 42 pacienty s Alzheimerovou chorobou (AD) je 11 pacientll s MMSE skére nizsim nez
dana hranice. Mezi 18 pacienty s mirnou kognitivni poruchou (MCl) je 6 pacientd s MMSE skére
nizsim nez dana hranice. Ovérte, zda se podily pacient( s nizsim skdre u pacient s AD a MCI lisi.
p;=11/42=0,262 a p,=6/18=0,333

Statistics -> Basic Statistics/Tables -> Difference tests: r, %, means -> Difference between two
proportions -> zadat pravdépodobnosti a pocty subjekti (viz Obr. 5 vpravo) -> Two-sided -> Compute
(dostaneme p-hodnotu)

14.ROC analyza

I.  Vytvofeni proménné mmse_neg (mmse_neg=-mmse), protoZe je nutné, aby hodnoty skore pro
kontrolni subjekty byly mensi nez hodnoty pro pacienty.

Il. Statistics -> Advanced Linear/Nonlinear Models -> Generalized Linear/Nonlinear Models -> Logit
model -> OK -> zvolit proménné (group_01_CnMci jako Dependent variable a mmse_neg jako
Continuous predictor -> zvolit Response codes (zadat hodnoty: 1 0 (je nutné to mit v tomto
poradi, aby byla sprdvné vypocitana senzitivita a specificita; 1 znaci rizikovou skupinu, 0
kontrolni skupinu)) -> OK -> OK -> na z&lozZce Resid. 1 kliknout na ROC Curve (vykresli se graf s
ROC k¥ivkou a AUC)

Ill.  Pro zjisténi cut-off (nejlepsiho déliciho bodu) je nutné nejdrive vypsat frekvencni tabulku hodnot
spojité proménné: Statistics -> Basic Statistics/Tables -> Frequency Tables -> zvolit proménnou
(napf. mmse_neg) -> Summary

IV. Vyslednou tabulku je nutné zkopirovat do Excelu: kliknout na levy horni roh tabulky (tim se cel&
tabulka oznaci) -> kliknout do tabulky pravym tla¢itkem mysi -> Copy with headers -> vloZit do
Excelu -> seradit podle hodnot prvniho sloupce sestupné
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V. Do Excelu za tuto tabulku ptikopirovat tabulku, ktera byla vytvorena jako vysledek ROC analyzy

VI. V Excelu spocitat specificitu (tzn. udélat 1-(sloupecek s 1-Specificity)) a pak spocitat soucet
senzitivity a specificity -> vybrat fadek s nejvétsi hodnotou souctu senzitivity a specificity

VIl. Vytvoreni kategorizovaného MMSE skére svyuZitim cut-off: Insert -> Add Variables ->
pojmenovat novou proménnou (napf. mmse_kat) a do Long name napsat =iif(v14<-28;0;1) -> OK

VIIl. Ovéreni vypocitané senzitivity a specificity: Statistics -> Basic Statistics/Tables -> Tables and
banners -> OK -> Specify tables (select variables) (napf. mmse_kat do List 1 a group_01_CnMci
do List 2)-> OK -> OK -> na zalozce Options zatrhnout Percentage of column counts -> Summary
(senzitivita je tady procento v pravém dolnim rohu, specificita je procento v levém hornim rohu
— zAleZi ale na nakodovani dat a v Listu 1 musi byt vysledek diagnostického testu a v Listu 2
skutecnost)

15.Korelacni analyza

Bodovy graf (“Scatterplot”)

Graphs -> Scatterplots... -> zvolit proménné (napf. Putamen_volume (mm3) jako X a
Amygdala_volume (mm3) jako Y -> OK -> na zaloZce Advanced Ize zatrhnout Corr. and p (linear fit)
(vypocita Pearsonuv korelacni koeficient a p-hodnotu) a R square (linear fit) -> OK

Vypocet Pearsonova korelacniho koeficientu

Statistics -> Basic Statistics/Tables -> Correlation matrices -> OK -> One variable list -> zvolit
proménné (napr. Amygdala_volume (mm3) a Putamen_volume (mm3)) -> na zaloZce Options zvolit
Display r, p-values, and N’s -> Summary

Srovnani dvou korela¢nich koeficientu

Statistics -> Basic Statistics/Tables -> Difference tests: r, %, means -> OK -> zadame hodnoty
korelacniho koeficientu a pocet subjekti obou vybéri -> Compute (spocitd ndm to p-hodnotu)

Vypocet Spearmanova korela¢niho koeficientu (vypocet ¢tvercové korela¢ni matice)

Statistics -> Nonparametrics -> Correlation (Spearman, Kendall tau, gamma) -> OK -> zvolit proménné
(napr. MMSE a Hippocampus_volume (mm3)) -> OK -> Spearman rank R

Vypocet Spearmanova Korelacniho koeficientu (vypocet detailni tabulky)

Statistics -> Nonparametrics -> Correlation (Spearman, Kendall tau, gamma) -> OK -> zvolit Detailed
report (misto Square matrix) -> zvolit proménné (napf. MMSE do First variable list a
Hippocampus_volume (mm3) do Second variable list) -> OK -> Spearman rank R

16.Regresni analyza

Linearni regrese a odstranéni vlivu kovariat
Statistics -> Multiple Regession -> zvolit proménné (napr. Nucl_caud_volume (mm3) jako Dependent
var., Age a gender_01,... jako Independent variables) -> OK -> OK -> Summary: Regression results
(vypiSe regresni koeficienty a p-hodnoty) -> OK
- Vykresleni Q-Q grafu pro rezidua: kliknout na Normal plot of residuals
- Vykresleni histogramu rezidui: na zalozce Residuals kliknout na Histogram of residuals
(vpravo Ize zvolit, zda chceme vykreslit histogram rezidui ¢i standardizovanych rezidui)
- Vykresleni bodového grafu predikovanych hodnot a rezidui: na zaloZce Scatterplots kliknout
na Predicted vs. residuals
- UloZeni rezidui: na z&loZce Save kliknout na Save residuals & predicted -> zvolit proménné,
které bude nové vytvorend tabulka ddle obsahovat -> OK

10



al lH.l Autor: RNDr. Eva Janou$ova
IBA Institut biostatistiky a analyz, Masarykova univerzita, Brno

17.Analyza preziti

Kaplantv-Meierav odhad funkce preziti pro jeden vybér
Statistics -> Advanced Linear/Nonlinear Models -> Survival Analysis -> Kaplan & Meier product-limit
method -> OK -> zvolit proménné (napr. cas jako Survival times a umrti jako Censoring indicator) ->
OK -> Code for complete responses: 1 -> Code for censored responses: 0 -> OK
- Vykresleni krivky preziti: kliknout na Survival times vs. cum. proportion surviving
- Vypsani tabulky pro vypocet x-letého preziti: kliknout na Summary: Product-limit survival
analysis
- Vypsani tabulky s medianem preziti: na zaloZzce Advanced kliknout na Percentiles of survival
function

Kaplantv-Meieriav odhad funkce preziti pro dva vybéry

Statistics -> Advanced Linear/Nonlinear Models -> Survival Analysis -> Comparing two samples -> OK
-> zvolit proménné (napr. cas jako Survival, umrti jako Censoring var, Skupina jako Grouping variable)
-> OK -> Code for complete responses: 1 -> Code for censored responses: 0 -> zkontrolovat, jestli
kategorie grupovaci proménné jsou v poradi, jaké chceme -> OK

- Vykresleni k¥ivek preziti: na zalozce Function plots kliknout na Cum. prop. surviving by group
(Kaplan Meier)

- Vypocet testu na srovnani preZiti ve skupinach: na zalozce Quick kliknout na Gehan’s
Wilcoxon test nebo Log-rank test (p-hodnota je v zahlavi tabulky)

- Vypsani tabulky pro vypocet x-letého preziti: na zaloZce Two-sample tests kliknout na
Proportion surviving by group (nevypisuje se ale stfedni chyba nutna pro vypocet interval(
spolehlivosti a nevypocitd se median preziti — je nutné tyto Udaje pocitat pro kazdou krivku
zvlast pomoci Kaplanova-Meierova odhadu funkce pfeziti pro jeden vybér (postup viz vyse))

Kaplantv-Meieriv odhad funkce preziti pro tfi a vice vybéra
Statistics -> Advanced Linear/Nonlinear Models -> Survival Analysis -> Comparing multiple samples ->
OK -> zvolit proménné (napf. cas jako Survival, umrti jako Censoring var, Skupina jako Grouping
variable) -> OK -> Code for complete responses: 1 -> Code for censored responses: 0 -> Codes (for
groups) -> All (kdyZtak zménit porfadi kategorii podle toho, jak potfebujeme) -> OK -> OK
- Vykresleni kfivek preziti: kliknout na Cumulative proportion surviving (Kaplan-Meier) by
group
- Vypocet testu na srovnani preziti ve skupindch: kliknout na Summary: Survival times & scores
(p-hodnota je v zahlavi tabulky)
- Vypsani tabulky pro vypocet x-letého preziti: na zaloZce Advanced kliknout na Percent
surviving by group (nevypisuje se ale stfedni chyba nutna pro vypocet interval(l spolehlivosti
a nevypocita se medidn preZiti — je nutné tyto udaje pocitat pro kazdou kfivku zvlast pomoci
Kaplanova-Meierova odhadu funkce preZiti pro jeden vybér (postup viz vyse))

Coxtiv model proporcionalnich rizik

Statistics -> Advanced Linear/Nonlinear Models -> Cox Proportional Hazards Model -> zvolit
proménné (napf. OS_doba_mesice jako Survival, ECOG1 jako Covariates, Umrti jako Censoring
variable) -> OK -> Code for complete responses: 1 -> Code for censored responses: 0 -> OK ->
Parameter estimates

Podékovani

Pfiprava vyukovych materidll pfedmétu ,,DSANO1 Analyza dat pro Neurovédy “ byla financéné
podporovana prostiedky projektu FRVS & 942/2013 ,Inovace material(i pro interaktivni vyuku a
samostudium predmétu Analyza dat pro Neurovédy”.
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