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Manual pro analyzu dat v softwaru SPSS

Software SPSS je produkt IBM (http://www.ibm.com/analytics/us/en/technology/spss/). SPSS je
dostupné v ramci MU z https://inet.muni.cz/auth/login (login stejny jako do www.is.muni.cz, seznam
dostupnych softwar( Ize najit v oddilu Provozni sluzby -> Software).

Nacteni datového souboru

File -> Open -> Data -> vybrat datovy soubor -> pokud naclitdme excelovsky soubor, nezapomenout
zmeénit Files of type na Excel (*.xls, *.xlsx, *.xIsm) -> Open -> ve Worksheet vybrat poZadovany list
excelovského souboru -> nechat zatrZzené Read variable names from first row of data -> OK

UloZeni datového souboru
File -> Save as -> zadat ndzev souboru -> Save

1. Vizualizace dat
Vytvareni grafl pomoci zalozky Graphs.

Kolacovy graf

Graphs -> Legacy Dialogs -> Pie -> Summaries for groups of cases -> Define -> Define Slices by: zvolit
proménnou (napr. Gender) -> OK

Pozn.: Po dvojim kliknuti na graf se ndm ukdZe okno Chart Editoru, kde Ize pfidat ndzev grafu (Options
-> Title), ménit barvu Ci ohraniceni grafu a upravovat Ci nastavovat dalsi parametry

Sloupcovy graf (na ose y pocty lidi)
Graphs -> Legacy Dialogs -> Bar -> Nechat zatrZené Simple a Summaries for groups of cases -> Define
-> Category Axis: zvolit proménnou (napr. Group) -> OK

Sloupcovy graf (na ose y procenta)
Graphs -> Legacy Dialogs -> Bar -> Nechat zatrZzené Simple a Summaries for groups of cases -> Define
-> Category Axis: zvolit proménnou (napf. Group) -> misto N of cases zatrhnout % of cases -> OK

Histogram (na ose y pocty lidi)

Graphs -> Legacy Dialogs -> Histogram -> Variable: zvolit proménnou (napr. Age) -> OK

Pozn.: Ddle Ize zatrhnout Display normal curve a Ize vykreslit histogramy podle kategoridini proménné
tim, Ze se kategoridlni proménnd pretdhne do Rows nebo Columns

Histogram (na ose y procenta)

Graphs -> Chart Builder -> OK -> Gallery: Histogram -> pfetdhnout poZadovany graf do okna vyse ->
poZadovanou proménnou (napr. Age) pretdhnout do pole X-Axis? pod grafem (viz. Obr. 1) -> Element
Properties -> Statistic: Histogram Percent -> pfipadné zaskrtnout Display normal curve -> Apply -> Close
-> 0K

Pozn.: Ddle Ize v Chart Builder vykreslit histogramy podle kategoridini proménné kliknutim na zdloZku
Groups/Point ID, zatrhnutim Rows panel variable nebo Columns panel variable a ddle pretdhnutim
vybrané kategoridlni proménné do policka Panel?

Krabicovy graf
Graphs -> Legacy Dialogs -> Boxplot -> Nechat zatrZené Simple a zatrhnout Summaries of separate
variables -> Define -> Boxes Represent: zvolit proménnou (napfr. Age) -> OK
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Obr. 1: Dialogové okno Chart editoru pro vytvoreni grafu
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2. Priprava dat pro analyzu

Nastaveni formatu u MMSE na numerickou proménnou

1. zpUsob: Prejit na Variable View a u vybrané proménné ve sloupci Type rozkliknout tlacitko se tremi
teckami -> zatrhnout Numeric -> OK -> u vybrané proménné prejit do sloupce Measure -> vybrat Scale

2. zplsob: Data -> Define Variable Properties -> Variables to Scan: zvolit proménnou (MMSE) ->
Continue -> Type: vybrat Numeric -> Measurement Level: vybrat Scale -> OK

Nastaveni formatu u scan_date na datum

1. zpusob: Prejit na Variable View a kliknout u vybrané proménné do sloupce Type -> zatrhnout Date ->
v pravém okné z nabidky vybrat format (napr. dd-mmm-yyyy)

2. zpUsob: Data -> Define Variable Properties -> Variables to Scan: zvolit proménnou (scan_date) ->
Continue -> Type: vybrat Date a formdt (napf. dd-mmm-yyyy) -> Measurement Level: vybrat napr.
Scale nebo Ordinal -> OK

Uprava poétu desetinnych mist u Weight
Prejit na Variable View a kliknout a nastavit Decimals napf. na hodnotu 1

Identifikace duplikaci

Data -> ldentify Duplicate Cases -> Define matching cases by: vybrat proménnou (ID) -> Sort within
matching groups by: vybrat proménnou (napf. scan_date) -> Sort: Ascending -> nechat zaskrtnuté
Indicator of primary cases a Last case in each group is primary -> Ize ponechat ndzev Name: PrimaryLast

Pozn.: Vysledkem je proménnd Primarylast, kterd primdrni zdznamy oznacuje hodnotou 1 a duplikatni
hodnotou 0. Je patrné, Ze jako primdrni je definovdn zdznam s nejnovéjsim datumem. Pokud chceme,
aby byl jako primdrni zdznam oznacen ten s nejstarsim datumem, tak zaskrtneme First case in each
group is primary -> Ize ponechat ndzev Name: PrimaryFirst

Odstranéni duplikaci:
Data -> Select cases -> zaskrtnout Use filter variable -> do okénka pretdhnout proménnou identifikujici
primdrni a duplikdtni zéznamy (napr. PrimaryFirst) -> zaskrtnout Delete unselected cases -> OK

Odstranéni chybéjicich a chybnych hodnot

Data -> Select cases -> zatrhnout If condition is satisfied -> kliknout na tlalitko If -> do okénka zapsat
podminky (napr. Age <110 & MISSING(Age)=0 & MISSING(Weight)=0) -> Continue -> zaskrtnout Delete
unselected cases -> OK

Reko6dovani proménné Gender, aby obsahovala pouze hodnoty F aM

1. zpUsob — ruc¢né: Najit si Fddek s hodnotou FF a hodnotu FF prepsat na F

2. zpUsob — vytvorenim nové proménné: Transform -> Recode into Different Variables -> do okénka
Input Variable pretdhnout proménnou Gender -> Name: zadat ndzev nové proménné (napf.
Gender_rek) -> Change -> kliknout na tlacitko Old and New Values -> v oddilu Old Value zadat Value:
FF -> zatrhnout Output variables are strings -> v oddilu New Value zadat Value: F -> Add -> v oddilu Old
Value zatrhnout All other values -> v oddilu New Value zatrhnout Copy old values -> Add -> Continue
-> 0K

3. zpUsob — pozménénim plvodni proménné: Transform -> Recode into Same Variables -> do okna
Variables pretdhnout proménnou Gender -> Old and New Values -> v sekci Old Value vepsat Value: FF
-> v sekci New Value vepsat Value: F -> Add -> Continue -> OK
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Rekddovani proménné Group, aby obsahovala pouze hodnoty 1 (CN), 2 (MCI) a 3 (AD)
Transform -> Recode into Different Variables -> do okénka Input Variable pretdhnout proménnou
Group -> Name: zadat ndzev nové proménné (napr. Group_3kat) -> Change -> Old and New Values ->
v oddilu Old Value zadat Value: 4 -> v oddilu New Value zadat Value: 3 -> Add -> v oddilu Old Value
zadat 3 -> v oddilu New Value zadat 2 -> Add -> v oddilu Old Value zatrhnout All other values -> v oddilu
New Value zatrhnout Copy old values -> Add -> Continue -> OK
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Obr. 2: Ukdzka rekddovani proménné do jiné proménné

Vytvoreni textovych popisku u kvalitativni proménné
Prejit do Variable View -> kliknout u prislusné proménné (Group_3kat) do okénka Value a
rozkliknout tlacitko se tremi teckami -> Value: 1, Label: CN -> Add -> Value: 2, Label: MCI -> Add
->Value: 3, Label: AD -> Add -> OK

Pozn. 1: Pri zaddvdni textovych popiski nepiSeme uvozovky, doplni se samy. 7

Pozn. 2: Hodnoty a testové popisky Ize pfepinat v hlavnim panelu pomoci tlacitka. ﬂ‘:?
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3. Popisna sumarizace dat
Popisnd sumarizace dat pomoci Analyze -> Descriptive Statistics

Popisna sumarizace kvalitativnich dat - frekven¢ni tabulka

1. zpGsob: Analyze -> Descriptive Statistics -> Frequencies -> Variables: zvolit proménnou (napr. Group)
-> 0K

2. zplsob: Kliknout pravym tlacitkem na ndzev proménné (napf. Group) v Data View nebo Variable
View -> Descriptive Statistics

Popisna sumarizace kvantitativnich dat
1. zpUsob: Analyze -> Descriptive Statistics -> Descriptives -> Variables: zvolit proménnou (napr. Age) -> OK

Pozn.: Automaticky se vypisuje primér, smérodatnd odchylka, minimum a maximum, Ize vybrat téz?
rozptyl, rozsah Ci standardni chybu, pokud bychom vypsat medidn, Ize vyuZit ndsledujici tfi postupy.

2. zplsob: Analyze -> Tables -> Custom Tables -> OK -> vybrané proménné pretdhnout do pravého okna
(do Rows nebo Columns) -> Summary Statistics -> zvolit napr. Valid N, Mean, Std. Deviation, Median,
Minimum, Maximum -> Apply to Selection -> Close -> OK

&3 Custom Tables X
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Obr. 3: Popisna sumarizace pomoci Custom Tables
3. zplsob: Analyze -> Descriptive Statistics -> Explore -> Dependent List: vybrat proménné -> zatrhnout
Statistics -> OK

4. zpUsob: Kliknout pravym tlacitkem na ndzev proménné (napr. Age) v Data View nebo Variable View
-> Descriptive Statistics

Popisna sumarizace - zapnuti filtru (vyfiltrovani poslednich 20 pacientii)

Data -> Select Cases -> zatrhnout Based on time or case range -> Range -> vyplnit First Case: 813, Last
Case: 833 -> Continue -> zatrhnout Filter out unselected cases -> OK
Analyze -> Descriptive Statistics -> Descriptives -> Variables: zvolit proménnou (napfr. Age) -> OK

Pozn.: Nezapomenout poté vypnout filtr Data -> Select Cases -> All cases -> OK
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4. Transformace dat

Logaritmicka transformace

Transform -> Compute Variable -> Target Variable: ndzev nové proménné (napr. Weight_log) ->
Function group: Arithmetic -> Functions and Special Variables: vybrat Ln a pfetdhnout do okna Numeric
Expresssion -> do argumentu funkce vloZime vybranou proménnou (napr. Weight)

‘:_f-'i Compute Variable %
Nazev nové proménné

IargelVarianle:/ Numeric Expression:
|Weight_log |~ [(Nowveight) ¢mmmmm Definovaninové

promeénné
Type & Label...

ﬁ . a ¢ kalkulatka”

roup L . .
&> Group_3kat " _ Function group: _
& group_Kasif | L < |f > [ ] [ a ] Al
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&b grouy

e e
Vybé énne, _ _
o v () (ol ) Gl

6
&4 Genc transformovana * | = || ~= 1 2 3 Current Date/Time \
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o J I GG oo sumeun
ef Age { - ] [ “ ] [ ] Eunctions and Special Variables:
& Height JLo Dl | m Abs i
& Height_cor Arsin
& Weight LN(numexpr). Numeric. Returns the base-e logarithm of Artan
f weight_konst numexpr, which must be numeric and greater than 0. Cos V\ibér funkce z konkrétni
& MMSE t Exp skupiny funkei
& MMSE_24 Popis vybrané funkce Lg10
& mmse_neg L Ln ’
L. mmea kat ] Lngamma
Mod
(optional case selection condition) Rnd(1)
l OK I Paste ] Reset “ Cancel || Help

Obr. 4: Ukazka transformace proménné na novou proménnou pomoci Compute Variable

Standardizace dat
Analyze -> Descriptive Statistics -> Descriptives -> Variables: vybrat proménné -> zatrhnout Save
standardized values as variables -> OK

Centrovani dat

Transform -> Compute Variable -> Target Variable: zadat jméno nové proménné (napf. Height_centr) -
> Numeric Expression: vybrat proménnou, kterou chceme centrovat a pfidat minus priimérnd hodnota
(napr. Height-175.97)

Kategorizace

Transform -> Visual Binning -> Variables to Bin: vybrat proménnou (napr. Age) -> Continue -> Binned
Variable: ndzev nové proménné (napr. Age_kat) -> Make Cutpoints -> vyplnit First Cutpoint Location:
60, Number of Cutpoints: 3, Width: 10 -> Apply -> Upper Endpoints: zatrhnout Excluded (<) ->
kliknout na Make Labels -> OK
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{3 Visual Binning Nazev nové X
proménné
Scanned Variable List: Name: Label:
& hge Current Variable: [Age l [ |
I Binned Variable: [Age_kat ] [Age (Binned) ]
Minimum: Nonmissing Values  Maximum:
Proménna, kterd ma
e W(ITHM‘HJ
54,00 52,80 63,60 62,40 7320 78,00 82,20 87,60
56,40 61.20 66,00 70,80 75,60 80,40 8520 90.00

Enter interval cutpoints or click Make Cutpoints for automatic intervals. A cutpoint value
@ of 10, for example, defines an interval starting above the previous interval and ending

Grid: at 10.
i Upper Endpoints . . .
Cases Scanned: : [value BOO‘LEM | O bhais Zahrnuti/vylouéeni
" ncluded (<= s
- : hranié¢niho bodu
Missing Values: 2 70,0 '
D 3 80,0 . kategorie
Copy Bins 4 HIGH
5 Make Cutpoints..
Pridani popiskd kategoriiﬁ Make Labels
& Make Cutpoints Definovénikategorii’ X

® Equal Width Intervals
Intervals - fill in at least two fields

First Cutpoint Location: Ian == Prvni hranice pro kategorii }

Number of Cutpoints: |3 == Celkovy polet hranicnich bodﬂ]

Width: |10.000 === Sitka kategorif ‘
Last Cutpoint Location: 80

Obr. 5: Ukazka kategorizace proménné pomoci Visual Binning

5. Intervaly spolehlivosti

Vypocet intervalu spolehlivosti a stiredni chyby priuméru (standard error)

Analyze -> Tables -> Custom Tables -> OK -> do okna vpravo pretdhnout vybrané proménné (bud' do
Rows, nebo Columns) -> Summary Statistics -> zvolit Mean, Lower CL for Mean, Upper CL for Mean,
Standard Error of Mean -> Apply to Selection -> Close -> OK

6. Statistické testy pro kvantitativni data - parametrické testy

Jednovybérovy t-test
Analyze -> Compare Means -> One-Sample T test -> Test Variables: zvolit proménnou (napf.
Hippocampus volume (mm3)) -> Test Value: vyplnit napr. 6575 -> OK

Parovy t-test
Analyze -> Compare Means -> Paired-Samples T Test -> Paired Variables: pfesunout vybrané proménné

(napr. Hippocampus_volume (mm3) jako Variablel a Hippocampus_volume_24 (mm3) jako Variable2)
-> 0K

Dvouvybérovy t-test

Analyze -> Compare Means -> Independent-Samples T Test -> Test Variables: zvolit proménnou (napf.
Putamen_volume (mm3)) -> Grouping Variable: zvolit proménnou (napr. Gender_rek) -> Define Groups
-> doplnit Group 1: F a Group 2: M -> Continue -> OK
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Analyza rozptylu (ANOVA) a post-hoc testy

Analyze -> Compare Means -> One-Way ANOVA -> Dependent List: zvolit proménnou (napr.
Hippocampus_volume (mm3)) -> Factor: zvolit proménnou (napr. Group_3kat) -> Options -> zatrhnout
Homogenity of variance test a Brown-Forsythe -> Continue -> Post Hoc -> zatrhnout Tukey (v pfipadé
vyrovnanych pocti subjektli ve skupindch) nebo Scheffe (pro stejné i nestejné pocty subjekti ve
skupindch) -> Continue -> OK

7. Statistické testy pro kvantitativni data - neparametrické testy

Wilcoxoniiv test - jednovybérovy

Analyze -> Nonparametric Tests -> One Sample -> na zdloZce Objective zatrhnout Customize analysis ->
na zdloZce Fields do pole Test Fields presunout proménnou, kterou chceme testovat (napr. MMSE) ->
na zdloZce Settings zatrhnout Customize tests -> zatrhnout Compare median to hypothesized ->
Hypothesized median: doplnit 27,5 -> Run

Wilcoxontiiv test - parovy

1. zplsob: Analyze -> Nonparametric Tests -> Related Samples -> na zdloZce Objective zatrhnout
Customize analysis -> na zdloZce Fields do pole Test Fields pfesunout proménné, které chceme testovat
(napr. MMSE a MMSE_24) -> na zdloZce Settings zatrhnout Customize tests -> Wilcoxon matched-pair
signed-rank (2 samples) -> Run

Pozn.: Chceme-li jinou neparametrickou obdobu pdrového t-testu, miZzeme zvolit znaménkovy test
zaskrtnutim Sign Test (2 samples)

2. zplUsob: Analyze -> Nonparametric Tests -> Legacy Dialogs -> 2 Related Samples -> Test Pairs: vioZit
proménné (napf. MMSE a MMSE_24) -> Test Type: Wilcoxon (pfipadné Sign) -> OK

Manniv-Whitneytiv test

1. zpUsob: Analyze -> Nonparametric Tests -> Independent Samples -> na zdloZce Objective zatrhnout
Customize analysis -> na zdloZce Fields do pole Test Fields pfesunout proménnou, kterou chceme
testovat (napr. Hippocampus_volume (mm3)) a do pole Groups presunout grupovaci proménnou
(napf. Gender_rek) -> na zdloZce Settings zatrhnout Customize tests -> Mann-Whitney U (2 samples)
->Run

2. zpUsob: Analyze -> Nonparametric Tests -> Legacy Dialogs -> 2 Independent Samples -> Test Variable
List: vybrat proménné (napr. Hippocampus_volume (mm3)) -> Grouping Variable: vybrat grupovaci
proménnou, kterd musi byt typu numeric (napf. Gender_rek2) -> Define Groups -> dop/nit Group 1: 1,
Group 2: 2 -> Continue -> OK

Pozn.: textovou proménnou Ize zménit na proménnou s ciselnymi kategoriemi pomoci Transform ->
Automatic Recode -> vybrat proménnou (naprf. Gender_rek) -> New Name: vyplnit ndzev nové
proménné (napf. Gender_rek2) -> Add New Name -> OK

Kruskaliv-Wallisiv test

1. zpUsob: Analyze -> Nonparametric Tests -> Independent Samples -> na zdloZce Objective zatrhnout
Customize analysis -> na zdloZce Fields do pole Test Fields presunout proménnou, kterou chceme
testovat (napr. Hippocampus_volume (mm3)) a do pole Groups presunout grupovaci proménnou
(napt. Group_3kat) -> na zdloZce Settings zatrhnout Customize tests -> Kruskal-Wallis 1-way ANOVA (k
samples) -> Run
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2. zpUsob: Analyze -> Nonparametric Tests -> Legacy Dialogs -> K Independent Samples -> Test Variable
List: vybrat proménné (napr. Hippocampus_volume (mm3)) -> Grouping Variable: vybrat grupovaci
proménnou (napf. Group_3kat) -> Define Range: doplnit rozsah grupovaci proménné Minimum: 1,
Maximum: 3 -> Continue -> OK

Pozn.: Post hoc testy ke Kruskal-Wallis ANOVE pocitané 2. zplisobem v SPSS neexistuji, je mozZné to resit
sadou Mannovych-Whitneyovych testi (manudliné je pak nutno provést Bonferroniho korekci)

8. Ovéreni piredpokladii statistickych testii

Vykresleni Q-Q grafu pro jednotlivé skupiny
1. zpGsob: Analyze -> Descriptive Statistics -> Q-Q Plots -> Variables: zvolit proménnou (napf.
Hippocampus_volume (mm3)) -> Test Distribution: Normal -> OK

Pozn.: Nelze pomoci tohoto zplsobu nastavit grupovaci proménnou.

2. zplsob: Analyze -> Descriptive Statistics -> Explore -> Dependent List: zvolit proménné (napfr.
Hippocampus_volume (mm3)) -> Factor List: vybrat grupovaci proménnou (napr. Gender_rek) -> Plots
-> odtrhnout Stem-and-leaf a zatrhnout Normality plots with tests (a pfipadné i Histogram) -> Continue
-> Display: zatrhnout Plots -> OK

9. Dalsi uzitecné prikazy

Popisna sumarizace kvantitativni proménné podle kategorii kvalitativni proménné
Analyze -> Tables -> Custom tables -> OK -> Columns: pretdhnout kvantitativni proménnou (napr.
Hippocampus_volume (mm3)) -> Summary Statistics: zvolit napf. Valid N, Mean, Std. Deviation,
Median, Minimum, Maximum -> Apply to Selection -> Close -> Rows: pfetdhnout kvalitativni
proménnou (napr. Gender_rek) -> Categories and Totals -> lze zaskrtnout Total (sumarizace pro
vSechny kategorie dohromady) -> Apply -> OK

Pozn.: Pokud chceme zobrazit popisné statistiky do radku, staci zvolit Position: Rows

Vytvoreni $ablony graft

Upravit si graf do findIni podoby v Chart Editor -> File -> Save Chart Template -> zaskrtnout, kterd
nastaveni se maji uloZit -> Continue -> File name: pojmenovat Sablonu -> vybrat adresdr, kam se to
uloZi -> Save

Uprava grafu podle $ablony
2x kliknout do grafu -> Chart Editor -> File -> Apply Chart Template -> vybrat styl -> Open

Rozdéleni souboru pomoci SPLIT FILE
Data -> Split File... -> zatrhnout Organize output by groups -> zvolit proménnou (napf. Group_3kat) do
Groups Based on: -> OK

Zruseni rozdéleni souboru
Data -> Split File... -> zatrhnout Analyze all cases, do not create groups -> OK
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10.Analyza kontingenc¢nich tabulek

Kontingen¢ni tabulka absolutnich ¢etnosti
Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Group_3kat) -> Columns
(select variables) (napf. Age_kat) -> Cells -> v sekci Counts zatrhnout Observed -> Continue -> OK

Kontingen¢ni tabulka procent

Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Group_3kat) -> Columns
(select variables) (napf. Age_kat) -> Cells -> v sekci Percentages zatrhnout Row, Columns nebo Total
-> Continue -> OK

Pokud chceme kontingen¢ni tabulku jenom procent
Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Group_3kat) -> Columns

(select variables) (napf. Age_ kat) -> Cells -> v sekci Percentages zatrhnout Row, Columns nebo Total
-> v sekci Counts nesmi byt zatrhnuté nic -> Continue -> OK

Kontingen¢ni tabulka - o¢ekavané cetnosti

Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Group_3kat) -> Columns
(select variables) (napf. Age kat) -> Cells -> v sekci Counts zatrhnout Expected -> Continue
-> 0K

Pearsontiv chi-kvadrat test
Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Group_3kat) -> Columns
(select variables) (napf. Age_kat) -> Statistics -> zatrhnout Chi-square -> Continue -> OK

Fisheruv exaktni test

Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. Gender_rek) -> Columns
(select variables) (napf. mmse_kat) -> Statistics -> zatrhnout Chi-square -> Continue -> Exact
-> zatrhnout Exact -> Continue -> OK

Poznamka: u 2x2 tabulek se vypocitd automaticky pfi zatrZzeni Chi-square (neni tieba zatrhdvat Exact).

McNemaruv test
Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napr. mmse_kat) -> Columns
(select variables) (napf. mmse_24_kat) -> Statistics -> zatrhnout McNemar -> Continue -> OK

Relativni riziko (RR) a pomér Sanci (OR)

Analyze -> Descriptive Statistics -> Crosstabs -> Rows (select variables) (napf. Gender_rek) -> Columns
(select variables) (napf. mmse_kat2) -> Statistics -> zatrhnout Risk -> Continue -> OK

11 Pozor, lze vypocitat pouze pro tabulky 2x2 !!!

Pomér Sanci (OR) vcetné p-hodnoty

Analyze -> Regression -> Binary Logistic -> vybrat zdvisle proménnou a kovaridtu -> Categorical (/ze
zvolit, zda je referencni kategorie Last nebo First; pfi zméné kliknout na Change) -> Options (zatrhnout
Cl for exp(B), aby se vypsaly intervaly spolehlivosti) -> Continue -> OK

10



i @ .._ Autofi: RNDr. Eva Koritakova, Ph.D., Bc. Lucie Nekvindova, Bc. Veronika Prelecova
- AN IBA Institut biostatistiky a analyz, Lékarska fakulta, Masarykova univerzita, Brno

11.ROC analyza

I.  Analyze -> ROC Curve -> zadat Test Variable (napf. MMSE) a State Variable (napfr.
group_01_CnMci) a jako Value of State Variable zadat rizikovou kategorii (napf. 1) -> na zdloZce
Options Ize zvolit, zda , Larger test result indicates more positive test” nebo ,Smaller test result
indicates more positive test” -> Continue

Il.  Pokud chceme vypocitat k AUC intervaly spolehlivosti a p-hodnotu: zatrhnout ,Standard erorr and
confidence interval”

lll.  Pokud chceme ziskat tabulku se senzitivitou a 1-specificitou: zatrhnout ,Coordinate points of the
ROC Curve”

IV.  Pro zjisténi cut-off (nejlepsiho déliciho bodu) je nutné tabulku s 1-specificitou zkopirovat do Excelu,
vypocitat specificitu a nalézt nejlepsi cut-off a to ndsledovné:

a. kliknout levym tlacitkem mysi na tabulku -> Copy -> vioZit do Excelu

b. v Excelu spocitat specificitu (tzn. udélat 1-(sloupecek s 1-Specificity)) a pak spocitat soucet
senzitivity a specificity -> vybrat Fddek s nejvétsi hodnotou souctu senzitivity a specificity -> to
je nejlepsi cut-off

V. Vytvoreni kategorizovaného MMSE skdre s vyuZitim cut-off: Transform -> Recode into Different
Variables -> pojmenovat novou proménnou (napf. mmse_kat3) v Output Variable a kliknout
Change -> Old and New Values -> do Range, LOWEST through value napsat 28,5 -> do New Value
(Value) napsat 1 -> Add -> kliknout na All other values -> do New Value (Value) napsat 0 -> Add
-> Continue -> OK

VI. Ovéreni vypocitané senzitivity a specificity: Analyze -> Descriptive Statistics -> Crosstabs -> do
Rows (napf. mmse_kat3) do Columns (napr. group_01_CnMci)-> Cells -> na zdloZce Precentages
zatrhnout Column -> Continue -> OK -> senzitivita je tady procento v levém dolnim rohu, specificita
je procento v pravém hornim rohu — zdleZi ale na nakddovdni dat a v Rows musi byt vysledek
diagnostického testu a v Columns skutecnost

12.Korelacni analyza

Bodovy graf (“Scatterplot”)

Graphs -> Legacy Dialogs -> Scatter/Dot... -> zvolit Simple Scatter -> Define -> zvolit proménné (napr.
Putamen_volume (mm3) jako X a Amygdala_volume (mm3) jako Y -> OK

Poznamka 1 — priddni regresni primky: 2x kliknout na graf -> Elements -> Fit line at total (pfipadné v
nové vyskoceném okné zrusit zatrZeni "Attach label to line" a kliknout na Apply)

Pozndmka 2 — vykresleni podle skupin: pri zaddvadni pfidat kategoridlni proménnou do Set Markers by.

Vypocet Pearsonova korela¢niho koeficientu
Analyze -> Correlate -> Bivariate -> zvolit proménné (napf. Amygdala_volume (mm3) a
Putamen_volume (mm3)) -> v sekci Correlation Coefficients zatrhnout Pearson -> OK

Vypocet Pearsonova korela¢niho koeficientu - 2. zptisob

Analyze -> Descriptive Statistics -> Crosstabs -> zvolit proménné (napf. Amygdala_volume (mm3) a
Putamen_volume (mm3)) -> Statistics -> zatrhnout Correlations -> Continue -> je vhodné zatrhnout
Supress tables -> OK

Pozndmka — spocte to zdroveri i Spearmantv korelacni koeficient

Vypocet Spearmanova korelacniho koeficientu
Analyze -> Correlate -> Bivariate -> zvolit proménné (napr. MMSE a Hippocampus_volume (mm3)) ->
v sekci Correlation Coefficients zatrhnout Spearman -> OK

Vypocet parcialni korelace (parametrické)
Analyze -> Correlate -> Partial -> zvolit proménné (napr. Pallidum_volume (mm3) a Nucl_caud_volume

11
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(mm3) do Variables a Age do Controling for) -> OK
Pozndmka — neparametrickou parcidini korelaci nelze v SPSS vyklikat, musi se pouZit syntax.

13.Regresni analyza

Linearni regrese a odstranéni vlivu kovariat
Analyze -> Regression -> Linear -> zvolit proménné (napr. Nucl_caud_volume (mm3) jako Dependent,
Age, gender_01, ... jako Independent(s)) -> OK -> vypise regresni koeficienty a p-hodnoty
- Vykresleni Q-Q grafu a histogramu standardizovanych rezidui: na zdloZce Plots kliknout na
*ZRESID a zaskrtnout Histogram -> Continue
- Vykresleni Q-Q grafu a histogramu pro rezidua — 2. zpUsob: kliknout na Save a v sekci Residuals
zaskrtnout Standardized ¢i Unstandardized -> Continue -> OK
Analyze -> Descriptive Statistics -> Explore -> Dependent List (zvolit napf. RES_1) -> Plots ->
zaskrtnout Normality plots with tests a Histogram -> Continue -> OK
- Vykresleni bodového grafu predikovanych hodnot a rezidui: na zdloZce Plots zvolit na Y osu
*ZRESID a na osu X *ZPRED
- UloZeni rezidui a predikovanych hodnot: na zdloZce Save zaskrtnout pri Predicted Values i pfi
Residuals: Standardized nebo Unstandardized podle toho, co ndm vyhovuje -> Continue -> OK

14.Analyza preziti

Kaplantv-Meiertiv odhad funkce preziti pro jeden vybér
Analyze -> Survival -> Kaplan-Meier... -> zvolit proménné Time a Status (napf. ¢as jako Time a amrti
jako Status) -> kliknout na Define event (do Single value zvolit pfislusnou hodnotu, kterd kdduje uddlost
(vétsinou hodnota 1)) -> OK
- Vykresleni kfivky preZiti: kliknout na Options a zatrhnout Survival v sekci Plots
- Vypsani tabulky pro vypocet x-letého preZiti: kliknout na Options a zatrhnout Survival table(s)
v sekci Statistics
- Vypsani tabulky s medidnem preziti: kliknout na Options a zatrhnout Mean and median
survival v sekci Statistics

Kaplantiv-Meiertiv odhad funkce preZiti pro vice vybéri
Analyze -> Survival -> Kaplan-Meier -> zvolit proménné Time a Status (napr. ¢as jako Time a umrti jako
Status) -> kliknout na Define event (do Single value zvolit prislusnou hodnotu, kterd koduje uddlost
(vétsinou hodnota 1)) -> zvolit Factor (proménnd podle které chceme rozdélit data do skupin) -> OK
- Vykresleni kfivek preziti: kliknout na Options a zatrhnout Survival v sekci Plots
- Vypocet testu na srovnani preziti ve skupindch: kliknout na Compare Factor a zatrhnout Log
rank v sekci Test Statistics
- Vypsani tabulky pro vypocet x-letého preZiti: kliknout na Options a zatrhnout Survival table(s)
v sekci Statistics
- Vypsani tabulky s medidnem preziti: kliknout na Options a zatrhnout Mean and median
survival v sekci Statistics

Coxuiv model proporcionalnich rizik
Analyze -> Survival -> Cox Regression -> zvolit proménné Time, Status a Covariates (napr.
0OS_doba_mesice jako Time, umrti jako Status a ECOG1 jako Covariates) -> kliknout na Define event
(do Single value zvolit prislusnou hodnotu, kterd kéduje uddlost (vétsinou hodnota 1)) -> OK

- Vykresleni krivek preziti: kliknout na Plots a zatrhnout Survival

- Interval spolehlivosti: kliknout na Options a zatrhnout Cl for exp(B) v zdloZce Model Statistics
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