MICROSOFT* OFFICE

Excel 2007

Excel Tutorial 2

Formatting a
Workbook

NEW PERSPECTIVES
COMPREHENSIVE




Objectives

 Format text, numbers, and dates
* Change font colors and fill colors
* Merge a range into a single cell

* Apply a built-in cell style

e Select a different theme
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Objectives

* Apply a built-in table style

* Add conditional formats to tables with highlight
rules and data bars

e Hide worksheet rows

* |nsert print titles, set print areas, and insert page
breaks

* Enter headers and footers

New Perspectives on Microsoft Office Excel 2007 3



Formatting Workbooks

* Formatting is the process of changing a
workbook’s appearance by defining the fonts,
styles, colors, and decorative features

* Atheme is a collection of formatting that '
specifies the fonts, colors, and graphical effects |
used throughout the workbook

* As you work, Live Preview shows the effects of
formatting options on the workbook’s
appearance before you apply them
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Formatting Text

* The appearance of text is
determined by its
typeface, which is the
specific design used for
the characters

— Font
* Serif fonts
* Sans serif fonts

* Theme font
e Non-theme font

— Font Style

— Font Size
* Measured in points
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Working with Color

* Theme colors are the 12 colors that belong to
the workbook’s theme

 Standard and custom colors

* Apply a color by selecting a cell or range of cells,
clicking the Font Color or Fill Color button arrow,
and then selecting an appropriate color
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Formatting Text Selections

* The Mini toolbar appears when you select text
and contains buttons for commonly used text
formats

Figure 2-5 Mini toolbar used to format text
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Setting a Background Image

* You can use a picture or image as the
background for all the cells in a worksheet

* Click the Page Layout tab on the Ribbon

* Click the Background button

* Locate the background, and then click the Insert
button

Background image added to the Documentation sheet Figure 2-6
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Formatting Data

e By default, values appear in the General number
format, which, for the most part, displays numbers
exactly as you enter them

 The Number group on the Home tab has buttons for
formatting the appearance of numbers

e Comma style button

* Decrease Decimal button
* Percent Style button

* Increase Decimal button

* Accounting Number Format button
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ormatting Data

Figure 2-8 Worksheet after formatting numbers

i = = _ - _ S— T —
6 |Units Sold !Region 2008 Sales 2009 Sales Increase % Increase
7 RO1 3,605 3,853 248 6.88%
8 RO2 3,966 3,842 (124) -3.13%
units include RO3 3,760 4,035 275 7.31% percente_rges include
commasand no - we = e
decimal places RO6 3,656 3,037 281 7.69% i
13 RO7 3,554 3,875 321 9.03%
14 RO8 3,344 3,844 . 0.00%
15 Total 30,136 31,174 1,038 3.44%
16
17 |Revenue Region 2008 Sales 2009 Sales Increase . % Increase |
18 RO1 — 5 104,364.75 $  115397.35 $ 11,032.60 10.57% 1
19 RO2 114,815.70 115,067.90 252.20 0.22%
RO3 108,852.00 120,848.25 11,996.25 11.02% -
fmt a:;ld IT:t RO4 109,344.15 121,686.85 12,342.70 11.20% | revenues include
g nay ROS 115,047.30 111,563.75 (3,483.55) ¢ ~€——=-p==| COmmas and two
the currency ek 2 = 2 :
hol RO6 105,841.20 117,913.15 12,071.95 11.21% | decimal places
Shiul Iy RO7 102,888.30 116,056.25 13,167.95 12.80%
25 RO8 111,283.80 115,127.80 3,844.00 3.45%
26 Total - 872,437.20 S 933,661.30 $ 61,224.10 7.02%
M 4 » W[ Documentation | Yearly Sales . Monthly Sakes - %2 N L m
Ready | 2 |
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Formatting Dates and Times

e Although dates and times in Excel appear as text,
they are actually numbers that measure the
interval between the specified date and time and

January 1, 1900 at 12:00 a.m.
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Aligning Cell Content

* |n addition to left and right alighments, you can
change the vertical and horizontal alignments of
cell content to make a worksheet more readable

e Alignment buttons are located on the Home tab

Aligns the cell content with the cell's top edge

3

Vertically centers the cell content within the cell

Aligns the cell content with the cell's bottom edge

Aligns the cell content with the cell's left edge

Horizontally centers the cell content within the cell

Aligns the cell content with the cell's right edge

Decreases the size of the indentation used in the cell

Increases the size of the indentation used in the cell

Rotates the cell content to an angle within the cell

Forces the cell text to wrap within the cell borders

) ) ) | ) ) o

Merges the selected cells into a single cell
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Indenting Cell Content

* You increase the indentation by roughly one
character each time you click the Increase Indent
button in the Alignment group on the Home tab

Centered and indented text
oy id - o s ExerComp Sales Report - Microsoft Excel i
'y Home | Insert | Pagelayout  Formulas  Data  Review  View -2 x
3 : Calibri o A AT | e =¢ | General ¥ h: % Sd 2:::::'- ;' i{ J&
n o | B e | - | (e oo S 2 i G- 5 2R
Clipboard Font ~ Alignment £ Number i r WL Lall Editing
as v (2 J| units sold * 1
A | B C ] D E ] E ] G
Units Sold _I Region 2008 Sales 2009 Sales Increase % Increase
RO1 3,605 3,853 248 6.88%
RO2 3,966 3,842 (124) -3.13%
9 RO3 3,760 4,035 275 7.31%
10 - J RO4 3,777 4,063 286 7.57%
11 ROS 3,974 3,725 (249) -6.27% centered
12 RO6 3,656 3937 281 7.69% | text
13 RO7 3,554 3,875 321 9.03%
14 RO8 3,844 3,844 - 0.00%
15 | text Total 30,136 31,174 1,038 3.44%
16 indented ’
17 | ONE SPace | Region 2008 Sales 2009 Sales Increase % Increase i
18 RO1 S 104,364.75 | $ 115,397.35 $ 11,032.60 10.57% |

0~

19 RO2 114,815.70 115,067.90 252.20 0.22%
20 RO3 108,852.00 120,848.25 11,996.25 11.02%
21 RO4 109,344.15 121,686.85 12,342.70 11.29%
22 ROS 115,047.30 111,563.75 (3,483.55) -3.03%
23 RO6 105,841.20 117,913.15 12,071.95 11.41%
24 RO7 102,888.30 116,056.25 13,167.95 12.80%
25 G 111,283.80 115,127.80 3,844.00 3.45%

26 Total $ 872,437.20 § 933,661.30 $ 61,224.10 7.02%
H 4> | Documentation | Yearly Sales . Monthly Sales <%0 il | ™
Ready ]
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Merging Cells

* One way to align text over several columns or

rows is to merge, or combine, several cells into
one cell

Merged range with centered text
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Clipboard = Font fu Alignment fi||  Number f= Styles Cells Editing
| At ~(3 £ | X310 vearly sales Analysis text centered in =]
A B the merged cell E F G
1 ExerComp
2 the Intelligent path to Fitness
3 [
4 | X310 Yearly Sales Analysis |
5
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Rotating Cell Content

* To save space or to provide visual interest to a
worksheet, you can rotate the cell contents so
that they appear at any angle or orientation

* Select the range

* |n the Alignment group, click the Orientation
button and choose a proper rotation
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Rotating Cell Content

Merged and rotated cell text Figure 2-13
A B C D E F G H

6 Region 2008 Sales 2009 Sales Increase % Increase

7 RO1 3,605 3,853 248 6.88%

8 RO2 3,966 3,842 (124) -3.13%

9 o RO3 3,760 4,035 275 7.31%

10 ﬁ <04 3,777 4,063 286 7.57%

11| & RO5 3,974 3,725 (249) -6.27%

12 2 RO6 3,656 3,937 281 7.69%

13 RO7 3,554 3,875 321 9.03%

14 rog | rotated labels| ; 544 3,844 - 0.00%

15 Total | take up less o136 31,174 1,038 3.44%

16 space in the

17 Region merged cells ples 2009 Sales Increase % Increase .
18 RO1 10736475 S 115397.35 § 11,032.60 10.57%

19 RO2 114,815.70 115,067.90 252.20 0.22%

20 RO3 108,852.00 120,848.25 11,996.25 11.02%

21 % RO4 109,344.15 121,686.85 12,342.70 11.29%

22 é RO5 115,047.30 111,563.75 (3,483.55) -3.03%

23 RO6 105,841.20 117,913.15 12,071.95 11.41%

24 RO7 102,888.30 116,056.25 13,167.95 12.80%

25 RO8 111,283.80 115,127.80 3,844,00 3.45%

26 Total S 872437.20 S 93366130 S 61,224.10 7.02%
M 4 » W Documentaton | Yearly Sales  Monthly Sakes . 7 I . " —I
Reagy | 73 _.
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Adding Cell Borders

* You can add borders to the left, top, right, or
bottom of a cell or range, around an entire cell,
or around the outside edges of a range using the

Border button arrow
Borders added to cells

A B & _ D E E G H
——6—-—-—b:lﬁegion | 2008 Sales | 2009 Sales | Increase _ %ncrease
7 RO1 3,605 3,853 248 6.88%
8 RO2 3,966 3,842 (124) -3.13%
9 <  RO3 3,760 4,035 275 7.31%
10 & Ro4 3,777 4,063 286 7.57%
11 £ ros 3,974 3,725 (249) -6.27%
122 Roe 3,656 3,037 281 7.69%
column titles RO7 3,554 3,875 321 9.03%
have a single ROS 3,844 3,844 - 0.00%
bottom border| Total 30,136 31,174 1,038 3.44%
16 ‘_I
I—l—’—» Region 2008 Sales 2009 Sales Increase % Increase Total rows 1
18 RO1 $  104,364.75 S 115397.35 $ 11,032.60 10.57% [Eees
19 RO2 114,815.70 115,067.90 252.20 0.22% | %
20 RO3 108,852.00 120,848.25 11,996.25 11025 | Single top
1) ¥ 4 »
21, 2 RM4 109,344.15 121,686.85 12,342.70 11.20% | Dorder and
22 % ROS 115,047.30 111,563.75 (3,483.55) 3.03% | adouble
23| © RO6 105,841.20 117,913.15 12,071.95 11.41% | bottom
24 RO7 102,888.30 116,056.25 13,167.95 12.80% | border
25 ROS 111,283.80 115,127.80 3,844.00 3.45% |
26 Total S 87243720 § 93366130 § 61,224.10 7.02%
W 4 » W] Documentation | Yearly Sales - Monthly Sales _ 7 T 5
Ready | 7
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Working with the

Format Cells Dialog Box
e The Format Cells dialog e R

Mumber | Algrment | Font | Border | Fil | Fratechion ow the

box has six tabs, each ===

number Decimal feces: |0
format

Time: [#] use 1000 separator ()

. Percentage
categories Fracton Hegative numbers:

focusing on a different
set of formatting options f

Murnber i weed for general display of nunbers, Currency and Accounting offer cpedalzed formattng
far menetary value.

|
options related
<«—] to the selected

category

Ok Cancel

Figure 2-16 Border tab in the Format Cells dialog box
e  adds lines around
:::Ti::st::d urber [ slgoment [ Font | Eorder [ il | [ fretecton the cell or range
the cell or range : I
| adds lines within
: the range
border line Quiine  Inside ‘
styles i n preview of
- the selected
selected [z Text Tedt Tmrder style
border line p—
color — = = — border of the
Wi i & & selected cells

The sslectid border style can b applad by ciddng the presets, preview disgram or the buttans
above.
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Copying Formats

with the Format Painter

 The Format Painter copies the formatting from
one cell or range to another cell or range,
without duplicating any of the data

e Select the range containing the format you wish
to copy

 Click the Format Painter button on the Home tab

* Click the cell to which you want to apply the
format
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Copying Formats with the

Paste Options Button

Using the Paste Options button

_ A L e i L R - H | J
1
2
g 11,361} pastes only
4 1,875 1,924 2,112 5911} the formats
5 850 912 750 2,512,
«| 0 Keep Source Formatting
6 6,330 6,832 6,622 19,784, i
' Use Destination Theme
7 | ' Match Destination Formatting
- 1 O  Values Only
9 O Values and Number Formatting
10 3,853 31842 41'035 111730 ©  Values and Source Formatting
11 2,112 1,801 2,304 6,217 O  Keep Source Column Widths "
12 . 1025/ 1,115 912 3,052 romatting only N
13 e 6,990 6,758 7,251  20,999] O Link Cells
14 | Paste Options button
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Copying Formats with Paste Special

Figure 2-18 Paste Special dialog box

paste values
and formats

_

paste only formulas

paste only values

paste only formats

L —

apply the
selected
operation to the
copied value

_

=) Formulas
e alies
L Formats
) Comments
7 Validation

Ciperatan

@) Mgne
T Add
) Subtract

shin blanka

Paste Link

(o]

7 Al using Sourc= theme

7 Al excapt borders

0 Column widths

T Farmulas and number farmats
771 Values and number formats

2 Mutiply
) Divide

Transpose. —

ot || conem ]

—_ )

paste the
selected

range rotated

90 degrees
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Applying Styles

* Astyleis a collection of formatting

e Select the cell or range to which you want to
apply a style

* |n the Styles group on the Home tab, click the
Cell Styles button

* Point to each style in the Cell Styles gallery to see
a Live Preview of that style on the selected cell
or range

* Click the style you want to apply to the selected
cell or range
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Applying Styles

Cell Styles gallery Figure 2-19

) - >~ s Sales Report - Microsoft Excel - =
@i‘:' o gallery of < —
Home 52 e rmul; - . oW " -
_ R built-in styles =
y ® | Caibri Slu -|A W)= General - ~5 b S ﬂ lﬁ
45 ] s i a'snaﬁa&
Paste |l == A d 3 - || *8 ¢ o o in
ite g || o) A-| | =E=a I‘i:; $ - % o ||%8 | EFormat~ | 23+ Fifer~ select
Clipboard = Font 1) Alignm  Good, Bad and Neutral -
A4 - 2 F | X310 Yearly Sales Analysis |. Normal | Bad Good Neutral
A B C Data and Model
|[calculation '_ Check Cell Explanatory ... |[Input Linked Ce: Note
:  ExerComp
- itness Tiles and Headings
eaain, eading Heading 3 Heading 4 T Total
Heading 1 style Heading 1 | Heading 2 ading3  Headi Iitle ]
Themed Cell
a —>X310 Ye —
5 20%- Accentl  20% - Accent2  20%- Accent3  20%- Accentd  20%- AccentS  20% - Accent6
. 40% - Accentl  40% - Accent2  40% - Accent3  40% - Accentd  40% - AccentS  40% - Accenté
6 Region 2008 Sales
7 RO1 3,60 :
g Ro2 3o TN CCCCTCHN [ [rccenis——
S| = Live Preview of the |3,76C MumuerFarmat
10 ﬁ Heading 1 style 3,777 Comma Comma [0] Currency Currency [0]  Percent -
11 = 3,974 5] New Celi Style...
12 - RO6 3,65€ (&) Merge Styles...
13 RO7 3,554 ey sex sz i
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Working with Themes

* The appearance of these fonts, colors, and cell
styles depends on the workbook’s current theme

Yearly Sales data with the Aspect theme applied
" 71 [~ ” ExerComp Sales Report - Microsoft Excel -8 x
- Home  Insert | Pagelayout | Formulas  Data  Review  View @ - = x
S K colors - 2 =l 3 '_'?‘ 51 widtn: Automatic = Gridlines |Headings 4B nt - |2 Align =
. Ig o |Themes button L- = -‘g -_;] §l) Height: Automatic = | ¥ View | V| View 2 -]
THamee [@esrects ~ e el :,',",'t e ¥ -:'t':: &) sealer  100% % print | [ print || B, Selection Pane S Rotate
s e Soo o] cieiicn B S
1~ S ]
A B - E { G I H i
o a different font is
Exf I‘COclﬂ g « used for the heading
the Intelligent path to Fitness
X310 Yearly Sales Analysis different fonts

1
2
3
4
: Regi 2008 Sale 2009 Sale: I % I and fll colors
glon ales ales ncraase ncreasa .
7 RO1 3,605 3,853 248 6.88% appear in the
g - ROZ 3,966 3,842 -124 -3.13% two tables
> RO3 3,760 4,035 275 7.31%
10| 9  Ro4 3,777 4,063 286 7.57%
11| £ | ros 3,974 3,725 -249 -6.27%
12| 5  ros 3,656 3,937 281 7.69% d
13 RO7 3,554 3,875 321 9.03%
14 ROB 3,844 3,844 [ 0.00%
15 Total 30,136 31,174 1,038 3.44%
16
17 Region 2008 Sales 2009 Sales Increase % Increase
18 RO1 $ 10436475 § 11539735 $§ 11,032.60 10.57%
19 RO2 114,815.70 115,067.90 252.20 0.22%
20 E RD3 108,852.00 120,848.25 11,996.25 11.02% -
21 £ R4 109,344.15 121,686.85 12,342.70 11.29%
22 ; ROS 115,047.30 111,563.75 (3,483.55) -3.03%
23| « | RO 105,841.20 117,913.15 12,071.95 11.41%
24 RO7 102,888.30 116,056.25 13,167.95 12.80%
25 ROS 111,283.80 115,127.80 3,844.00 3.45%
26 Total $ 87243720 §  933,661.30 % 61,224.10 7.02%
27
28
W 4 » W Documentstion | Yearly Sales =~ Monthly Sales ¥J T m
Reagy 7
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Applying a Table Style
to an Existing Table

* You can treat a range of data as a distinct object
in @ worksheet known as an Excel table

* Select the range to which you want to apply the
table style

* |n the Styles group on the Home tab, click the
Format as Table button

* Click a table style in the Table Style gallery
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Applying a Table Style
to an Existing Table

Banded rows effect applied manually and with a table style Figure 2-23

A B G D E
1
2 RO1 3,605 3,853 248
3 RO2 3,966 3,842 -124
4 RO3 3,760 4,035 Fr
5 RO4 3,777 4,063 286
& ROS 3,974 3,725 249
e 7 [Ros 3,656 3,937 281
| fill color is pink | T R07 3,554 3,875 321
S ROB 3,844 3,844 1]
10 Total 20,136 31,174 1,038) fill color
11 remains pink,
fill color is changed original table with banded rows losing the
M to white, retaining banded rows
the banded rows effect effect
A B [ D E A B G D E
2 [RO1 3,605 3,853 248 2 RO1 3,605 3,853 248
3 |RO2 3,966 3,842 -124 3 RO2 3,966 3,842 =124
4 RO3 3,760 4,035 275 4 R03 3,760 4,035 275
— P07 3,554 3,875 321 5 RO7 3,554 3,875 321}
6 ROB 3,844 3,844 0 & ROB 3,844 3,844 0
7 Total 18,729 19,449 720 7 Total 18,729 19,449 720
g8 B
table formatted with a table style retains table formatted manually loses banded
banded rows after rows are deleted rows after rows are deleted
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Selecting Table Style Options

e After you apply a table style, you can choose
which table elements you want included in the
style

Revised table style Figure 2-25

Y-~ )s

Haome Insert

Table Tools

. |se|ected table elements

Design

Table Name: {8 summarize with PivetTable e ¥ Header Row First Column

Tablel [ Remave Duplicates & Or Total Rowr ¥/ Last Column
T Resize Table | 5 Convert to Range e Banded Rows [ Banded Columns
Properties Tools External Table Data Table Style Options “ Table Styles
B6 v (3 J| Month Bl
A C > E E S i | table styles show L
1 Exe r Nmn formatting for
...| header row selected elements
banded | | formatted
:‘::ls:wed ’ X310 Monthly Sales Analysis }?;trr(l::tltl:ém
7 288 345 326
8 278 304 294 297 310 278 275 294
9 Mar 294 320 297 304 316 291 297 307
10 @1 Apr 288 313 300 300 320 284 275 295
11 2 May 284 329 304 297 313 288 275 310
12 .E Jun 313 339 316 315 326 307 288 329
13 = 4 Jul 313 332 320 310 313 300 304 336
14 *g Aug 294 339 315 339 339 304 307 323
15 2| Sep 284 310 310 304 316 284 281 304
16 Oct 284 326 304 297 316 281 281 300
17 Nov 339 364 326 320 364 345 294 336
18 Dec 346 345 348 387 377 384 361 358
19 L Total 3,605 3,966 3,760 3,777 3,974 3,656 3,554 3,844
W Documentation - Yearly Sales | Monthly Sales -2 [

Reagy ]
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Introducing Conditional Formats

* A conditional format applies formatting only when a cell’s value
meets a specified condition

* Select the range or ranges to which you want to add data bars.

* In the Styles group on the Home tab, click the Conditional
Formatting button, point to Data Bars, and then click a data bar
color

or

* Select the range in which you want to highlight cells that match a
specified rule

* In the Styles group, click the Conditional Formatting button, point
to Highlight Cells Rules or Top/Bottom Rules, and then click the
appropriate rule

* Select the appropriate options in the dialog box, and then click
the OK button
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Adding Data Bars

e A data baris a horizontal bar added to the

background of a cell to provide a visual indicator
of the cell’s value

e Select the cell(s)

* |n the Styles group on the Home tab, click the
Conditional Formatting button, point to Data
Bars, and then click the DataBar option you wish

to apply
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Adding Data Bars

Data bars added to the regional monthly sales data

January sales for
the RO1 region
are lower than

| 27308 304 2078 310} 278) 2758

expected E 2 320B 34F 3168 29 207

10| 8 FE 2l ::B 300l 3200 284 275

11| & i 24 300 2078 313 288 275§

12| £ | JNEVE]  NEET) I s 326l 307F 2e3[B

13 3 B ;i 332 308 330 338 330F 0B

14 £ E 2040 3390l 35500 339 339 3¢ 3071

15 > i 224 30 30 304 3160 284 281

16 i 248 3260 304 297 316 281 2811

17 B ol el 36 20 sl 35 200l

18 B 3l 3ol ;xR ;7B s o [l 3ss

19 3,605 3,966 3,760 3,777 3,974 3,656 3,554 3,844

20

21

22 345

93] 207 14 3 ann 207

WA Sales | Monthly Sales <% )

Ressy | 23|
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Hiding Worksheet Data

* Hiding rows, columns, and worksheets is an
excellent way to conceal extraneous or
distracting information

* |n the Cells group on the Home tab, click the
Format button, point to Hide & Unhide, and
then click your desired option

31
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Changing the Page Orientation
to Landscape

* Click the Page Layout tab on the Ribbon

* |n the Page Setup group, click the Orientation
button, and then click Landscape
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Defining the Print Area

* By default, all parts of the active worksheet
containing text, formulas, or values are printed

* You can select the cells you want to print, and
then define them as a print area

e Select the range, in the Page Setup group on the
Page Layout tab, click the Print Area button, and

then click Set Print Area

33
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Inserting Page Breaks

* Excel prints as much as fits on a page and then
inserts a page break to continue printing the
remaining worksheet content on the next page

 Manual page breaks specify exactly where the
page breaks occur
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Setting and Removing Page Breaks

To set a page break:

e Select the first cell below the row where you want to
insert a page break

* In the Page Setup group on the Page Layout tab, click
the Breaks button, and then click Insert Page Break

To remove a page break:

e Select any cell below or to the right of the page break
you want to remove

* |In the Page Setup group on the Page Layout tab, click
the Breaks button, and then click Remove Page Break
(or click Reset All Page Breaks to remove all the page
breaks from the worksheet)
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Setting and Removing Page Breaks

HEBSEHERaE:
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Adding Print Titles

* You can repeat information, such as the
company name, by specifying which rows or
columns in the worksheet act as print titles,
information that prints on each page

* |[n the Page Setup group on the Page Layout tab,
click the Print Titles button

* Click the Rows to repeat at top box, move your
pointer over the worksheet, and then select the
range

* Click the OK button
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Adding Print Titles

Figure 2-36 Second page of the printout
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Adding Headers and Footers

* A header is the text printed in the top margin of
each page

* A footer is the text printed in the bottom margin
of each page

* Scroll to the top of the worksheet, and then click
the left section of the header directly above cell
Al to display the Header & Footer Tools
contextual tab
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Adding Headers and Footers

Page header Figure 2-37
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