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Vytvoření nového shapefile: 
 

- Pro vytvoření nové bodové, liniové či plošné vrstvy (shapefile) máme v ArcGIS hned dvě 
možnosti: 

o  Použití nástroje v ArcToolbox → Data Management Tools → Feature Class → Create 
Feature Class 

o Kliknutí pravým tlačítkem myši na cílovou složku v ArcCatalogu → New → Shapefile 
- V obou případech lze rovnou nadefinovat souřadný systém. 

 
 
Souřadné systémy : 
 
Pro vytvoření mapy v ArcMapu v určitém měřítku je vhodné nastavit souřadný systém  

-  PTM na Layers → Properties → záložka Coordinate System a ve spodním rámečku vybereme 
požadovaný systém.  

 
Je třeba dbát, aby všechny v projektu použité vrstvy byly ve stejném souřadném systému, jinak se 
musí provést transformace mezi systémy.  
 
Nastavit souřadný systém pro jednotlivé vrstvy je možné i v ArcCatalogu  

-  PTM na název datové vrstvy →Properties → záložka XY Coordinate System → Select nebo 
Import (při možnosti Import se importuje systém ze shapefilu, u něhož je již explicitně 
nadefinován).  
 

Souřadné systémy nejčastěji používané v českém prostředí:  
 
- S-JTSK: Predefined → Projected Coordinate Systems → National Grids → Europe → S-JTSK Krovak 
EastNorth (př. souřadnic: -597154,931 -1159597,971 Meters)  
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- UTM: Predefined → Projected Coordinate Systems → UTM → WGS 1984 → Nothern Hemosphre → 
WGS_1984_UTM_Zone_33N (př. souřadnic: 617180,601 5451127,108 Meters)  

- WGS 84: Predefined → Geographic Coordinate Systems → World → WGS 1984 (př. souřadnic: 
16°35’4,851”E 49°12’37,385“N)  

- S-42: Predefined → Projected Coordinate Systems → Gauss Kruger → Pulkovo 1942 → Pulkovo 
1942 GK Zone 3 (př. souřadnic: 3617202,914 5453234,195 Meters)  
 
Při použití S-JTSK nutné otočit směrovku o 6° po směru hodinových ručiček (směřuje ke 
kartografickému pólu ve Finském zálivu).  
 
 
Definování a změna souřadného systému: 
 
Pokud nemá shapefile nadefinovaný souřadný systém, můžeme takto učinit pomocí nástroje Data 
Management Tools → Projections and Transformations → Define Projection. Vytvoří se tak soubor 
*.prj.  
 
Jelikož se často nedá spolehnout na automatickou transformaci mezi souřadnými systémy, zpravidla 
nestačí jen změnit nastavení v Properties vrstvy nebo datového rámu (Data Frame Properties), je 
třeba souřadnice přepočítat podle transformačních rovnic a uložit data do nového shapefile 
 

- nástroj Data Management Tools → Projections and Transformations → Feature → Project 
pro vektor  

-  Data Management Tools → Projections and Transformations → Raster → Project Raster pro 
rastr.  

 
 
Georeferencování: 
 

Georeferencování slouží k transformaci podkladů bez prostorové reference (skenované 
mapy, letecké fotografie, družicové snímky) do určitého souřadného systému. Georeferencování 
probíhá na základě určení přesné polohy tzv. vlícovacích bodů, které se označí jak na rastru, tak na 
vektorové vrstvě, podle níž data transformujeme.  

 
Transformací rozlišujeme několik, mezi základní patří lineární konformní transformace (jde o 

posun a otočení), polynomická transformace (změna měřítka není ve všech směrech stejná). Řád 
polynomické transformace určuje minimální počet vlícovacích bodů (I. řád 3 body, II. 6, III. 10), další 
body již transformaci nezpřesňují, jen zmenšují polohovou chybu.  

 
Georeferencovaná rastrová data jsou následně převzorkována do nového rastru s jiným 

rozměrem buňky. V GIS je pak možné uvedená data kombinovat s jinými vrstvami v GIS, zobrazí se ve 
správných souřadnicích. 



Z0262 Geoinformatika, jaro 2015 
str. 3/10 

 
 

 
 
Georeferencování v prostředí ArcMap: 
 

Do ArcMapu nahrajte skenovaný obrázek a vektorový referenční soubor – v našem případě 
shapefile okresů ČR z ArcČR500.  

 
Spusťte lištu nástrojů pro georeferencování: View → Toolbars → Georeferencing 

 
 

V rolovací nabídce Layer na liště Georeferencing by měl být zobrazen název souboru, který 
referencujete (např. Slepice_GU.jpg).  

 
Na shapefilu okresů vyberte přes pravou myš Zoom to Layer, v Data View uvidíte okresy, 

nikoliv obrázek. Upravte si vrstvu okresů tak, abyste viděli jen hranice, ty zvýrazněte (tloušťkou, 
barvou). Zadejte z menu Georeferencing příkaz Fit to Display. Zobrazí se Vám obrázek i vektrory 
(okresy) současně, ne ale přesně na sobě.  

 
Pomocí nástroje Add Control Points zadejte vlícovací body – tedy body, které identifikujete 

jak na obrázku, tak na vektoru. Nejprve se klikne na místo na obrázku, potom na odpovídající místo 
na vektoru. Body musí být minimálně 4, pravidelně rozmístěné. Při vkládání bodů se obrázek posune 
do polohy dané vlícovacími body, s přidáním dalších bodů se vždycky zpřesní. V momentě, kdy 
vektory přibližně „sedí“ na obrázku, se může přejít na další krok Georeferencing → Rectify. 
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V předchozím dialogu může Cell Size zůstat, jako metodu převzorkování vyplňte Nearest 
Neighbor, zkontrolujte umístění výsledného transformovaného obrázku, zadejte požadovaný 
formát (např. JPG) a uložte. V zadaném adresáři vznikne nový soubor, který si potom nahrajete do 
ArcMapu.  

Měl by se správně umístit vzhledem k vektorům. V tomto okamžiku můžete odstranit 
původní obrázek, jakmile ho odstraníte, zmizí i křížky vlícovacích bodů. Tímto je georeferencování 
skončeno. 

Georeferencování nemusíme provádět pouze s rastrem a vektorovou vrstvou se známým 
souřadným systémem. Stejným způsobem lze pracovat s dvěma rastry, nebo dvěma vektory, kde má 
vždy jeden z nich nadefinován souřadný systém. 
 
 
Vektorizace podkladů: 
 

Vektorizace je jedna z nejpoužívanějších metod vytváření prostorových dat, jedná se o jeden 
ze způsobů digitalizace. Dříve se k převodu papírových map do digitální podoby používala zařízení 
nazývaná digitizéry, která byla připojená k počítači.  

Dnes je postup z hlediska vlastního snímání velmi podobný, liší se jen v tom, že se celý 
odehrává na displeji pracovní stanice (počítače) nad rastrovou mapou, plánem, leteckým snímkem, 
webovou mapovou službou apod. V ArcMap používáme funkci Editing (viz dále). 
 

o Editace v prostředí ArcMap:  
 
Nejprve vytvořte novou, v našem případě polygonovou, vrstvu (tj. shapefile). Je též možné použít již 
vytvořený shapefile např. okresů, který rozkrájíme na menší části. 
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Spusťte lištu nástrojů pro editaci: View → Toolbars → Editing  
Nebo PTM do šedé plochy, kde jsou umístěny ostatní ovládací lišty, a zatrhněte Editor.  
 
Pokud máte v Data Frame více vrstev, dávejte pozor, kterou editujete! 
 

 
 
Základním nástrojem je Create Features, kterým kreslíme vertexy budoucích polygonů. 

 
 

V nabídce Feature Construction, která se objeví při kreslení nových tvarů, nebo též na liště 
Editing naleznete mj. tlačítko pro rovný segment, pravý úhel, kruhovou výseč i úseč, Bezierovu křivku, 
průsečík nebo též tzv. Trace Tool, pomocí něhož lze obkreslit i jiné téma, než je právě editované 
(musí být ale vybrané). Na liště se nacházejí i jiné praktické nástroje:  

 
- Edit Vertices – posouvání s vertexy vybraného polygonu  

- Reshape Features Tool  
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- Cut Polygons Tool  

 
 

 
 
- Split Tool – rozdělování čar  

- Rotate Tool – otočení tvaru  
 
Lze také použít některé přednastavené tvary, viz obr.: 
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Povšimněte si zejména nástroje Auto Complete Polygon: 

 
 
Dokončení tvaru se provede klávesou F2 nebo dvojklikem.  
 

V hlavním menu na liště jsou ještě další nástroje – Move (posun o zadané hodnoty), Buffer 
(zvětší polygon o obalovou zónu), Merge (sloučení polygonů), Clip (ořeže o zadanou hodnotu)… Dále 
je u editačních úkonů možné nastavit vzdálenosti, úhly nebo souřadnice pro přesné kreslení v 
prostoru.  
 

Důležité je také přichytávání, tzv. snapping. Přichytávat lze jak na vertexy, tak na body na 
úsečce, na konec úsečky, na její střed, na průsečík, … Používání přichytávání sníží výskyt 
topologických chyb.  
 

Jak docílit správné editace bez „hluchých míst“, nedotahů, přetahů, překryvů apod.:  
- Nakreslit velký polygon a ten pak rozčleňovat pomocí nástroje Cut Polygons Tool, tímto způsobem 
lze dělit již existující shapefile např. okresů.  
 
- Editovat polygony jednotlivě a přidávat je k sobě nástrojem Auto Complete Polygon nebo sousední 
hrany řešit nástrojem Trace  
 
Nezapomeňte průběžně ukládat a na konci ukončit editaci pomocí Stop editing!!  
Během editace geometrie samotné, případně po ní je nutné doplnit atributovou tabulku o zónách 
zpracovávaných témat. 
 
 
Ořez vrstvy: 
 
- nástroj Clip slouží k ořezání objektů libovolné vektorové vrstvy podle objektů polygonové vrstvy  
- ArcToolBox → Analysis Tools → Extract → Clip nebo záložka Geoprocessing → Clip 
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- Ořez rastrové vrstvy podle polygonové vrstvy 

Data Management Tools -> Raster -> Raster Processing -> Clip (ve starších verzích ArcGIS 
nazýváno Crop) 
 

 
 

 
Vizualizace rastru: 
 
Stretched – plynulý přechod od min. do max. hodnoty použité barevné škály, pro jednu složku RGB  
RGB Composite – stejná metoda jako u předchozího, kombinuje červené, zelené a modré pásmo  
Classified – rozdělení do intervalů, pro jedno pásmo  
Unique Values – definování barvy pro jednotlivé hodnoty buněk  
Colormap – přednastavené barvy  
Discrete Color – náhodné přiřazení barev  
 

Ne vždy lze nastavit všechny možnosti, záleží na konkrétním formátu dat. Obrácení škály se 
provede u možnosti Stretched pomocí chechboxu Invert, v případě možnosti Classified se klikne na 
Symbol → Flip colors.  

 
Úprava barevné škály – pravé tlačítko myši na škálu → Properties, pro uchování Save to Style 

(jinak je nově vytvořená škála jen dočasná). Checkbox Use hillshade effect zajistí stínování např. 
reliéfu.  
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Nástroj Spatial Analyst Tools → Extraction → Extrakt by Mask ořeže rastr podle jiné rastrové 
vrstvy stejně, jako to provede Clip u vektorů.  
 

 
 
 
Definování relativní cesty k souborům: 
 
- v ArcGISu je možné nadefinovat relativní cestu k použitým datovým vrstvám, aby se i např. po 
přesunutí celé složky data v projektu (*.mxd) zobrazovala správně  
- File → Map Document Properties - zaškrtneme "Store relative pathnames to data sources" 
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Zadání cvičení č. 2: 
 

Vytvořte mapu vybraného tématu:  
- Atlas podnebí ČSR (1958): Počátek sázení pozdních bramborů (pro okres svého trvalého bydliště a 
okres sousední)  
- Atlas rajonizace zemědělské výroby ČSR (1959): Přehledná mapa zón vhodnosti chovu slepic (pro 
okres svého trvalého bydliště).  
 

Nejprve skenovaný podklad správně georeferencujte a poté zvolenou oblast vektorizujte. 
Přidejte podkladové vrstvy (potřebné vrstvy z ArcČR 500 si zkopírujte do vlastního adresáře!!) a další 
náležitosti tak, aby výsledná mapa obsahovala:  
- Tematický obsah mapy vč. hranic areálů, pro něž vytvořte vlastní barevnou stupnici  

- Topografický podklad – říční síť a vodní plochy, lesy, hranice okresů, vybraná plošná a bodová sídla, 
popřípadě další vrstvy jako jsou pozemní komunikace, železnice... dalším nápadům se meze 
nekladou;) Pro podklad volte decentní barvy tak, aby byl vidět a zároveň nepřehlušoval hlavní téma 
mapy, pracujte s transparentností. Dbejte na správné pořadí vrstev nad sebou. Alespoň u sídel a 
významných vodních toků přidejte popisky, nevhodně umístěný popis posuňte.  

- Správně vytvořenou a upořádanou legendu  

- Všechny ostatní povinné kompoziční prvky mapy, nezapomeňte uvést zdroje mapy.  
 
Požadovanému měřítku 1 : 300 000 přizpůsobte jak formát stránky, tak její orientaci. Při hodnocení 
mapy se budou brát v potaz i estetické kvality výsledné kompozice.  
 
Mapu včetně stručného popisu postupu práce odevzdejte v požadovaném formátu pro protokoly 
v tomto předmětu do odevzdávárny v ISu do 14 dnů od zadání, tj. do 24. 3., resp. 25. 3. 
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