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Disclaimer
Stereonet 9.5 is distributed on an "as is" basis without any warranty, explicit or 

implicit.  The author will not be liable for direct, indirect, incidental, or consequential 
damages resulting from any defect in this software or this user's manual, even if he has 
been previously been made aware of the defect. Furthermore, I make no systematic ef-
fort to inform all users of either bug fixes or upgrades. This program may not be sold or 
offered as an inducement to buy any other product. 

Referencing this Program
The science behind the algorithms in Stereonet 9.5 can be found in the following 

references:

Allmendinger, R. W., Cardozo, N., and Fisher, D., 2012, Structural geology algorithms: 
Vectors and tensors in structural geology: Cambridge University Press (book to 
be published in early 2012).

Cardozo, N., and Allmendinger, R.W., 2013, Spherical projections with OSXStereonet: 
Computers & Geosciences, v. 51, p. 193 – 205, doi:10.1016/j.cageo.2012.07.021.

Please refer to this publication in any study or presentation that result from the use of 
this program.

Credits
Stereonet 9.5 was written by Richard W. Allmendinger; the interface for the pro-

gram is modeled after Stereonet3D by Néstor Cardozo and Richard Allmendinger. The 
rotation algorithm has been completely rewritten from one originally written by Randy 
Marrett.  The  contouring  algorithm used is  “conrec”  by  Paul  Bourke  (1987).  The  ei-
genvalue and eigenvector routines have been modified from the book Numerical Recipes. 
The PDF classes included in this program are from pdfFile by Toby W. Rush Copyright 
© 2004. I am particularly grateful to comments and advice from Néstor Cardozo during 
the development of this program and for sharing many other programming adventures. 
Finally, to all of you who have taken time to report bugs or, better still, just written to 
say thank you, I really appreciated it!

Introduction
Stereonet 9.5 is a complete rewrite of my venerable, but aging, stereonet plotting 

program for Windows, originally called “StereoWin”. The program has a revamped, 
and vastly improved, user interface, includes all  of the scientific functionality of the 
older versions, and will work just fine on modern operating systems such as Mac OS X 
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and Windows 7 and higher. The functionality and interface of the program has been 
modeled after Stereonet3D by Néstor Cardozo and Richard W. Allmendinger. The only 
difference is that Stereonet3D uses an interface with a main window and two drawer 
windows that can be opened and closed at will, whereas Stereonet 9.5 version uses a 
single window with several different panes for different interface elements (Fig. 1) .1

 The figures throughout this manual are from the Macintosh version of the program but Windows and 1

Linux version are functionally identical.
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Entering and Saving Data

Entering new data

To enter  a  new data  set  into  the 
program,  use  the  pull-down menu next 
to the label “New data set” or use the se-
lections  in  the  Data>New  Data  Set>  
submenu. Stereonet supports five differ-
ent data types as shown in the figure to 
the  right.  As  soon  as  you  release  the 
menu, a new data set of the highlighted 
type will be created and the first datum 
in the data set  will  also be created and 
selected ready for you to type in the ori-
entation.  In  the  example  shown  in  the 
figure  one  would  first  type  the  trend 
measurement,  then press the tab key to 
move to the plunge column to enter the 
plunge measurement.  After entering the 
plunge, if you press the Return Key, a second line will be added automatically to enter 
another line of data. Alternatively, you can click the “+” button beneath the data listing 
pane to add a new line of data.

If you need to enter more details about your data — latitude, longitude, eleva-
tion, date, time, and free form notes — you can open Window>Data Details and enter 
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lines and planes in that dialog box. This dialog box can only accommodate planes data 
in right-hand-rule format, but has the obvious advantage that you can see exactly where 
the datum is located by clicking “Map Location” to show the datum in Google Satellite, 
terrain, or roadmap view.

If  you are  entering rakes  of  lines 
on planes, Stereonet 9.5 will create both a 
lines data set and a planes data set (figure 
to the right). These two data sets must be 
given the same name.  If  you delete  the 
planes data set (or change its name), you 
will  still  be able to show the lines data, 
but you will not be able to display it us-
ing the rake (RK) format.

The name of the data set can be edited at any time by clicking on the name (e.g., 
“Untitled Lines”) and then typing in whatever you want. It is useful to give the data 
sets sensible names because those are used in various operations (e.g., poles to planes, 
rotations) and are saved as part of the binary file. Note that you can set the default for-
mat for newly entered data by selecting Preferences.

Entering New Data with Mouse

You can also add data by clicking the mouse inside the primitive of the stereonet. 
To enable this option, select “Enter with mouse” from the Data Menu. A message will 
appear explaining how to plot lines and planes (Figure below). Anytime “Enter with 
mouse” is checked, you can enter a new line by holding down the Shift Key while click-
ing, or enter a new plane by holding down the Option or Alt Key. In both cases, the da-
tum is  entered when you release the mouse,  not  when you click the mouse.  When 
choosing a new plane this way, the place that you click the mouse becomes the pole to 

- � -8



the plane; as you drag to move the pole around, the corresponding great circle is dis-
played. The first time you enter data with the mouse, it will be placed in a special data 
set named “ad hoc lines” or “ad hoc planes”. Any subsequent lines or planes added 
with the mouse will be added to the same ad hoc data set, rather than creating a new 
data set. As long as Stereonet 9.5 finds either of those two data sets listed, data entered 
with the mouse will be added to the existing data set. You can, of course, change the 
name of the data set to whatever you want; however, when you do so the program will 
then create a new “ad hoc lines” or “ad hoc planes” data set for any subsequent lines or 
planes entered with the mouse. In practice, these ad hoc data sets will most likely be 
used for temporary constructions. You can turn them off with the appropriate check-
boxes or delete them entirely once you are done. They are saved with the binary file.

Setting Data Format Preferences

From the Preferences menu choice under 
the  Windows  Menu  (Windows)  or  Application 
Menu (Mac OS X) you can select the default for-
mats  for  new  data  sets.  To  set  default  colors, 
styles,  line  weights,  point  sizes,  etc.,  set  all  of 
those  features  in  the  Inspector,  then  check  the 
box, “Set to current settings in Inspector” before 
clicking Okay in the Preferences dialog. You can 
also set the default window size on startup.

Deleting Data

You can delete an individual datum by selecting the line of data in the data list 
pane and then pressing the “–” button located beneath the data list pane in the bottom 
right corner of the window. The datum will be deleted and the remaining lines beneath 
the datum will be shifted upwards. If you have a multiple selection in the data list pane, 
only the first line of data will be deleted.

To delete an entire data set, selected in the Data Set pane and then press the “–” 
button located beneath the data set pane (i.e., to the right of the add data drop-down 
menu). The data set and all of its associated data will be deleted.

No warning is given when you press the “–” for either data sets or individual 
lines of data!! They are simply deleted.
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Opening a Data File

Importing text files with Stereonet formatting code

Using the “Import Text File” command under the File Menu, you can read in a 
text file that has a two letter header on the first line of the text file. These were the only 
sorts of files that could be used with StereoWin and versions of Stereonet for Mac ver-
sions 6 and earlier. The following table has a description of the two letter codes that 
Stereonet 9.5 recognizes:

Data 
Type Code Example Description

Lines

TP 277, 42
The trend value appears first, followed by the plunge. A 
negative plunge indicates a vector pointing into the upper 
hemisphere.

PT 42, 277 The plunge value appears first, followed by the trend.

PQ 42 N 83 W
The plunge value appears first, followed by the trend, given in 
quadrant format.  The trend must contain a letter (N, E, S, W), a 
number between 0 and 90, and another letter (N, E, S, W).

LL 41, -76
The latitude of the point appears first, followed by the Longitude. 
South latitude and west longitude are given as negative 
numbers.

RK 123 23 E 45
Lines are specified as a rake (pitch) in a plane. The plane 
orientation is given first in AD format, followed by the rake from 
the given strike azimuth.

Planes

AD 320 25 W
Strike azimuth between 0 and 360° is given first, followed by the 
dip magnitude, and then a letter specifying the quadrant (N, E, 
S, W) of the dip direction.

AZ 140 25

This format assumes that the dip azimuth is located clockwise 
from the strike azimuth.  In other words, if you give a strike of 
137, Stereonet will assume that the dip azimuth is 227 (to the 
southwest).  In this example, if your dip is to the northeast then 
you should specify a strike azimuth of 317.  This is the format 
that Stereonet uses for all of its internal calculations, even if you 
don't enter it that way.

QD N 40 W 25 W

In this format, you can report any bearing with respect to N, S, E, 
or W.  For example, the program will correctly interpret W 50 N 
the same as N 40 W.  Only the first letter is significant for the 
compass directions (SW is interpreted as S).

DD 25, 230 A format more commonly used in Europe.  Note that the dip 
magnitude (vertical angle) comes before the dip azimuth.
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Following the two line header, there were any number of lines, each with only one da-
tum (e.g., trend and plunge, or strike and dip) followed by a return character. The val-
ues on the line can be separated by a comma, space, tab or any combination.

Opening column formatted text files (e.g., from spreadsheet programs)

Stereonet 9.5 can also parse any text file that has be formatted into columns using 
a separator character. The program parses the columns automatically: if tab characters 
are present they will be used as a separator; if tabs are absent, commas will be used and 
if commas are absent, spaces will be used. In the latter case, the program assumes that 
contiguous spaces are a single separator, so this is clearly the least desirable option for 
such files. The Parse Text File dialog box is shown, below

�

The labels and numbers of popup menus for columns changes depending on what is 
selected in the popup menu “The data in this file are:”. Simply chose the column in 
which each data type appears and Stereonet 9.5 will read in the column. You can skip 
specific rows of data by deselecting the checkbox on the left side. For many people, this 
will be the most convenient way to enter details such as location information, etc.

Opening Column-formatted Text on the Clipboard

You can also enter or add column formatted data from the system Clipboard. If 
you want to add data to an existing data set, select the data set in the data set list box; if 
instead you want to create a new data set, make sure that no data sets are selected in the 
data set list box. Then choose Edit>Paste into Data Set.  The same dialog box as you see 
above will appear allowing you to identify the different columns of data. Make your 
elections and when you click Okay then data will be added to the program.
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Moving Data from One Data Set to Another

You can combine data from two existing data sets by selecting the data that you 
want to move in the data list box (non-contiguous selections are okay) and choosing 
Edit>Copy All Data. Then, select the data set the you wish to add the data to in the Data 
Set List Box and select Edit>Paste into Data Set. The selected data from the first data set 
will be added to the second data set; the first data set will remain unmodified. If you 
want to keep both data sets unmodified, create a new blank data set of the appropriate 
type, first, and then Copy all Data from both old data sets and paste into the new data 
set. Note that you cannot use the normal copy and paste commands because they will 
not capture all of the data.

Opening Stereonet 9.5 Native Files

Stereonet 9.5 introduces a new binary file format that, in a single file, contains not 
only all of the data sets entered, but also all of the settings at the time the file was saved. 
This includes all of the formatting you have applied to the stereonet (e.g., colors, grid 
spacing, projection, etc.), the data (e.g., colors,  symbols, line weights, etc.), the plot it-
self, and the contents of the Analysis pane. Opening a Stereonet 9.5 native file is just like 
picking up exactly where you left off when you last saved the file. Stereonet 9.5 can read 
Stereonet 7 binary files, but Stereonet 7 cannot read Stereonet 9.5 binaries! Older version 
of the program cannot read binary files created by newer versions of the program.

Saving Data Files

Likewise, Stereonet 9.5 can save data files in two formats:

Exporting Text Files

You can export text  files in two flavors:  if 
you want to save a text file with a two line header, 
just  like  older  version  of  Stereonet/StereoWin, 
choose Stereonet  6  Format.  Lines are only saved 
with the TP (trend, plunge) format and planes are 
saved only with the AD (Azimuth Dip, i.e., right 
hand rule) format. Use export text file if you want 
to exchange data with Stereonet3D or with older 
versions of Stereonet/StereoWin.

You can also save text files in Table format. 
In this flavor, you get a one line header with column labels and you save all of the loca-
tion information (longitude, latitude, elevation, notes) as well as the orientation data. 
These file can be read back in to Stereonet 9.5 using the Parse Text File option, above.

In either case, only the selected data set is saved.
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Save Stereonet 9.5 Native (Binary) File

The “Save As…” command under the file menu saves a Stereonet 9.5 native (bi-
nary) file with the file suffix “.stnt”, which can only be read by Stereonet 9.5. As de-
scribed above, these files contain an exact copy of the state of the program and data at 
the time that you save the file. The Stereonet 9.5 native file cannot be read by any previ-
ous version of Stereonet. Stereonet 9.5 (but not earlier versions) can also save a binary 
file in the Stereonet v. 8.8 format, providing some backwards compatibility. To do so, 
hold down the Shift Key and the Option (Mac) or Alt (Windows) Keys while choosing 
File>Save As…

Choosing which data to plot or analyze
Stereonet 9.5 will only plot or analyze data that are checked in the Data Set and 

Data List panes to the right of the plot. The program makes it easy to link data in the 
plot to the table in the data list box by highlighting selected points and planes in yellow, 
an effect I call the “selection halo”. If you click on a point in the plot, the row will be se-
lected in the table, and clicking on a row provides a selection halo in the Plot Window. 
You can multiple, non-contiguous selections in the table of the Data List pane by com-
mand clicking the rows of interest. From the Data Menu, or equivalent popup menu in 
the Data Drawer accessed by right-clicking, you can toggle on or off selected data.

The Toggle On and Off commands in the Data Menu can be very powerful when 
combined the ability to sort rows by clicking on a column in the table of the data list 
pane. The first time you click a column heading all the rows will sort ascending, the 
next click will sort descending according to the value in the column clicked. To return to 
the original sorting, click the “No.” heading of the column farthest to the left. Once sort-
ed by whatever criteria you want, you can then select the range of rows that fits your 
criteria and Toggle Off the rest of the data set.

Stereonet  9.5  also  allows  you  to 
search a single data set or all data sets for 
matching  parameters  by  selecting 
Data>Search which will give you the dia-
log to the right. Here you can specify any 
combination of  matching tag criteria  by 
checking the checkbox to the left  of  the 
name. In the example shown to the right, 
pressing  “select”  will  toggle  on  only 
those measurements in the currently se-
lected data set that have trends between 
350 and 010°, elevations between 800 and 
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1200, and contain the phrase “Salar Grande” in the notes field. If you elect to search 
across all data sets, then the trend or the strike will be between 350 and 010°, etc. Click 
select opposite to toggle on those measurements which do NOT meet the entered crite-
ria. Finally, the “Restore All” button will turn on all measurements in all data files.

Plotting Your Data

Stereonet 9.5 will plot whatever options are checked in the Plot menu. Select a 
plot type once to turn it on and a second time to turn it off; the plot will automatically 
change to reflect your selections. If a plot option is checked at the time of data entry, the 
points (or great or small circles) will appear interactively as you enter each datum. The 
same plotting options are applied to all checked date sets in the Data Set pane. For ex-
ample, turning on scatter will make a scatter plot for all lines data sets. If you do not 
want a data set to appear in a plot, then turn it off by unchecking it in the Data Set pane. 
As described above, only data that are checked in the Data List Pane will be plotted.

Plotting is specific to data set type. For example, you cannot contour a Planes 
data set. To produce a contour diagram of poles to planes, you must first make a Lines 
data set containing the poles, which you do by choosing “Poles” from the Calculation 
Menu.

Several plot types are specific to lines, or vector, data. These include: Contour, 
Cylindrical Best Fit, Conical Best Fit, and Mean Vector. As of version 9.5 you can now 
choose to perform these plots/analyses on an individual data set basis by using the 
submenu options as shown in the following figure. The submenu for Cylindrical Best 
Fit is shown but appears exactly the same for the other three submenus. To turn on plot-
ting for all data sets, select “All Data Sets” from the submenu. To turn off plotting for all 
data sets, choose “No Data Sets” or select “All Data Sets” a second time (to uncheck it). 
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Beneath those two options, the lines data sets are listed by their name in the Data Set 
Listbox. The checked data sets are the ones being plotted.You can make different choices 
for different types of analyses. The figure shows that contouring is turned on for data 
sets “first” and “third”, cylindrical best fit also for the same two data sets, but mean vec-
tor is turned on for only data set “second”.

Some of the options in the Plot menu write the results of the underlying analysis 
to the Analysis Pane. For example, if you choose Mean Vector from the Plot menu, the 
mean vector statistics will also be written to the Analysis pane. At any time, you can 
erase extraneous information that you don’t need from the Analysis pane by selecting it 
and pressing the delete key on the keyboard.

Changing the Appearance of Your Plot using the Inspector

The  appearance  or  formatting  of  your  plot,  including  the  type  of  projection 
(equal area or equal angle) is controlled by the Inspector, which is accessed from the 
View Menu. There are a large number of choices in the Inspector, thus giving you many 
options for formatting the plot to your liking. Any change that you make in the Inspec-
tor is immediately reflected in the plot.

Stereonet Tab

The first  tab of  the Inspector con-
trols  the  appearance  of  the  stereonet,  it-
self. Here, you can set the projection, grid 
spacing,  colors,  etc.  If  you  select  “Polar 
Grid”,the small circles will be centered on 
the  center  of  the  projection;  otherwise, 
they  will  be  centered  on  the  north  and 
south poles of the projection. You can turn 
off the grid or the fill color for the stere-
onet.  To  change  a  color,  click  on  the 
beveled  color  box  to  get  the  standard 
Windows or Mac color picker in order to 
chose a new color.

Data Sets Tab

The  second  tab  controls  the  ap-
pearance  of  individual  data  sets.  The 
changes you make in this tab apply only 
to the data set that is selected in the Data 
Set  Pane  and/or  using  the  pop-down 
menu next to the “Data set:” label in the 
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tab. If you have three lines data sets en-
tered, only the one that is selected will ac-
quire  the  properties  that  you  enter.  The 
appearance of this tab changes depending 
on which of the five data types are select-
ed. Lines can be assigned one of four dif-
ferent symbol types, either hollow or sol-
id, and can have any color. “Plot as con-
nected line segments” only applies if you 
have entered a latitude-longitude data set 
(line  format  type  “LL”).  Lines  can  have 
either positive (lower hemisphere) or neg-
ative (upper hemisphere)  plunges.  Stere-
onet  9.5  always  plots  negative  plunges 
with the same symbol and color, but op-
posite hollow-type than positive plunges. 
For example, if a single lines data set is set 
to  use  hollow  triangles,  any  negative 
plunges will be plotted as solid triangles 
(or  vice  versa).  You  can  choose  to  plot 
negative  plunges  in  either  the  upper  or 
the lower hemisphere,  but they will  still 
have the opposite hollow setting from the 
positive plunges in the data set.  Small cir-
cles always break across the primitive, but 
you can select to plot the small circle en-
tirely  in  the  upper  or  the  lower  hemi-
sphere.

Analyses Tab

The third tab controls the appear-
ance of various types of analyses that you 
can apply to your data such as Bingham 
Axes (Cylindrical Best Fit), the mean vec-
tor,  and rose diagrams. If  the “use indi-
vidual  data  set  colors  and  symbols  is 
used” the colors that you set here will be 
overridden  by  the  existing  colors  which 
have been set for the individual lines and 
planes files. This is a global setting for all 
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analyses on this tab. 

If your data set has both positive and negative plunges, as is common with pale-
omagnetic data sets, you can choose to plot a separate mean vector for positive and 
negative populations, and chose to plot the negative mean vector in the lower hemi-
sphere. Doing so would be equivalent to performing a paleomagnetic reversal test.

For the Rose Diagram, you would typically set the perimeter value to be slightly 
larger than the scale of the largest petal, but you can set any value here, which allows 
you to compare different data sets. Statistically, it is more valid to scale the petals by 
area rather than length, though the majority of published diagrams are scaled by length 
because the concentrations look more impressive (than they really are!). Stereonet uses 
scale by area if checked; otherwise it scales by length. You can also treat the data as axes 
with no directional significance rather than as vectors. If treated as axes, Krumbein’s 
mean vector is calculated rather than the standard mean vector.

Contour Tab

The fourth tab is where you specify whether you want Kamb or 1% area contour-
ing and control the appearance of your contour plots. Like the items on the Analyses 
Tab, changes in the Contours Tab apply to all lines data sets. If you want to plot the con-
tour lines with the same color as used for the different lines data sets, make sure that 
“Use individual data set colors and sym-
bols”  at  the  top of  the  Analyses  Tab  is 
checked. The contour interval is appropri-
ate to both Kamb and 1% area contouring, 
but  the  significance  is  only  pertinent  to 
the former. The resolution of the counting 
grid is controlled by the pop-down menu, 
with choices of 20, 30, or 40. Note that a 
higher  resolution  grid  takes  more  time 
and, especially with smaller data sets can 
introduce  insignificant  detail  when 
smoothing is actually called for. You can 
turn  on  or  off  contour  lines  with  the 
checkbox of that name. Color sets the col-
or for the contour lines (for all data sets) 
assuming that it is not overridden by the 
“Use  individual  data  sets  colors…” 
checkbox.  The  Contour fill  checkbox  de-
termines  whether  the  contoured  regions 
are filled or empty. Finally, four different 
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contour color ramps are available from the pop-down menu: Rainbow, monochrome 
(gray scale), blue scale or red scale. The opacity of the fill is controlled with the slider.

The Terzaghi Correction is intended for data that you sample along a 1-D linear 
transect (borehole, etc.), which can be biased by the fact that you are very unlikely to 
sample a representative number of structures that trend sub-parallel or parallel to your 
sampling line. As Randy Marrett explained it to me, to apply the Terzaghi correction for 
this bias, you just multiply the value at each counting node times 1/cos(angle between 
the sample line and the counting node). The trend and plunge that you enter in the In-
spector’s Contours Tab gives the orientation of the sampling line or transect. Counting 
nodes that are parallel to the sample line should have a value of infinity, but that would 
result in an awful lot of contours, so you must specify some upper maximum value, the 
default value being 10.

Changing the View Direction of Your Plot

Structural geologists are accustomed to viewing the stereonet as a lower hemi-
sphere  projection,  as  if  one  were  looking  vertically  downward.  However,  there  are 
many  times  when  a  different 
frame of reference is better. For ex-
ample, you may want to plot data 
in  the  plane of  a  cross  section (a 
view direction which is horizontal 
and perpendicular to the azimuth 
of the cross section), or in the pro-
file plane (down plunge view) of a 
cylindrical  fold  (a  view  direction 
parallel to the fold axis). Of course, 
you  can  do  this  by  rotating  all 
your  data,  but  it  can be  a  bit  te-
dious, and you don’t have and vi-
sualization  aids.  Stereonet  allows 
you  to  set  any  view  direction 
without  having  to  rotate  all  of 
your data.

When you choose “Set View 
Direction…” under the plot menu, 
the dialog box will  appear to the 
right.  The  trend  and  plunge  that 
you  enter  in  this  dialog  will  be-
come the new center of the projec-
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tion and the primitive plane perpendicular to that direction. You can easily return to the 
default view of North-East-Down by clicking the “Default View” button in the set view 
dialog box. You do not need to enter any values first. The following diagram shows the 
relationship between the Cartesian coordinates of a normal geographic stereographic 
projection (in black) and those of the new view (in red).

The new view coordinate system axes are plotted at the same position as the old 
axes. For example, the new X´3 is plotted in the center of the net at the same place as the 
old X3.  Stereonet does not modify your data in any way; you will see no change in the 
orientations in the Data List box. 

To maintain a sense of orientation, I highly recommend that you have “Show 
Grid” turned on in Preferences; Stereonet will then plot the rotated grid, with the great 
circles intersecting at the north or south pole. This essentially lets you see both coordi-
nate systems at once. For the values shown in the above dialog, the rotated grid with 
the new and old coordinate systems, is shown below. Note that for the entered values, 
X1, X2, and X3 are all positive, but other view directions can result in negative axes be-
ing plotted.

When you click and hold down the mouse on the stereonet, the orientation that 
you see is in geographic coordinates. That is, if you click on the pole in the above dia-
gram, the trend and plunge will show “T&P = 0, 0”, or perhaps “T&P = 360, 0”. This is 
the fastest way to determine whether or not the pole showing is north or south (the lat-
ter, of course, will have a trend of 180°). Clicking on points above the horizon will show 
negative  plunges,  because these  points  are  plunging upwards into  the  upper  hemi-
sphere,  negative by standard structural  convention.  If  you hold down the shift  key 
while you click on the stereonet, you will see the trend and plunge of the clicked point 
in the new view coordinate system. It is unlikely that you will need this very often!

One potentially confusing aspect of this new capability is the concept of “upper” 
and “lower” hemispheres. Once you set the view direction, the upper hemisphere is the 
one  in  the  direction  opposite  to  the  direction  in  which  you are  looking.  Lines  that 
plunge downward geographically (and thus have positive plunges) may well end up in 
the “upper” hemisphere of the new view. When you choose Scatter or Mean Vector, 
Stereonet will ask you how you want to handle these “upper” hemisphere lines. The 
figure below shows the same data set plotted in geographic coordinates (left) and with a 
view direction of 045°, 37. Note that some of the lines in the left hand graphic have be-
come “upper” hemisphere (to the new view direction) because of the coordinate trans-
formation. In the right, “Plot negative plunges in lower hemisphere has been selected. 
Note that contouring always occurs in the lower hemisphere of the current projection.
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Calculations and Data Analyses

Pole to Planes, Planes from Poles

These to options produce new data sets. In the case of Poles to Planes (if a planes 
data set is selected in the Data Set Listbox) or Planes from Poles (if a lines data set is se-
lected), a new data set is always created with a name taken from the original data set 
preceded by “poles to…” or “planes from…” but you can change the name afterwards if 
you want. Note that, to contour poles to planes, or calculate cylindrical best fit, there 
must actually be a Lines data file which contains the poles to the planes.

Rotations

Rotate Data

Your data can be rotated about an 
axis of  any orientation.  Rotation magni-
tudes  are  positive  if  they  are  clockwise 
looking in the direction of the given az-
imuth  and  plunge  of  the  rotation  axis, 
and  negative  if  they  are  counter-clock-
wise. The data are always rotated as vec-
tors: If the rotation produces a line with a 
negative plunge (pointing into the upper 
hemisphere), it will not be converted into 
a lower hemisphere line.  

As  shown  in  the  rotation  dialog 
box to the right, you have the choice of 
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rotating just the selected data set or all of 
the data sets in the Data Sets Pane. Addi-
tionally, you can specify that the rotation 
replace the existing data sets or that new 
data sets be created. The screen capture to 
the right shows the results of rotating all 
entered  data  and  placing  them  in  new 
data sets.

Unfold Bedding

While Rotate Data rotates and en-
tire data set by the same amount, that is 
not what you want to do if, say, you have 
a  group  of  paleocurrent  measurements 
and the bedding orientations where they 
were  collected  and you want  to  unfold 
them because the rotation of  each pale-
ocurrent  measurement  depends  on  the 
local  bedding  orientation.  You  can  ad-
dress this situation with Unfold Bedding, 
which  gives  you  the  dialog  box  to  the 
right. In the first pop-down menu, choose 
the lines or planes data that you want to 
rotate; in the second choose the bedding 
data set to be rotated back to horizontal. 
A new data set will be created with the 
rotated lines or planes.

Statistical Analyses

I highly recommend that you do not use these statistical analyses blindly but in-
stead actually learn what they mean and when they are appropriate. This section is not 
intended to instruct the user on these techniques, only list some of the key equations. 
Please read the books by Davis (2002), Fisher et al. (1987), Butler (1992), Allmendinger et 
al. (2012), etc. These statistical analyses accessed from the Calculations Menu are carried 
out on the selected lines file in the Data Set Pane and the results written to the Analyses 
Pane. No data sets are modified in any way.

Fisher Vector Distribution

This is the standard mean vector calculation: the direction cosines of all of the in-
dividual unit vectors are simply added up. The mean length reported is just the length 
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of the resultant vector, R, divided by the number of vectors summed, N. The reported 
trend and plunge are derived from the resultant vector normalized to a unit vector. The 
uncertainty intervals are calculated from the following equation:

�

Where p is the probability, N is the number of observations, and R is the resultant vector 
length. Kappa, κ, the dispersion or concentration factor, is estimated from one of the fol-
lowing calculations:

�

For the lower equation, one can find the in literature either (N – 1) or (N – 2) in the nu-
merator. Stereonet uses (N – 1) following following Fisher’s original estimation but you 
should be aware that some authors and programs use (N – 2) (e.g., Davis, 2002).

Bingham Axial Distribution

The Bingham axial distribution is used where the data are axes rather than lines. 
Its most common use is in the cylindrical best fit determination of the fold axes. The 
routine works by calculating the orientation tensor:

�

from the direction cosines of the individual measurements and then calculating the ei-
genvalues and eigenvectors to get the principal axes of the tensor. The first axis corre-
sponds to the greatest concentration of points, the second to the intermediate and the 

cosδα p = 1−
N − R
R

⎛
⎝⎜

⎞
⎠⎟

1
1− p

⎛
⎝⎜

⎞
⎠⎟

1
N−1

−1
⎡

⎣

⎢
⎢

⎤

⎦

⎥
⎥

κ ≈
N

N − R( )

⎛

⎝
⎜⎜

⎞

⎠
⎟⎟ 1− 1

N
⎛

⎝
⎜

⎞

⎠
⎟

⎛

⎝
⎜

⎞

⎠
⎟

2

     for N <16

κ ≈
N −1( )
N − R( )

     for N ≥16

T =

cos2α[i ]∑ cosα[i ] cosβ[i ]∑ cosα[i ] cosγ [i ]∑
cosβ[i ] cosα[i ]∑ cos2 β[i ]∑ cosβ[i ] cosγ [i ]∑
cosγ [i ] cosα[i ]∑ cosγ [i ] cosβ[i ]∑ cos2 γ [i ]∑

⎡

⎣

⎢
⎢
⎢
⎢
⎢
⎢

⎤

⎦

⎥
⎥
⎥
⎥
⎥
⎥

- � -22



third to the smallest concentration; the third axis is usually interpreted as the cylindrical 
fold axis. For more than 25 points, Stereonet calculates the semi-major and minor axes 
of  the error  ellipses  around each principal  axis  following the procedure outlined in 
Fisher et al. (1987).

von Mises Distribution

The von Mises Circular Distribution is similar to the mean vector calculation. It 
corresponds to the sum of the two horizontal direction cosines of horizontal vectors, 
producing a two dimensional horizontal mean vector. the circular variance is given by:

�

And the concentration factor, κ, estimated using lookup tables (Davis, 2002). The error 
on the mean direction is the standard error given by:

�

Where !  is the length of the resultant vector divided by the number of measurements.

Angle between…

Selected Lines, Selected Planes

If two lines are selected in a data set you can 
choose to calculate the angle between them, which 
is  essentially the angle in the plane that  contains 
both lines. Both the angle and the two lines selected 
will be recorded in the Analysis pane.

If two planes are selected in the same data 
set,  the program will calculate not only the angle 
between the two planes but the line of intersection 
as well. The result will be written to the Analysis pane:

σ 2 =
(N − R)
N

σ e =
1
NRκ

R
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-----Angle between Lines | 8/10/2011 at  10:18 PM-----
Angle = 27.1°  or  152.9°
Line of intersection = 016.7,    12.4
Planes selected (RHR):  347.0°, 24.0°    and    259.0°, 14.0°



Finally, you can also use the mouse to click on two points inside the stereonet 
and the angle between those two points will be displayed in a dialog box and you will 
be given the option of writing the results to the Analysis Pane.

Apparent Dip Calculator

You  can  rapidly  calculate  apparent  dip 
problems  by  selecting  Calculations>Apparent 
Dips.  Two  different  options  are  available  by 
clicking the tabs at the top. In the first, you pro-
vide two lines and the program will calculate the 
plane  that  contains  them.  In  the  second,  you 
provide the plane and the program will calculate 
the  apparent  dip  in  the  direction  of  the  given 
trend, or the two trends that have a given plunge 
in the plane of bedding. The results can be writ-
ten to either a new or existing data set for plot-
ting, and can also be written to the plot record. 
The apparent dip calculator is a floating window 
that will stay open until you close it.

Two Planes Calculations

Stereonet can perform an number of cal-
culations on two planes including the acute and 
obtuse bisector, the line of intersection, etc. The 
result of any of these calculations can be written 
to the Analysis pane and can also be added to 
the plot by selecting the appropriate check box-
es. The two planes can be entered manually, or 
you can select  any two planes  within a  single 
data set.

Axial Plane Finder

Stereonet 9.5 can also do some basic fold analysis with Calculations>Axial Plane 
Finder. To use this function, you must select a lines data set that contains the poles to 
bedding before choosing this menu option.  Furthermore,  this analysis only works if 
your folds have relatively planar limbs and sharp hinges such that the bedding poles 
cluster in two distinct groups, one for each limb. Click on the two limb clusters and tell 
the program whether the axial plane bisects the acute or obtuse angles between the 
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limbs. Remember that an obtuse angle between 
the limbs produces an acute angle between the 
poles to the limbs! The program will then calcu-
late and report the trend and plunge of the fold 
axis, the strike and dip of the axial plane, and the 
interlimb angle:

�

The Axial Plane finder window is a floating win-
dow  which  will  stay  open  until  you  close  it. 
While it is open, all clicks in the stereonet will be 
assumed to be clicks on clusters of pole for one 
limb or the other.

Convert to Lower Hemisphere
If you prefer to deal with axes and not vectors, you can select this command  to 

convert all your measurements to the lower hemisphere. Practically, this is only useful if 
your data set has negative plunges or dips. This operation only works on the selected 
data set and, for safety’s sake, creates a new data set rather than overwriting the old. 
Once you have completed the operation, you can delete the old data set if you (really) 
want. 

Direction Cosines
This command will write out the direction cosines of any selected lines, or the 

poles to any selected planes, to the Analysis Window. The entries are tab separated, 
making it easy to copy the results from the Analysis pane and paste them into a spread-
sheet or other document:
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Copying, saving and printing your plot
Once you have the plot just as you like it, you can save it as a PDF file for import 

into other programs. The PDFs produced should be of publication quality and should 
appear identical to, but higher resolution than, the plot window itself. The size of the 
pdf is controlled by the size of the Plot tab in the Main window.  

Alternatively, Stereonet 9.5 can save plots as scalable vector graphics (.svg), an 
open, high resolution vector format that can be read by all major web browsers and 
most modern vector graphics programs (e.g., Illustrator, EazyDraw, etc.). SVG has many 
desirable characteristics and is the best one to use if your graphics program supports 
this format. Note that all modern web browsers can open SVG files and most can then 
export them as PDFs in case you do not have a SVG-capable graphics program.

Finally, you can save your plot in an older vector format by choosing “Save Plot 
as PICT/EMF” which will save the plot as an enhanced metafile format in Windows. 
PDF and SVG output is superior to PICT/EMF and is thus highly recommended .2

Stereonet 9.5 also supports the clipboard. If any text is selected in either the Data 
List or the Analysis Pane, that editable text will be copied to the clipboard. Otherwise 
the Graphic in the Main Window will be copied as vector objects to the clipboard for 
pasting into another application. The application into which you paste the graphic will 
determine the format in which it appears. In Mac OS X, Cocoa applications, it will usu-
ally appear as a Tiff image, whereas Carbon apps will recognize the vectors. The clip-
board uses .EMF quality graphics and thus should not be used for final production 
work if you can help it.

----- Direction Cosines | 8/10/2011 at  10:38 PM-----
Data set: Corral Quemado Paleomag
Datum Trend Plunge   North   East   Down
  15 024.9 -46.7   0.622   0.289 -0.728
  29 212.2   37.9 -0.668 -0.42    0.614
  52 339.3 -59.7   0.472 -0.178 -0.863
  59 200.     45.7 -0.656 -0.239   0.716

----- Direction Cosines | 8/10/2011 at  10:39 PM-----
Data set: BreeCreekNWBdg.txt
Datum Strike   Dip   North   East   Down
  1 201.   49. -0.27   0.705   0.656
  3 340.   25. -0.145 -0.397   0.906
  15 199.   49. -0.246   0.714   0.656
[direction cosines are for the poles to the planes]

 I have had reports that PDF output does not work on German systems. If that is the case, just switch 2

your system to US English for long enough to save the plot as a PDF.
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KML output

Stereonet can export a KML 
file of geographically registered 3D 
strike  and  dip  and  lineation  sym-
bols  for  plotting  in  Google  Earth 
(thanks  to  Tom  Blenkinsop  and 
Nestor Cardozo for the idea). To do 
so,  select  File>Export  Text 
File>KML File….. The dialog box be-
low  shows  the  basic  options  for 
symbols  and  colors;  more  can  be 
chosen if you toggle the disclosure 
triangle at the bottom of the initial 
window. Only the selected data set 
will be saved as KML. Once saved, 
the  file  can  be  opened  inGoogle 
Earth simply by double clicking on 
the file. 

- � -27



The 3D symbols are excellent for teaching purposes.  As the screen capture in 
Google Earth, above, shows, plotting in 3D is excellent for understanding the relation-
ship between the measurement and the 3D geology depicted in Google Earth. It is also 
useful for identifying anomalous strikes and dips — that 70° dip looks suspect to me!

If you use this option, please reference Blenkinsop, T.G., 2012. Visualizing struc-
tural geology: From Excel to Google Earth. Computers & Geosciences 45, 52–56.

Printing

Stereonet 9.5 has a very basic printing routine which will print the graphics in the 
Plot pane, again using .EMF quality graphics. At present, the graphic is printed at the 
size it appears on the screen unless it is larger than 7 inches, in which case it is shrunk to 
fit the screen. The default size of the graphics window produces a stereonet that just fits 
on one page. The text in the Analysis Window/Pane is automatically added beneath the 
stereonet. On the Mac OS X, you can print to PDF as you can in other programs, howev-
er, the pdf that is produced by the save plot as pdf command is higher quality than that 
saved from the print window.

Interactive Features
• Whenever the mouse moves over the stereonet, the trend and plunge at 

the tip of the cursor is displayed in the lower left corner

• Clicking and dragging the  mouse inside the  stereonet  temporarily  dis-
plays a great circle whose pole coincides with the tip of the cursor.

• When “Enter with mouse” is checked under the Data Menu, you can enter 
data by clicking and dragging the mouse inside the stereonet. Hold down 
the Shift Key to enter Lines; hold down the Alt Key to enter Planes.

• Clicking on a data point in the stereonet selects the corresponding row in 
the data table and vice versa.  Multiple, noncontiguous selections are pos-
sible

• Changes made in the Inspector are instantly reflected in the plot

Version History
Version 9.5.0 — 2016.01.03 (Happy New Year!)

• Major new feature: Plotting applied to lines — contouring, cylindrical best 
fit, continual best fit and mean vectors — can now be turned on or off on a 
per data set basis. For example, in a file with three lines data sets, you can 
now choose to contour only the second set, while continuing to display 
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scatter plots of the other data sets. In the plot menu, the contouring, cylin-
drical best fit, continual best fit and mean vector menu choices all now 
have submenus where you can choose: All data sets (to turn on the, say, 
mean vector of all data sets), no data set (turn off plotting mean vector for 
all sets), and a separate menu entry to toggle on or off each individual 
data set depicting the same name as is shown in the Data Sets list box. The 
All Data Sets submenu choice functions exactly as the main menu choice 
in previous versions of Stereonet and has the same key command assigned 
to it.

• New binary file format — to accommodate the new plotting granularity, I 
had to implement a new binary file format. The new version of the pro-
gram can read old file formats, but old versions cannot read the new for-
mat. However, Stereonet can now save a binary file in the previous ver-
sion (back to v. 8.8) for those of you who need backwards compatibility 
with colleagues/students who have not yet updated. To do so, hold down 
the  Shift  and  Option  (Mac)  or  Alt  (Windows)  Keys  while  choosing 
File>Save...

• The choice of Kamb or 1% Area contouring has been moved to the top of 
the Contours tab of the Inspector palette. This was necessary to make the 
submenus in the Plot menu consistent. A benefit of this move is that your 
contouring preference is now saved when you set the Preferences for the 
app.

• Printing from the File menu now correctly scales the plot for the page so 
that none of the symbols are distorted. Note that, although you can use 
File>Print to save a PDF, the File>Save as PDF will produce a higher quali-
ty graphic. The most versatile vector graphic format is File>Save as SVG, 
if  your  graphics  program  supports  scaleable  vector  graphics  (all  web 
browsers support SVG and from the web browser you can export PDF if 
you need to do so). Click here to see an SVG file rendered in your browser.

• Several bugs fixed. Probably lots of new bugs introduced with the above 
changes. I breathlessly await your reports 

Version 9.3.3 — 2015.11.28

• Fixed obscure crashing bug that would happen when a lines data set had 
no points checked.

• PDF and SVG files now follow the specifications set in the Inspector re-
garding the symbol and color used for the mean vector and Bingham axes 
(thanks, Alex!)
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Version 9.3.2 — 2015.09.03

• Fixed a bug that would cause a crash when you chose Edit>Copy All Data 
and then chose Edit>Paste Into Data Set

Version 9.3.1 — 2015.06.03

• Corrected a bug where small circle data would not display correctly

• The mean vector arrow on rose diagrams is always drawn using the rose 
diagram color (not the data set color) set in the Inspector.

Version 9.3.0 — 2015.05.13

• Major improvements to the Rose diagram functionality, including:

• Scale the petals by either length or area (new). Only length was possi-
ble before

• Calculation of the mean direction for axial data (i.e., data with no di-
rectional  significance).  this  is  sometimes  referred  to  as  Krumbein's 
(1939) mean

• Half circle rose diagrams always show Krumbein's mean; full circle di-
agrams can either depict vector azimuths or, if "treat data as axes" is 
checked in the Inspector,  the full  circle  diagrams will  be symmetric 
(this has been a highly requested feature that I've resisted until now!)

• Addition of  a  Von Mises  Distribution option to  the  Calculations  menu 
which displays the same 2D azimuthal statistics as the Rose diagram dis-
plays.  The program now calculates  the circular  variance,  kappa,  and 1 
sigma standard error for azimuthal data.

• Plots wil polar grids can now be saved as .pdf and .svg files 

• Fixed a bug that occurred when planes were being entered in "DD" format 
and the data details window was opened.

Version 9.2.3 — 2015.02.16

• Corrected a bug that where the equator of the stereonet grid (EW line) 
would not be drawn in pdf and svg files if the grid was set to 10°.

Version 9.2.2 — 2015.01.31

• Corrected a bug that would cause Stereonet to crash if a data set required 
more than 100 contour levels (Thanks to Al L.)

Version 9.2.1 — 2015.01.18

• Corrected a bug in reading the notes fields when importing a "Lines & 
Planes" text file
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• Corrected  a  bug  in  saving  data  that  were  imported  using  "Lines  & 
Planes" (Thanks to Gordon W. For helping me track this down)

Version 9.2.0 — 2014.08.18

• View>Hide Unchecked Values removes the unchecked values in the data 
listbox from view.

• The Search Window remembers your last search and automatically selects 
the same box.

• File>Save Plot as PICT/EMF has been disabled (again) because of a still 
unfixed bug in the compiler I use. The only workaround is to use PDF or 
SVG format output (these are higher quality that PICT/EMF, anyway...)

• Bug fixes...
Version 9.1.1 — 2014.07.19

• Data>Batch Annotate now has a Find and Replace panel so you can you 
can batch replace any text in the Notes field for multiple observations

• Rose  diagrams  now  show  the  number  of  observations.  Also  cosmetic 
changes to rose diagram

• Stereonet now remembers selected search criteria between searches

• Corrected a bug that occurred when pasting data into a data set where the 
copied data had return characters in the notes field (those are now re-
placed with semicolons)

• Fixed a rare crashing bug when changing the contour interval in the In-
spector (e.g., completely erasing the old interval value before entering a 
new value)

Version 9.1.0 — 2014.05.29

• New Data>Batch Annotate command for adding the same annotation to 
the Notes field of multiple observations all at once

• Text file and clipboard parsing dialog now allows one to add multiple col-
umns to  the Notes  field by adding comma or  space separated column 
numbers to the new combo box for the notes field. Each column added 
to the notes field is put on a separate line of the notes field.

• The Search dialog now permits you to add the found matches to the exist-
ing checked data so you can sequentially add two subsets together. 

• Stereonet now correctly reads numbers entered in non-U.S. formats. It will 
use the number format specified in the user's system preferences.
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• A minor crashing bug — when the user tried to quit the program when 
there were no open windows — has been fixed

• Fixed a bug in reading the old Stereonet v. 6 rake format text files ("RK")

• Fixed cosmetic issues with reading in the text record from a stereonet bi-
nary file.

Version 9.0.6 — 2014.04.18

• A few bugs associated with deleting data sets squashed (hopefully).

• Stereonet now checks the screen size and forces the window to be smaller 
than the maximum screen size,  even if  a  larger  window size has been 
saved with preferences 

Version 9.0.4 — 2014.03.18

• The Parse Clipboard text dialog no longer appears when Using Edit>Copy 
All Data and then Edit>Paste into Data Set to move data from one data set 
to another within the program

• In the Data Details window, up-down arrows have been added next to the 
datum number text box, allowing one to step easily through a data set, 
one datum at a time.

• A bug changing scale in the extended KML export dialog box has been 
fixed with other minor cosmetic fixes as well.

• The ability to import Stereonet v. 6 files in the old "PQ" format (lines in 
quadrant format, e.g., 45 N 27 W) has been restored.

Version 9.0.3 — 2014.02.11

• Several small cosmetic bugs related to deleting a data set while contouring 
is turned on have been quashed.

• Choosing Data>Enter with Mouse will display a small notification in the 
upper right hand corner of the Plot canvas. This notification also includes 
a reminder about what key to press when clicking the mouse to get lines 
or planes. This notification is NOT saved with the plot.

• The angle between two clicked points window now displays the line and, 
if you are working on the second line, the angle between lines as you drag 
the mouse around. This is particularly useful in conjunction with Enter 
data with mouse: you can, for example, click one point along a great circle 
then click and drag the mouse the exact angular distance along the great 
circle and when you release the mouse, if you are holding the shift key 
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down, the program will plot the second point the specified distance from 
the first.

Version 9.0.1 — 2014.02.06; 9.0.2 — 2014.03.05

• Corrected a bug that would cause Stereonet to crash under certain con-
touring  conditions.  Thanks  to  Mario  Sánchez  Gómez for  help  tracking 
down the bug.

• Corrected a bug reading the Preferences file in versions 8.9.5 and higher. 
Stereonet  9.0.2  will  write  a  brand  new  preferences  file  called  "Stere-
onet9Prefs.txt" to the appropriate location the first time you run it. If you 
have made changes to the default Preferences, you will need to set them 
again and save them via the preferences dialog. Thanks to Myra Keep for 
helping to track this one down.

Version 9.0.0— 2014.01.28

• Added two new color contouring options to choose from

• Corrected numerous cosmetic bugs that reared their ugly heads when a 
contoured diagram had the size of the stereonet changed.

• Contouring  now  works  correctly  when  the  view  direction  is  changed 
from the default

Version 8.9.5, 8.9.6— 2014.01.24

• Happy New Year update — only one new feature but it is a big one...

• Contour Fill! Contours can now be filled with either a monochrome or a 
rainbow set of colors and plotted with or without contour lines. The con-
tour fill can be made partially transparent and multiple datasets can be 
plotted on the same diagram. You can still plot just contour lines.

• some menu items have been disabled at start up if there are no data sets 
entered as selecting them in that condition could cause a crash.

• copyright updated to 2014 :-)

• v. 8.9.6 corrects some screen refresh issues related to the new functionality
Version 8.9.2— 2013.11.24

• Added a new planes format: “DR” which allows one to specify planes as 
Dip Azimuth and dip (e.g.,  242/56)  in addition to the already existing 
“DD” format (e.g., 56/242)

• If you specify either DD or DR formats, the Data Details window will now 
show your planes orientations in those formats rather than in Strike and 
Dip.
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• Added a checkbox to the Inspector to specify a polar grid using either 
equal area or equal angle (without changing the view direction)

• Fixed a bug that caused crashes when using two planes calculations.

• Fixed a bug that caused the “Set Stereonet Radius” (under the View Menu) 
to work incorrectly.

• The trend and plunge display in the plot pane was not showing the correct 
values when the view plunge was not vertical; this has been fixed

• Disabled the Save Plot as PICT/EMF command as several functions that 
were used have been deprecated and cause crashes on modern systems. It 
may or may not be reinstated in the future...

Version 8.9.1— 2013.11.14

• Stereonet’s help file is now accessible from the new Help menu

• The Mac version of Stereonet is now code-signed with my own developer 
certificate from Apple which means that the first time you run it, you no 
longer have to go through the process of right-clicking on it as described 
in the text in the upper left of this page.

Version 8.9.0— 2013.10.21

• You can now import old Stereonet v. 6 format files that used the QD for-
mat (e.g., N 60 W 45 N). Stereonet does not save data in this format, but 
this should help people with legacy files

• The  zoom  slider  for  the  Google  satellite  view  in  the   data  details 
window has now been moved to one side, allowing Windows users to see 
it, perhaps for the first time! Windows users still do not see the strike and 
dip (or trend and plunge symbol) that is seen on Mac versions of the pro-
gram. Sorry...

• You can click the label for the elevation field in the data details window to 
retrieve the elevation of the datum from the MapQuest elevation server 
and will overwrite whatever is already in the elevation field. Any previous 
values are written to the Notes text area of the Data details window.

Version 8.8.9 — 2013.08.28

• Kml symbols can now be output as 2D symbols, which of course, are only 
useful if you are looking straight down in Google Earth

• More bug fixes
Version 8.8.8 — 2013.08.06
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• More bugs related to reading old Stereonet v. 6 format files corrected. Oth-
er bugs also squashed.

Version 8.8.7 — 2013.07.27

• Corrects a bug reading a data file in AD format using commas as delim-
iters where the quadrant was given as two letters (e.g., "SE") rather than 
just one ("S").

• Corrects  a  bug that  would cause a crash when reading more than one 
Stereonet v. 6 format data files.

Version 8.8.6 — 2013.07.04

• Added a horizontal splitter between the data sets and the data list boxes 
on the right hand side of the Window so that you can resize their heights

• Fixed a bug that occurred when deleting a data set

• Fixed a bug where lines entered as rakes could not be selected by clicking 
on them in the stereonet

• Cleaned up some of the code which could, of course, introduce interesting 
new bugs!

Version 8.8.5 — 2013.06.25, rev. 2013.06.27

• cosmetic glitch with the Windows splash screen fixed -- not worth chang-
ing the version number so download it again if you downloaded in the 
last few days.

• A recently introduced version broke the import of Stereonet 6 text files. 
This has now been fixed

• Stereonet now quits correctly on Windows when you close the last remain-
ing open Window

• Tabbing order through dialog boxes has been improved
Version 8.8.4 — 2013.05.13

• corrected a bug in the Edit>Paste into data set routine that was introduced 
by the new compiler

• corrected a bug in the expanded KML save dialog box that you get when 
you hold down the shift key while choosing that option. Also added more 
options for using your own kml symbols.

• Changed the splash screen
Version 8.8.3 — 2013.05.13

• Option-dragging on a text annotation will duplicate the annotation
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• Compiled in a new compiler with minor interface changes

• Corrected another crashing bug related to Calculations>Poles and Calcu-
lations>Planes from Poles that occurred when no other lines (or planes) 
data sets were present

Version 8.8.2 — 2013.05.13

• Corrects  a  crashing bug in  Calculations>Poles  and Calculations>Planes 
from Poles that was introduced in v. 8.7.5. If you have downloaded v. 8.7.5 
or 8.8.1 please replace them with this version.

Version 8.8.1 — 2013.05.30

• Text annotations — Select Edit>Annotate Plot, click on the plot where you 
want the text to begin, enter your text and specify color and size if you 
want and your done. You can reposition existing text annotations simply 
by clicking and dragging then in the plot pane. Handles occur on either 
side of the annotation during the drag operation. Viewing annotations can 
be toggled on or off with Plot>Text Annotations, and annotations can be 
deleted with Edit>Delete All Annotations. Annotations can be up to 64 
characters long. When you right- or control-click on an annotation, you 
will get a contextual menu which will allow you to edit or delete just that 
annotation.

• New binary file format — the addition of text annotations has required a 
new binary file format. Stereonet 8.8 can read all older binary files; older 
versions will NOT be able to read Stereonet 8.8 binary files. Sorry…

• Menu options pertaining to particular types of data sets are only enabled 
if that type of data actually exists. For example, if there are no Lines data 
sets, Plot>Lines will be grayed out and you will not be able to select it.

• The usual bug fixes...
Version 8.7.5 — 2013.05.16

• Drag to reorder the data sets in the Data Sets list box (upper right corner)

• Improvements to text parsing (via files or the clipboard) so that Stereonet 
will work better with files generated by GeoID iPhone app

• You can now copy complete data sets to a new or different document by 
selecting the dataset in the first document, choosing Edit>copy all  data 
then pasting it into the second document with Edit>Paste into data set

• Fixed bug in parsing comma separated values.
Version 8.7.0 — 2013.05.01
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• Half circle rose diagrams now work. Use the checkbox in the Analysis tab 
of the Inspector

• New menu option to clear the plot: Plot>Clear Plot

• Cosmetic improvement to drawing 2° grids

• Fixed some glitches writing the Rose diagram results to the text analysis 
area.

Version 8.6.6 — 2013.04.11

• Two planes calculations — line of intersection, acute and obtuse bisectors, 
and angle between planes

• Convert to Lower hemisphere — new command to force all data to be in 
the lower hemisphere. To protect you from yourself, this command creates 
a new data set rather than overwriting the old one

• You can now see the data for an unchecked, but selected, data set.

• Several graphical glitches concerning the plotting of mean vectors have 
been fixed

• Rose  diagrams are  only  plotted  when the  traditional  view direction  is 
used (looking straight down on the lower hemisphere)

• The four add data sets buttons ("+L", "+P", etc.) were getting out of hand 
so they have been replaced with a single drop-down menu.

• v. 8.6.6 corrects a minor bug in the convert to lower hemisphere routine 
that was introduced in the short lived v. 8.6.5

Version 8.6.0 — 2013.03.24

• Lasso selection now works (but only for lines). You can have it select ei-
ther those points inside or outside the lasso.

• New data type: Arcs. Arcs are segments of great circles that are drawn be-
tween a starting point and an ending point that you define by entering the 
trends and plunges of the corresponding lines. Arcs can cross the primi-
tive and you can choose whether to plot the acute or obtuse angle. You can 
also specify that the program should draw and arrow head at either the 
start or the end of the arc (or both)

• Redesign of the Data Sets tab of the Inspector. Now you only see data per-
tinent to the selected data set. You can select the data set from the popup 
menu in the Inspector or by clicking on it in the Data sets list box.
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• Fixed (hopefully) a bug with copy and paste on Windows version of the 
program

Version 8.5.1, 8.5.2 — 2013.03.06

• Stereonet is now "document based" meaning that you can open as many 
different windows with different plots in them as you want. 

• When you start up the program, the About box is now displayed; you 
should select either the new blank file button or the open file if you want 
to open a Stereonet binary file. At any time, you can choose File>New and 
a new blank window will appear; likewise, file>open allows you to open 
another file while leaving the first one open as well.

• You can now copy and paste data! Select some rows in one data set and 
paste them to a different data set in the same window or to a a dataset in a 
completely different window. You can also copy any tab delimited data 
from any text file (Including an Excel spreadsheet).

• if stereonet doesn't recognize the format of data on the Clipboard, it will 
present you with a dialog box so you can tell it how to parse the clipboard 
data. Use Edit>Copy all data to include the data that only shows up in the 
Data Details Window. To paste into an existing data set, you have to use 
Edit>Paste into Data Set.

• KML export of geographically registered 3D strike and dip and lineation 
symbols  for  plotting  in  Google  Earth  (thanks  to  Tom  Blenkinsop  and 
Nestor Cardozo for the idea). Click here for an example. If you use this op-
tion, please reference Blenkinsop, T.G., 2012. Visualizing structural geolo-
gy: From Excel to Google Earth. Computers & Geosciences 45, 52–56.

• Bug fixes related to not saving the conical best fit with the plot
Version 8.0.4 — 2013.02.14

• Data entry by mouse was broken and is now fixed

• Conical best fit now uses the approach outlined in Mulchrone et al. (2013) 
so that it now works more reliably in the lower hemisphere [oops, not ex-
actly, I'm still working on this.]

• Other bug fixes and improvements
Version 8.0.2 — 2013.01.24

• Fixed various issues related to rake format ("RK") and rake preferences se-
lection, including a rotation bug
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• Fixed window rewriting problems when setting the stereonet size from 
View>Set Stereonet Size.

• Details window now has a "2x" checkbox that will enable you to double 
the size of the satellite image/map

Version 8.0.1 — 2012.11.23 (counter reset)

• Corrected a crashing bug in the Analysis tab of the Inspector when only 
planes were entered

• Added a character count to the Notes field in the Details Window so you 
can tell when you are getting close to the 512 character limit for that field. 
Character count turns red when you exceed 512 characters

Version 8.0.0 — 2012.10.20

• Major  feature:  Plotting  lines  or  planes  on  Google  satellite,  terrain,  or 
roadmap imagery by choosing Window>Data Details

• New native data (binary) format now includes location information plus 
free form notes field where you can write anything about a datum in 512 
characters or less.

• Ability to parse any column oriented text file — particularly useful for en-
tering location data.

• Axial  plane  finder  in  Calculations  menu provides  basic  fold  geometry 
analysis.

• Angle between clicked points now shows trend and plunge while clicking.

• Fixed a bug in adding new data to existing data sets.
Version 7.3.6 — 2012.09.23

• The Mac OS X version of the program is now a native Cocoa app with a 
more modern interface rather than the Carbon app as previously.

• Corrected a bug in the angle between two planes routine

• Corrected a bug introduced in previous version related to saving a new 
default window size from preferences

• Disclosure triangle/arrows now behave in a more "standard" manner
Version 7.3.5 — 2012.09.18

• Scans can now be repositioned by dragging them within the plot window 
by selecting Edit>Drag Image

• Return of the Apparent Dip Calculator! You can use lines or a plane select-
ed in an existing data set, or you can enter new values directly into the di-
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alog box. The results can be written to an existing data file or a new data 
file for plotting. The Apparent Dip Calculator is a floating window that 
you can keep open if you have a lot of calculations to do.

• Default height of the main window has been reduced to 640 pixels to ac-
commodate users who prefer to keep their screen resolutions at low val-
ues (e.g., to increase the size of text on their screens). This will hopefully 
avoid the artifact that cause the text box to overwrite the bottom of the 
plot area. You can still resize the window to larger sizes once the program 
has been opened.

• To compensate for the smaller initial main window size, a a new check box 
in the Preferences dialog, "Set current window size to default", will allow 
you to have set the initial size of the window to whatever you what.

• Removed Plot Planes as Poles option. It was confusing too many people, 
particularly when they couldn't do a cylindrical best fit. Now, if you have 
entered planes and want to plot poles, you will have to choose Calcula-
tions>Poles first (which was the original behavior of the old Stereonet. If it 
turns out that LOTS of people loved plotting planes as poles without cal-
culating poles first, I'll consider reinstating it.

Version 7.3.0

• New Feature — import scans of existing stereonet plots, and overlay be-
neath the live stereonet in the program. You can use this to compare your 
data to published data or, in combination with Data>Enter with Mouse, 
you can extract digital values from published stereonets. Scans can be im-
ported as pdf, tiff, png, or jpeg formats. New Plot menu option allows you 
to show or hide a scan.

• New Feature — SVG (scalable vector  graphics)  output option for  your 
plots. .svg is an open, high resolution graphics format that can be read by 
most modern graphics programs. Unlike other graphics output options in 
Stereonet, .svg saves small and great circles as open polygons rather than 
separate line segments for ease in touching up plots in graphics programs. 
Both .svg and .pdf options are higher resolution than the emf/pict format.

• Bug fixes related to window display.
Version 7.2.4 — 2012.02.21

• Mac version of Stereonet 7 posted for those who need a Carbon program 
that works on Mac OS X operating systems older than 10.6 or for those 
who need compatibility with the Stereonet 7 for Windows binary file for-
mat. For Mac users who have Mac OS X 10.6 or higher installed, I still rec-
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ommend OSXStereonet. Also posted the Linux version of the program as 
I have had a few requests for one of those.

• Corrected bugs related to deleting a data set or an individual datum from 
a data set

• Fixed the default setting for Bingham axes to plot all three axes plus the 
great circle. (The program was defaulting to plotting only the largest prin-
cipal axis)

• Deactivated  the  maximize  button  in  the  main  window  as  it  was  not 
stretching the window elements correctly. You can still resize the window 
to whatever you want by dragging the edge/corner of the window.

• When no data sets are selected in the data sets listbox, no data will be dis-
played in the data listbox.

• Added several informational dialogs:

• If a user tries to delete a data set, they are warned that it is undoable 
and they have the option of canceling

• If a user tries to do a cylindrical best fit when only planes have been 
entered they are now advised that they must calculate the poles first as 
cylindrical best fit only works on lines data sets. Users have been con-
fused because of the option to plot planes as poles.

• If a user tries to rotate a "selected" data set but no data set is selected in 
the data sets list box.

Version 7.2.3 — 2012.01.11

• Now uses GDI+ for anti-aliased (i.e., smoother) drawing to the screen.

• Copyright updated to 2012 :-)
Version 7.2.1 — 2011.11.18

• Variable rotation by unfolding beds.  Choose a lines or planes data set, 
then select the data set that contains bedding where the observations were 
made, and click Okay. each datum will be unfolded by rotating the corre-
sponding bedding back to horizontal.

• Rose diagrams for planes: If the planes format is "AD" or AZ" the rose dia-
gram will be based on the strikes of the planes; if the format is "DD" the 
rose diagram will be based on the dip azimuth rather than the strike az-
imuth.

Version 7.2.0 — 2011.11.07
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• Major new features: enter data with mouse by clicking and dragging in-
side the stereonet.

• Fixed beg where window not resized correctly when reading in a binary 
file

• Fixed bug where program tried to draw error cone even when normalized 
mean vector length was <0.65

Version 7.1.6 & 7.1.7 — 2011.10.26

• Planes can now be drawn as either solid or dashed lines

• If only rose diagrams are showing, the equal area angle grid is not dis-
played. Instead equally spaced concentric circles, at either 5 or 10 percent-
age intervals, and spokes at 10° intervals are drawn and labeled as a scale 
for the rose diagram. This happens automatically and only when rose dia-
grams and nothing else are displayed. The value at the primitive is con-
trolled by the entry in the Inspector Analysis tab.

• The outer edge of rose petals are now drawn as an arc rather than as a sin-
gle straight line segment, which is much more attractive!

• Plot mean vector on rose diagrams has been enabled

• Fixed some interface bugs related to showing or hiding the data panels

• Significantly speeded up selecting tabs in the Inspector -- Yay!
Version 7.1.5 — 2011.09.12

• You can now hide the data set list and data list panes by toggling a disclo-
sure triangle or from the Windows Menu. This makes the overall window 
narrower, which might be of help for people on small screens or if,  for 
some reason, you want to hide the data.

• Various optimizations to improve performance selecting from the Data set 
list.  The Inspector  also appears  more rapidly,  though selecting tabs re-
mains sluggish (sorry…)

• Fixed a bug where reading in a binary file that was saved with a view 
plunge of 90 degrees would be read in with a view plunge that wasn’t ex-
actly 90 degrees

• Fixed a bug associated with calculating poles from planes and planes from 
poles

• Planes can now be visualized as great circles and poles simultaneously
Version 7.1.2 — 2011.09.12
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• Cylindrical best fit now draws the best fitting plane and writes its orienta-
tion to the Analysis text pane,

• When you add a new data set, the appropriate plot type is automatically 
selected so you see your data plotted as you enter it. E.g., if you select new 
lines, Scatter will be turned on in the Plot Menu, etc.

• Preferences dialog box has been added to allow the user to set their pre-
ferred default data format and stereonet format settings.

Version 7.1.1 — 2011.08.30

• Fixed a bug in the Dip, Dip Azimuth (DD) format for planes. Previous 
versions did not handle this format correctly

• Added uncertainty calculations to  the cylindrical  best  fit/Bingham sta-
tistics

• Disabled pop up menu for planes style in Inspector because those options 
have not yet been implemented

• minor bug fixes
Version 7.1.0 — 2011.08.21

• Drawing contour lines has now been implemented. You can now do either 
Kamb or 1% area contouring by selecting one of those options in the Con-
tour submenu of the Plot Menu.

• Contour lines are saved to PDF files and EMF files, they will print, and 
they are copied to the clipboard with the rest of the plot

• Contours do not yet have a fill pattern. Those options have been turned off 
in the Contour tab of the Inspector

• Lots of little bug fixes.
Version 7.0.4 — 2011.08.18

• Yet another new binary data format. Previous files will not read in correct-
ly, so I hope that you have been exporting your data as text files!

• Stereonet can now handle input data of lines as rakes (pitches) on planes. 
To enter a new data set, hold down the shift key while clicking on the +L 
button. This will cause both a new lines and a new planes data set to be 
entered. These data sets should have the same name. The two letter format 
code for such data sets is “RK”.

• The format code in the Data set list box has been changed to a two or three 
letter code, identical to that shown in the table in earlier int eh users man-
ual and as used by earlier versions of Stereonet.
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• Changing the format code in the Data set list box will now change the 
format of the data listing.

Version 7.0.3 — 2011.08.17

• New binary file format. It will read the old format with only minor glitch-
es in the analysis text. Nonetheless, you should re-save all of your binary 
files.

• Interface for contouring has been put in place (e.g., the Inspector now has 
a Contours tab) but contouring itself still does not work.

Version 7.0.2 — 2011.08.16

• minor bug fixes and behavior changes

• more predictable Inspector behavior
Version 7.0.1— 2011.08.15 -- Initial beta release!
Things that are known not to work in this release

• Contouring has not yet been implemented

• Set  view  direction  does  not  work  with  latitude-longitude  plots.  This 
means that you are effectively limited to viewing continents in the West-
ern Hemisphere

• Conical best fit has not yet been implemented

• Adding lines by their rake in a plane has not yet been programmed

• There is no way (yet) to combine data files, either by appending them to 
existing data sets or by or by copying and pasting between data sets

• Plotting small circle in the upper hemisphere is broken

• Variable rotation (e.g., by unfolding lines associated with bedding) has not 
yet been implemented

• Half circle rose diagrams and plotting mean directions for rose diagrams 
have not yet been implemented

• Refreshing the data listing does not always work. You may have to click 
on the data set again to refresh the data listing

• There is no way to control the format of the data listing at present

• There is currently no way to parse an unidentified text file that does not 
start  with  the  standard  two  character  header  from  earlier  versions  of 
Stereonet.
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