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Pasivní optické skenery
• Zpracování snímků pořízených synchronizovanými fotoaparáty

• Triangulují prostorové souřadnice z dvou a více snímků, 
pořízených synchronizovanými kamerami z různých úhlů 

• Rozlišení prvků na fotografiích -> výpočet prostorové polohy s 
rozdílů jejich uspořádání na různých fotografiích

• Předmět musí být v konstantní vzdálenosti pod přesně 
stanoveným úhlem

• Tvar povrchu objektu je rekonstruován na základě geometrických 

pravidel ze známé vzdálenosti, pozice a úhlu kamer vůči objektu. 
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Vectra XT

▪ 6 kamer

▪ Obličej, hlava i horní 
část trupu
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Animace softwaru při 
vytváření 3D modelu 

Vectra XT

Výsledné modely



Vectra M1 Vectra H1

▪ 2 kamery 

▪ Pouze obličej

▪ Pro záznam celého obličeje nutno kombinovat více 
snímků



Výsledné modely po spojení



Výhody

▪ Rychlost záznamu, která 
je srovnatelná s 
fotografováním 

▪ Eliminace negativního 
vlivu pohybu snímané 
osoby na kvalitu 
výsledného modelu

▪ Záznam textury 
snímaného objektu

▪ Zdravotní nezávadnost 
(mimo epileptiků)
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Nevýhody

▪ Relativně vysoká 
pořizovací cena

▪ Vyšší nároky na 
výpočetní techniku

▪ Limitace metody



Limitace
• Trichologický materiál 

(vlasy, vousy) – i 
jednotlivě

• Velmi lesklé povrchy

• Náročnost na kvalitní 
osvětlení

• Okraje skenu mohou 
být deformované

• Výsledný sken 
neobsahuje informace 
o částech objektu, 
které skener 
nenasnímá 9



Editace modelů

• Ořez chybně naskenovaných částí modelu

• Zarovnání modelů, nastavení modelu do definované polohy

• (nejen) Pro skeny z Vectry M1 spojování 3 skenů do 1 modelu

• Očištění od nadbytečných dat a chyb polygonální sítě

• Vyplnění děr v polygonální síti

• Odstranění chybných a izolovaných fragmentů a zdvojených sítí

• Redukce rozlišení polygonální sítě

• Změna velikosti digitálního modelu
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Osnova:

• krátký popis problému a motivace 
proč jej řešit

• příklad postupu v dostupném 
softwaru

• Videonávod (video na odkaze)

Editace modelů



Obj (může nést texturu, Meshlab, 
Blender,….)

Stl (bez textury, GOM Inspect, Meshlab,.. )

Ply

Wrl

Editace modelů - formáty



Ořez raw skenu
• V projektech Fidentis řešených u nás primárně: VECTRA XT 3D Imaging

Systém

• Také možné v: GOM Inspect (označit + delete), Meshlab (Z-painting + delete)

• Chybně nebo omylem naskenované polygony 

• Mohou zanášet chybu v dalších krocích editace a následných analýzách
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Přímo v programu u Vectry (VECTRA XT 3D Imaging Systém) pomocí k tomu určených nástrojů ořezat 
veškeré přebytečné polygony (např. zachycené oblečení, fragmenty okolí, vlasy atd.) dále je třeba ořezat 
místa s nízkou frekvencí polygonů na okrajích skenů. U laterálních skenů je možné ořezat i chybně 
naskenované oči (nepoužije se jejich textura).

Open in Analysis

a) Ořez pomocí nástroje k tomu určeném (blok ořezu, laso, označení oblasti) + delete
1) Uložení File – Safe – Ok

2) Export: Exort – Složka – Zaškrtnout obj formát – (Advanced jen pro Vectru XT) - Everywere + Single 
texture – Name: Číslo probanda

b) Vytvoření animace do aplikace pro probandy (využívá se jako odměna za účast v projektech)
(pokračování v práci Open in Analysis)

1) Export: Export pdf – označit Vanila + změnit na složku určenou pro tento účel

2) Animace: File – Create animation – Generate – Vpravo ikona uložení – Zpět – Najít mirror – export 
nejdřív v .pdf a pak v .obj

Ořez raw skenu (návod)



• Freeware

• 3 verze 2014 (videonávody), 2018 a 2020

• Liší se jen v detailech a pojmenováním 
několika funkcí (bude upozorněno)

• http://www.meshlab.net/#download

Příklad softwaru pro editaci modelů
Meshlab



Základní orientace v Meshlabu

Pracovní plocha

Lišta s funkcemi programu

Layer Dialog



• Modelem lze otáčet pomocí myši a klinutím na pravé tlačítko

• Lze jím také pohybovat v rovině (Ctrl +RBM), zvětšit jej (kolečko 
myši) nebo změnit perspektivu (Shift + kolečko myši)

• Model také můžete vyexportovat jako obrázek (ikona fotoaparátu)

• Layer Dialog slouží k orientaci mezi modely: 

• Oko – který model vidíte

• Žluté označení – označuje model se kterým pracujete (na to pozor, 
vždy mějte označen model na kterém pracujete!! jinak můžete 
upravovat jiný, který ani nemusíte mít zobrazen)

• Možnost zobrazit si pouze oblak bodů, síť, nebo komplet i s 
texturou 

• Export modelu klasicky přes nabídku File – Export Mesh/Export 
Mesh As

Základní orientace v Meshlabu



• Digitální modely jsou tvořeny vrcholy, jejichž poloha v prostoru je 
definována hodnotou tří souřadnic.

• Každý model má tedy určitou polohu a orientaci v kartézské 
soustavě souřadnic. 

• Poloha modelu, získaného skenováním nebo fotogrammetricky, je 
často dána polohou objektu při snímání nebo kalibrací dotykového 
digitizéru. 

• Poloha modelu v soustavě souřadnic není totožná s polohou, ve 
které se na model díváme v náhledovém okně aplikací. Otáčením 
modelu v náhledovém okně ve skutečnosti měníme úhel pohledu a 
ne orientaci modelu.

Nastavení modelu do definované polohy



Nastavení modelu do definované polohy

• Editační programy umožňují změnu polohy a orientace modelu v jeho 
soustavě souřadnic – tj. přepočítání polohy všech vrcholů modelu. 

• Tyto nástroje můžeme využít k ustavení modelu do některé ze 
standardních poloh (např. anatomické polohy nebo frankfurtské 
horizontály), do polohy vhodné k prezentaci.

• Sjednocení setu modelů, budoucí editace a analýzy 



Nastavení modelu do definované polohy

• Meshlab, Landmark, Cloudcompare, Blender

• Meshlab: pomocí funkce Manipulators Tool

20



Nastavení modelu do definované polohy (návod)

Zarovnání modelu podle os

1) Render – Show axis (okáže bod 0 na xyz souřadnici)

Na tento bod 0 zarovnáváme bod Pronasale (špičku nosu), tak aby obličej byl ve 

Frankfurtské horizontále

2) Manipulators tool

a) stisknutí klávesy T = po ose X, Y a Z dle natočení modelu – potvrzení Enter

b) stisknutí klávesy R = rotace – potvrzení Enter

Zkontrolujeme model ze všech stran, po každém zarovnání je nutné potvrdit 

Enter a deaktivovat Manipulators tool kliknutím na ikonu, pak můžete model 

pootočit a pokračovat dále

3) Uložení: Pravým tlačítkem na myši klik v Show Layer Dialogu na libovolný 

zarovnaný sken a z nabídky vybrat Freeze Current Matrix + export



https://web.microsoftstream.com/video/29e3122b-324d-44f6-ba3b-b1a08acaff28



Zarovnání modelů na sebe

• Landmark, Meshlab, Blender

• Meshlab: pomocí funkce Align, Point Based Glueing

• Pro spojení více modelů do jednoho (nejen faciálních 
skenů)
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Přes funkci Align zarovnání pomocí bodů pod tlačítkem “A v kolečku“ 

1) Frontální sken označíme pomocí tlačítka Glue Here Mesh jako primární (na něj budeme zbylé dva 
zarovnávat)

2) označíme jeden z laterálních skenů a stiskneme Point Based Gluening

3) Ve dvou oknech naneseme pomocí dvojkliku levého tlačítka na myši na oba skeny min. 4 body (u
složitějších skenů i více, číslování bodů začíná na 0) sloužící k zarovnání. Bod 1 na prvním odpovídá
bodu 1 na druhém skenu, atd. Proto je třeba velké přesnosti. Body umísťujeme na snadno
identifikovatelná místa (např. koutky úst, očí). Je třeba také umístit tyto body tak, aby byly rozmístěné
různě po skenu (a netvořily tak např. linku, ve videu příklad špatně zvolených bodů kdy se modely
zarovnají otočené). Body lze vymazat pomocí ctrl + levé tlačítko myši.

4) OK

5) Process

6) Pravým tlačítkem na myši klik v Show Layer Dialogu na libovolný zarovnaný sken a z nabídky vybrat 
Freeze Current Matrix – apply to all visible layers

7) Export

Zarovnání modelů na sebe



Spojování modelů
• Meshlab, GOM Inspect, Blender

• Pomocí funkce Flatten Visible Layers

• Více modelů tvořící jeden objekt např. skeny z Vectry M1 –
získáme tak kompletní informaci
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Spojování modelů

Spojení skenů

- Dále je třeba z těchto 3 zarovnaných skenů vytvořit jeden model

1) Pravým tlačítkem na myši klik v Show Layer Dialogu na libovolný 

sken a z nabídky vybrat Flatten Visible Layers (pozor musí být 

všechny 3 skeny viditelné! – ikona oka vlevo od názvu skenu) 

2)  Apply (vytvoří se jeden model)



https://web.microsoftstream.com/video/2b17804a-72a9-4151-876f-

8e3284a411ed



Očištění dat od chyb polygonální sítě, zdvojení sítě, ..

• Meshlab

- Filters- Remeshing - Screened Poisson Surface
Reconstruction

- Poté ořez přebytečných částí modelu

• GOM Inspect

- export - geometry – ASCII

- vyexportovaný oblak bodů v GOM + rekonstrukce polygonální 
sítě (Polygonize point cloud)
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Meshlab

Označený model 

1) Poissonova rekonstrukce povrchu: 

Filters- Remeshing - Surface Reconstruction (stará verze) nebo Screened Poisson

Surface Reconstruction (nová verze)

2) Ořez zadní části modelu

a) Funkce Štětec (Z-painting)

b) Zakliknout červený štětec – označit co se má oříznout (prostor mezi ušima, za 

čelem a v dolní části až k textuře, můžete zvolit velikost štětce a to zda štětec označí i 

polygony skryté, či obrácené 

c) Klik na Delete the current set of selected faces and all the verticles sorrounded by 

that faces (červený přeškrtnutý trojúhelník s kolečky na vrcholech)

d) Dočistit hrany tak aby nevytvářely vystupující útvary 

e) Exportovat v obj nebo stl



https://web.microsoftstream.com/video/1921d839-2a32-428a-9fba-

9454bb793cce



• Polygonální sítě tvořící 3D model často obsahují velké množství děr. Nemusí jít pouze o 
díry odpovídající přirozeným otvorům modelovaného objektu nebo díry vzniklé v 
místech, která nemohla být nasnímána, např. z důvodu zákrytu nebo špatné 
dostupnosti. 

• Velké množství nepatrných děr vzniká také v důsledku chybného generování 
polygonální sítě, jde o artefakty tvorby modelu. 

• Díry v polygonální síti mohou být překážkou aplikace některých analytických nástrojů 
(např. měření objemu, vytváření rovinných řezů). 

• Úplná uzavřenost polygonálních sítí je nutná také pro 3D tisk – některé aplikace z 
tohoto důvodu hlásí chybu při ukládání neuzavřeného modelu do formátu stl, 
nativního formátu stereolitografie, jedné z metod 3D tisku.

Zaplnění děr



Zaplnění děr

GOM Inspect

Automatické vyplňování 
• Označíme celý model – LMB > Select All. 
• Spustíme nástroj pro automatické vyplňování – Operations > Mesh > Close holes > Automatically… 
• Nastavíme parametry děr, které chceme automaticky zaplnit (podle obrázku níže). U řady nástrojů lze 
parametry jejich použití nastavit automaticky, kliknutím Ctrl + LBM na relevantní oblast polygonální sítě. 
Automatické vyplňování nastavíme kliknutím na okraj díry tak, že budou vyplněny díry stejné a menší 
velikosti. 
• Nástroj aplikujeme stiskem Apply

Manuální vyplňování
• Spustíme nástroj manuálního vyplňování děr – Operations > Mesh > Close holes > Interactivelly... nebo 
příslušnou ikonou. 
• Díru, kterou chceme editovat, vybereme kliknutím Ctrl + LMB do blízkosti jejího okraje 
• Po nastavení parametrů výplně aplikace dopředu vypočítá její tvar (v případě složitějších děr může tato 
operace trvat několik sekund). 
• Nastavení Filling result měníme podle požadovaného výsledku. V případě některých děr je dobré zvolit 
jemnější přechod, respektující tvar okolí díry, v případě přirozených děr můžeme použít rovnou výplň 
(Plane-based). 
• Výplň aplikujeme příkazem Apply. 
• Celý proces opakujeme u dalších děr modelu



Meshlab

• Program Meshlab obsahuje nástroj, který automaticky vyplňuje všechny 
díry do velikosti definované počtem polygonů ohraničujících díru.

• Vyplňování děr v polygonální síti – MeshLab

• Spustíme nástroj automatického vyplňování děr – Filters > Remeshing, 
Simplification and Reconstruction > Close holes

• Definujeme max. velikost vyplňovaných děr. Pro vyplnění drobných děr 
zvolíme nějakou přibližnou hodnotu, např. 20 (při nastavení na tuto 
hodnotu budou editovány všechny díry, které jsou ohraničeny dvaceti a 
méně polygony). Nastavení příliš velké hodnoty by mohlo vést k 
nechtěnému uzavření větších děr

Zaplnění děr



Kvalita a rozlišení polygonální sítě se 
může v různých částech modelu lišit.

Nesjednocená síť může zanášet chybu 
při analýze sítí

GOM Inspect, Meshlab, Blender

- Select all – mesh – other – regularize
– 0,006 mm (vyberete požadovanou 
toleranci povrchu)– apply

Regularizace polygonální sítě



• Redukce rozlišení je krokem, ke kterému můžeme přistoupit v různých 
fázích editace modelu. 

• V ideálním případě pracujeme s modelem v původním, maximálním 
rozlišení, daným např. nastavením 3D skenování. 

• S rostoucím rozlišení modelu však úměrně stoupá velikost souboru a 
výpočetní náročnost jeho zpracování, proto často přistupujeme k 
redukci rozlišení na počátku celé editace tak, abychom snížili její 
výpočetní náročnost. 

• Zvolené rozlišení je vždy kompromisem mezi množstvím uchované 
informace, zachycených detailů, a velikostí souboru.

Redukce rozlišení polygonální sítě



Redukce rozlišení polygonální sítě

• Vybereme celý model – RMB > Select All…

• Spustíme nástroj pro redukci rozlišení „Thin Mesh“ – Operations > Mesh > Thin… 

• Zvolíme nastavení Surface tolerance a zadáme maximální odchylku, kterou může 
mít nový model od originálu. 

• Můžeme aktivovat také volbu Max. edge length, která omezuje délku hran nově 
vzniklých polygonů. Např. při nastavení Surface tolerance na hodnotu 0.2 a Max. 
edge length 2 bude výsledkem redukce polygonální síť, která se tvarově neliší od 
původní sítě o víc než o 0.2 

• Redukce rozlišení polygonální sítě – GOM Inspect 74 mm a jejíž vrcholy nejsou od 
sebe dál než 2 mm. 

• Redukci spustíme tlačítkem Apply Druhou možností je nastavení přesného počtu 
vrcholů redukované polygonální sítě (Number of points). 

• Výhodou nastavení maximální odchylky je, že nemusí být specifikován konkrétní 

počet bodů, závislý na velikosti sítě a její složitosti, ale jen tvarová tolerance. 

GOM Inspect



Meshlab

• V Layer Dialog aktivujeme model (LMB), jehož rozlišení chceme redukovat 

• Spustíme nástroj redukce rozlišení – Filters > Remeshing, Simplification and 
Reconstruction > Quadric Edge Collapse Decimation... 

• Nastavíme parametry redukce a aplikujeme – Apply

• Target number of faces – nastavíme počet polygonů výsledného modelu 

• Preserve Normal, Preserve Topology, Preserve Boundary – volby zabraňující 
větším změnám v geometrii modelu. Při aktivaci bude zachováno směrování 
polygonů, redukce rozlišení nepovede ke změnám topologie modelu, např. 
vyplnění děr v modelu, a ke změnám tvaru děr v polygonální síti. 

• Jednotlivé volby jsou podrobně popsány v nápovědě, která může být aktivována 
tlačítkem Help v dialogovém okně. Stejná nápověda je k dispozici u většiny 
nástrojů.



Textury
Barevná informace 

Nejčastěji .obj formát 3D modelu

.jpg nebo .png

.mtl soubor spojující model s texturou

Definována nejčastěji v RGB spektru( ale i CMYK) nebo 
stupni šedi a rozlišením

Zásadní u digitalizace bodů např. na obličeji

Pro identifikační účely ve forenzních vědách

Informace o stavu objektu 
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Textury
Vstup: modely - Raw edited zarovnané a) jeden bez textury označen číslem a CA (.ply)

Postup:
Vytvoření souřadnic 
Meshlab – otevřít soubor 
První cesta: Filters – Texture – Parametrization: Flat plane – apply – apply
Alternativní cesta: Filters – Texture – Set texture, texture dimension: 4096 – apply

Druhý krok:
U obou souborů CA i F 
Filters – Texture – Transfer vertex attributes to texture (between 2 meshes), Tabulka:
Source: S texturou 
Target: bez textury
Color data source: texture color
Název: Přesně jako ten s texturou CA + .png
Texture u obou čísel 4096 
Zaškrtnout: Fill texture i Assign texture (nezaškrtnout: overwrite target!)
Dále: uložit v .obj

V textovém editoru
Do řádku u souboru nového modelu pod ( NS řádek) z .mtl map. Kd + přesný název souboru

39



https://web.microsoftstream.com/video/d2803b2d-f56f-

40a0-a708-8cfae39c5de9



Digitalizace landmarků a křivek

Landmark (od 2019 už není freeware)
-Křivky: Curve > Primitives > Edit Landmark Primitives
-Semilandmark density, export .pts nebo .nts

Meshlab

GOM Inspect

Fidentis (viz dále)



• Registrace polohy význačných bodů na digitálních povrchových modelech 
odpovídá digitalizaci význačných bodů na objektech např. dotykovým 
digitizérem. 

• Výhodou digitálního prostředí je možnost uložit postup práce a dodatečně 
kontrolovat umístění bodů, stejně jako větší přístupnost různých struktur 
analyzovaného objektu.

• Nevýhodou je především horší lokalizace některých význačných bodů, v 
závislosti na kvalitě/přítomnosti textury a přesnosti modelu. 

• Prvním krokem je umístění bodů na povrch digitálního modelu, druhým export 
3D souřadnic těchto bodů, obvykle v textovém formátu.

Digitalizace landmarků



• Otevřeme projekt s modelem. 
• Spustíme nástroj editace povrchových bodů Construct > Points > 

Point.. Editace a export význačných bodů– GOM Inspect
• Body umisťujeme na povrch modelu příkazem Ctrl + LMB. V 

dialogovém okně můžeme změnit jméno bodu. Vytvoření bodu 
potvrdíme příkazem Construct. Všechny definované prvky jsou 
součástí projektu a jsou uvedeny v seznamu Explorer jako tzv. 
Geometries… Prostorové souřadnice všech prvků mohou být 
exportovány ve formátu CSV nebo ASCII příkazem File > Export > 
Geometry… 

• V seznamu Explorer označíme body, které chceme exportovat nebo 
nadřazenou složku Points v případě, že chceme exportovat všechny 
body.

• Souřadnice bodů exportujeme přes dialogové okno File > Export > 
Geometry Pokud nezměníme cílové umístění exportovaných dat, uloží 
se do složky Export, která je součástí projektu.

GOM Inspect

Digitalizace landmarků



Meshlab

• Editace a export význačných bodů– MeshLab Body editujeme za pomoci nástroje 
PickPoints. Nástroj pracuje s předpřipravenými šablonami, do kterých jsou doplňovány 
souřadnice. Prvním krokem je příprava šablony s konfigurací bodů, druhým pak samotná 
registrace polohy bodů. 

• Otevřeme projekt s importovaným modelem. 
• Spustíme nástroj PickPoints
• Volbou Add Point přidáme do šablony potřebný počet bodů, pro lepší přehled body 

pojmenujeme. 
• Vedle Add Point jsou v Template Controls umístěny také další nástroje pro ovládání 

šablony. Námi vytvořenou šablonu můžeme uložit pro pozdější použití volbou Save, dříve 
vytvořenou šablonu můžeme nahrát volbou Load. Volbou Clear šablonu kompletně 
vymažeme. K editaci bodů, obsažených v šabloně, slouží nabídka pod seznamem bodů. 
Možností je body přejmenovat (Rename Point), odstranit body ze šablony (Remove Point), 
vymazat souřadnice bodu (Clear Point).

• V dialogovém okně označíme první bod (kliknutím LMB) a určíme jeho polohu na modelu 
pravým tlačítkem myši. Pokračujeme v umístění všech bodů šablony, do dialogového okna 
jsou automaticky zaznamenány jejich souřadnice. Špatně umístěný bod můžeme znovu 
zaznamenat nebo využít volby Move Point, kdy s bodem můžeme při stisknutém RMB volně 
hýbat po povrchu modelu. 

• Šablonu se souřadnicemi uložíme příkazem Save. Souřadnice jsou uloženy ve formátu .pp. 
Soubor může být otevřen např. v textovém editoru a souřadnice překopírovány do tabulky

Digitalizace landmarků



Digitalizace křivek

• Aplikace nabízejí řadu nástrojů pro tvorbu volně definovaných 
povrchových křivek a rovinných řezů, průsečíků modelů s 
definovanými rovinami. 

• Editace a export křivek křivky mohou být exportovány ve formě 
vektorů, častěji jsou však exportovány a dále zpracovávány 
souřadnice bodů, kterými křivka prochází.



• Otevřeme projekt a importujeme model. • Spustíme nástroj pro konstrukci 
povrchových křivek (Construct > Curve > Surface Curve…) 

• Umísťováním bodů na povrch modelu (Ctrl + LMB) editujeme průběh křivky. 
Pokud v průběhu editace křivky klikneme na její první bod, křivku uzavřeme. 
Vytvoření naeditované křivky potvrdíme volbou Ok. 

• Křivka je zařazena do seznamu Explorer, do oddílu Geometries > Surface
Curves. 

• Na rozdíl od křivek editovaných v programu Landmark je výsledkem jediná 
povrchová křivka (a ne řetězec křivek), přesně kopírující povrch modelu. 

• Program exportuje křivky ve formě souřadnic velkého počtu bodů, kterými 
procházejí. Počet bodů, jejichž souřadnice exportujeme je nastaven 
automaticky (v případě křivky editované na pánvi jde o ca 500 bodů). 

• Křivku, kterou chceme editovat, označíme v seznamu Explorer a spustíme 
dialogové okno pro export File > Export > Geometry… 

• V dialogovém okně nastavíme jméno souboru a jeho umístění, křivku 
exportujeme příkazem Export

Digitalizace křivek

GOM Inspect



• Program GOM Inspect umožňuje vytvářet rovinné řezy digitálními modely. Výsledkem je křivka 
odpovídající průsečíku polygonálního modelu a definované roviny. Vytvoření rovinného řezu probíhá 
ve dvou krocích. Prvním krokem je definování roviny řezu (v případě, že nechceme vést řez 
rovnoběžný s rovinami souřadnicového systému), druhým pak vytvoření samotné křivky. 

• Otevřeme projekt a importujeme model. • Spustíme nástroj vytvoření roviny za pomoci tří bodů 
(Construct > Plane > 3-Point plane…)

• Příkazem Ctrl + LMB umístíme na povrchu modelu 3 body, kterými bude rovina procházet. • Rovinu 
vytvoříme příkazem Create. Rovina je jedním z geometrických prvků (stejně jako body). Vytvořené 
roviny jsou proto uvedeny v seznamu Explorer jako Sections. 

• Označíme část modelu, kterou chceme vést řez. V našem případě celý model. • Spustíme nástroj pro 
vytvoření rovinného řezu (Construct > Section > Single Section…) 

• V dialogovém okně zvolíme za Reference plane námi definovanou plochu. Volba Position umožňuje 
posun plochy řezu vůči referenční ploše, v našem případě ponecháme nastavení 0. Řez bude veden 
přímo námi definovanou plochou. 

• Rovinný řez vytvoříme příkazem Create. Rovinné řezy jsou uvedeny v seznamu prvků Elements jako 
Sections. 

• Křivku, kterou chceme editovat, označíme v seznamu Explorer a spustíme dialogové okno pro export 
File > Export > Geometry… 

• V dialogovém okně nastavíme jméno souboru a jeho umístění, křivku exportujeme příkazem Export. 

Digitalizace křivek

Meshlab



• Porovnání rozdílů mezi dvěma a více modely

• Celková variabilita v populaci/vzorku
• Rozdíly mezi skupinami (m x ž, věkové skupiny, populace,…)
• Porovnání vzorku s databází/populací/kontrolní skupinou
• Lokální variabilita (oblast nosu, očí, kloubní plošky na kostech, nelezení 

místa s největšími rozdíly na modelech,…)

Analýza modelů



Převedením 3D modelu do 2D (ztráta informace! Pouze pokud není
jiná možnost nebo to vyžaduje metodika)

-Fotografie, náhledy

-Biometrické systémy

-Hloubkové mapy

Vlastní analýzy modelů:

-Analýzy landmarků (např. Procrustova analýza, měření vzdáleností -
Meshlab, výpočet v Excelu (Pythagorova věta ve 3D))

-Analýzy semilandmarků a křivek

-Analýzy sítě (Vertex to vertex)

Analýza modelů



Fidentis AnalystNapříklad:



Fidentis Analyst

Umožňuje analýzy modelů (porovnáním sítí)
1:1 – dva modely (před a po operaci, muž žena, porovnání stejného 
jedince po několika letech – např. růst
1:n – jeden jedinec vs databáze (např. jak moc se liší od populace)
n:n – všichni se všemi (např. variabilita populace, …)

https://www.fidentis.cz/analy
st





Model je potřeba před analýzou registrovat do 3D prostoru  

GPA algoritmus (Generalized Procrustes analysis)
- Na základě procrustovských vzdáleností jednotlivých bodů

ICP algoritmus (Iterative Closest Point) 
-Hledá minimalizaci rozdílu mezi dvěma oblaky bodů, bod po bodu

Scale – zahrnutí analýzy celkové velikosti objektů, či nikoli (= analýza pouze tvaru)

Registrace modelu



Registrace modelu



Digitalizace landmarků

Nástroj pro digitalizaci landmarků

1) manuální
2) automatická



Manuální digitalizace landmarků

https://web.microsoftstream.com/video/879

14581-bf42-400b-8dcd-847cc3ddebd6



Automatická digitalizace landmarků

https://web.microsoftstream.com/video/77d

a7b98-ea28-47db-a1a8-1d888a9b8475



Vpravo nahoře je k dispozici seznam landmarků s definicemi



42 landmarků se standardizovanými definicemi
např.glabella, subnasale, gnathion, ...

Standardizovaná pozice, přesná a jasná definice bodu minimalizuje spolu s dalšími faktory chybu digitalizace.

Vždy kontrola chyby digitalizace!



Orientace v menu a konfigurace

https://web.microsoftstream.com/video/44d

af8b1-2b65-422e-a172-38003dd89cd3



Procrustovská analýza a Cross section

Procrustovská analýza – body (např. když máte jen je 

nebo je nemožná analýza celé sítě

Cross section – řezy, v mnoha případech nám mohou 

rychle a přehledně ukázat jak a kde se liší 

analyzované modely (i vůči průměru)

https://web.microsoftstream.com/video/a03f2b18-

47ab-450f-b1f8-1346234817e0



Analýza lokálních oblastí

Důležitá chceme-li na základě námi zvolených parametrů

analyzovat nějaké konkrétní oblasti – s nejmenšími/největšími

rozdíly, s podobnou morfologií

https://web.microsoftstream.com/video/3e48c35b-7459-4f24-

9ed6-5b1390b64880



FIDENTIS Analyst

Numerické výsledky

● Rozdíly mezi 3D objekty jsou vyjádřeny ve formě point to point 
vzdáleností (nebo jejich derivátů: průměr, minimum, maximum, root
mean square atd.)

root mean square - Kvadratický průměr je statistická veličina představující 
druhou odmocninu aritmetického průměru druhých mocnin daných hodnot.



FIDENTIS Analyst
Numerical results

0 10

Vertex to vertex distance (in mm)

0 50

Vertex to vertex distance (in mm)

0

Vertex to vertex distance (in mm) for results between 5 and 95 thresholds

50



Využití

Popisná statistika

Porovnání výsledků pomocí statistických metod 

Analýzy landmarků (lineární regrese, PCA,..)



Vizuální vyjádření rozdílů

● Komparativní analýza modelů

● Superpozice

● Explicitní vyjádření rozdílů pomocí konverze numerické 
informace do vizuální mapy

FIDENTIS Analyst



FIDENTIS Analyst

Color map - “Diverging” color spectrum Color map - “Rainbow” color spectrum

Color map - “Sequential” color spectrum Cross-sections



FIDENTIS Analyst

Transparency

Contours + GlyphsContours + Fog simulation

Transparency + Fog simulation



Úkoly:

1) složka ukol_1 (Meshlab)
-3 Raw skeny zarovnat na sebe a spojit do 1

-Provést Poissonovu rekonstrukci povrchu

-Oříznout zadní část + vytvořit texturu

-Vyexportovat obrázek modelu z Fidentisu z 
frontálního pohledu a pravého profilu



2) složka ukol_2
-Provést v programu Fidentis analýzu 1:1 
-Vyexportovat vizuální výsledky a slovně 
popsat kde se modely nejvce liší

3) složka ukol_3
-Provést v programu Fidentis analýzu n:n
-Z numerických výsledků zjistit dvojici 
nejpodobnějších a nejodlišnějších 
modelů

(registrace modelů úkol 2 na povrch úkol 3 na body 
- excel) 



Výsledky zaslat na: dominikcerny@sci.muni.cz

V případě dotazů pište tamtéž

Nahromadí-li se více dotazů domluvíme Stream přes 
MS Teamsy


