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Cvičení 5  

Vizualizace, vektorizace, data  



 

Vytvořte si adresář pro toto cvičení. 
 

Naučte se nepoužívat v názvech adresářů ani souborů mezery, pro některé operace 
je mezera kdekoli v cestě nepřekonatelnou překážkou! 
 

Do adresáře si nakopírujte a rozbalte data pro toto cvičení z učebních 
materiálů předmětu na is.muni.cz 
 

1. Symbologie 

 

V .zip je adresář, obsahující část dat, kterými disponuje laboratoř GIS na ÚBZ 
(složka ukázka dat). Dostáváte je, aby jste získali přehled o tom jaká data jsou u nás 
 

k dispozici, a také proto, abyste si na nich vyzkoušeli možnosti symbologie a 
tvorby finálních mapových kompozic.  

K dispozici máte také data arcCR500 (produkt firmy Arcdata, data ČR v měřítku 1 : 
500 000) 

 

Vyzkoušejte si různé typy symbologie na různých vrstvách. Podle čeho 
data symbolizovat většinou naleznete v atributových tabulkách. 
 
 

 

 Single symbol. Všechny prvky se budou vykreslovat stejným symbolem. V 
tomto případě se vůbec nepoužívají informace z atributové tabulky. 



 

 Categories: Unique values. Stejným symbolem se vykreslí všechny prvky, 
které mají v určeném poli atributové tabulky stejnou hodnotu, tedy používají 
se atributy, které prvky identifikují (název obce, půdní typ, řád toku…). 
Jedinečné hodnoty lze získat přímo z jednoho atributu…. nebo lze jedinečnost 
prvků skládat dohromady kombinací z více polí. 



 

 Quantities: Používají se pro zobrazení prvků podle číselné hodnoty v atributu - 
kvantitativního atributu – počtu, poměru, velikosti, úrovně. (Všimněte si, že 
pro Value Field můžete vybírat pouze z číselných, nikoli např. textových polí)

o Graduated colors. Používá zadaný počet intervalů na vybrané barevné 
škále. Nastavit lze hranice intervalů (podle různých klasifikačních 
metod nebo manuálně) a nastavit lze i vlastní barevnou škálu.  







 

o Quantities: Graduated symbols. Vhodné pro mapování velikosti nebo 
významu bodových prvků (obyvatele města, vydatnost pramene, 
velikost zdroje znečištění), liniových prvků (řád toku dle Strahlera, 
hluk podél komunikace) i polygonových prvků (plochy jsou 
reprezentovány bodem, umístěným v centru polygonu)  



 

o Quantities: Proportional symbols. Velikost symbolu nevyjadřuje 
příslušnost do určitého intervalu hodnot ale odpovídá absolutní 
hodnotě atributu. Metoda proto není vhodná pro zobrazení 
prvků s velkým rozpětím hodnot  



 

o Quantities: Dot density. Tato metody se používá k vyjádření 
kvantifikace pouze u polygonových prvků. Náhodně rozmístěné 
body vyjadřují celkové množství, nastavuje se hodnota, jakou má 
reprezentovat jeden bod.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

o 



 

2.Layout 

 

Vytvořte z nich libovolný mapový výkres (Layout) který budete nakonec 
exportovat do obrázku a odevzdáte do odevzdávárny na Isu.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Pár tipů k layoutu:  

 Podle čeho data symbolizovat většinou naleznete v atributových tabulkách

 Pro tvorbu popisků můžete použít záložku Labels v Layer Properties


 Prvky (Data Frame, měřítko, legendu, severní šipku, název mapy…)v Layout 
view vybírejte nástrojem Select Elements  z palety nástrojů Tools







 Měnit velikost a tvar Data Framu lze pomocí jeho krajních bodů 



 

 Kliknutím kamkoli mimo Data Frame se dostanete do Page and Print Setup, 
kde můžete nastavit formát papíru 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Vyzkoušejte si rozdíl mezi nástroji v paletě nástrojů Tools a Layout (ta se vám 
přidala automaticky, když jste se z Data View přepnuli do Layout View) 



 

 Layout může obsahovat více Data Frames (pokud je jich více v TOC, zobrazí se 
všechny v Layoutu. I pokud je v TOC jen jeden Data Frame, lze ho v Layoutu 
použít vícekrát (typicky když jeden zobrazuje celek a druhý detail téhož). 
Pokud chcete v jedné mapě použít vícekrát stejný data frame, použijte funkci 
Copy: Klikněte na Data Frame v Layoutu (vyberte ho), pak v (Hlavním menu – 
Edit – Copy). Klikněte v (Hlavním menu – Edit – Past). ArcMap vloží do layoutu 
kopii prvního Data Frame na stejné umístění. Klikněte tedy myší na Data 
Frame, a myší odtáhněte kopii na nové umístění.


 Pokud používáte jeden Data Frame pro celek a druhý pro detail téhož 

území, můžete nastavit symbol pro dynamické změny výřezu při zoomování 
v Data Framu s detailem. 



 
 
 

 Mapa by měla obsahovat šipku na sever (Hlavní menu – Insert – North Arrow). 



 

 Mapa by měla obsahovat měřítko. Vzhledem k tomu, že budete výsledek 
nakonec exportovat do souboru (obrázku) a nevíte, v jaké velikosti si ji pak 
další uživatelé otevřou nebo vytisknou, než číselné měřítko bude 
vhodnější grafické měřítko, nezávislé na velikosti při tisku. Pokud budete v 
mapě (ne v Layoutu) zoomovat, bude se dynamicky měnit i měřítko. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Mapa by měla obsahovat legendu. Legendu vložíte opět podobně jako u 
předešlých prvků (Hlavní menu – Insert – Legend). V levé části okna jsou 
vypsány všechny vrstvy, které máte v mapě. V pravé části, které ukazuje jaké 
vrstvy se budou zobrazovat v legendě, jsou defaultně načteny také všechny 
vrstvy. Když je legenda vytvořena a umístěna v layoutu, můžete dále měnit 
její vzhled (PTM na legendu > Properties) Na jednotlivých kartách měníte 
vlastnosti obdobně jako v Legend wizard. Pokud chcete provést nějaké změny 
pouze u některých položek, je třeba je označit na záložce Items (dvojklik na 
příslušnou položku).



 

 Jednotlivé prvky Layoutu můžete orámovat, podbarvit a také jim přidat 
stín. Klikněte pravým tlačítkem na prvek(samotný Data Frame, legendu, 
měřítko, textové pole…), který chcete orámovat nebo podbarvit a zvolte 
Properties a dále kartu Frame. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Mapa by měla obsahovat název, popřípadě nějaké další textové pole.
 Až budete s výsledkem spokojeni, můžete tisknout/exportovat (Hlavní menu >

File > Print/Export) 



 
 
 

3. Podíl lesů 
 

Budete hledat závislost počtu jedinců vašeho oblíbeného zkoumaného druhu na 
podílu lesních porostů v okolí jejich výskytu (resp. připravovat podklady pro 
toto hledání) 
 

3.1.Vytvoření bodové vrstvy 
V terénu jste zaměřili pomocí GPS místa pozorování. 
 

Data jste si z GPS stáhli na počítač a uložili v souboru gps.txt. Můžete si ho otevřít 
a prohlédnout. 
 

I z textového souboru lze vytvořit bodovou vrstvu, vložte si do ArcMapu další 
Data Frame a do něj přidejte gps.txt a otevřete ho. Má strukturu tabulky, zkuste 
tedy použít funkci (Display XY Data). 
 

Převeďte z WGS84 do S-JTSK (Toolbox > Data Management Tools > Projections 
and Transformations > Feature > Project) a přidejte do dalšího nově otevřeného 
Data Framu. 

 

3.2.Přidání dat z Internetu 
Přidejte si z ArcGIS Online ortofoto od ČUZK, abyste zkontrolovali, jestli jste data 
z GPS použili správně. 
 

Pro analýzu byste potřebovali polygonovou vrstvu lesních porostů. Lesácké mapy 
nejsou ale tak podrobné, některé menší kousky lesa (různé remízky a větrolamy) na 
nich nenajdeme. Protože ani Corine ani data z UHUL pro vás nejsou dostatečně 
podrobná a jedná se o celkem malé území, rozhodli jste se si svoji mapu lesních porostů 
vytvořit sami vektorizací ortofota.  

 

Potřebujete vytvořit nový prázdný polygonový shapefile, což 
provedete v ArcCatalogu. 
 

3.3.Buffer 
 

Dříve, než začnete vektorizovat, je třeba znát rozsah území, které vás zajímá Je 
třeba vědět, jak daleko sahá definované okolí (buffer) kolem bodů. 

 

Uděláte kolem bodů buffer v několika šířkách (s vedoucím práce jste se dohodli na 
5, 10, 20, 50, 100 a 200 metrech). Nemusíte dělat každou šířku zvlášť, zkuste najít 
vhodný nástroj. Pozor na volbu Dissolve Option, All nebo None? 



Nejširší buffer vám definuje rozsah území, které je třeba vektorizovat. Hranici  

vektorizovaného území byste měli znázornit jako obdélník kolem nejširších bufferů. 
Slouží k tomu funkce Feature Envelope to Polygon. Tato funkce ale tvoří obálku  

(obdélník kolem feature) pro každý prvek, musíte tedy nejdřív použít funkci Dissolve a 

všechny prvky spojit do jednoho (je třeba mít v atributové tabulce pole, kde budou  

pro všechny prvky stejné hodnoty). 
 
 
 

3.4.Vektorizace  

Nyní se můžete pustit do vektorizace vymezeného území (Editor > Start Editing)  

 Používejte Polygon z Construction Tools (nebo můžete nástrojem  Cut 
Polygons Tool postupně vyřezávat kousky lesa z vrstvy FeatureEnvelope)


 Při kreslení větších ploch můžete nakreslit dva překrývající se prvky a ty 

pak vybrat a spojit (Editor > Merge)


 Nastavte si Editovanou vrstvu jako The Only Selectable Layer (PTM na 
vrstvu v TOC > Selection > Make This The Only Selectable Layer)


 Průběžně si vektorizaci ukládejte (Editor > Save Edits)


 

3.5.Intersect 
 

Intersectem vrstvy bufferů a vrstvy lesů vznikne vrstva, která bude mít v atributové 
tabulce informace o obou vstupních vrstvách. Zajímá vás plocha jednotlivých 
bufferů jednotlivých bodů, celkem tedy 20x6 údajů o ploše lesa. 

 

Přesunete se do atributové tabulky. Plochy, které atributová tabulka zobrazuje se při 
změně tvaru prvku neaktualizují, tzn. jsou to plochy, které měly jednotlivé prvky před 
intersectem – pamatujte, že údaje v atributové tabulce o rozloze nebo souřadnicích se 
nemění, když se změní rozloha nebo poloha prvku – tato pole je třeba přepočítat (v 
atributové tabulce PTM na název sloupce > Calculate Geometry > Area). 
Jiná možnost je neuložit výsledek nástroje z toolboxu jako shapefile, ALE jako 
FeatureClass do Geodatabáze. Tam bude mít stále aktuální pole se správnou rozlohou. 

 

3.6.Sumarizace 
 

Nyní budete sumarizovat, tedy počítat sumární statistiky pro skupinu prvků 
stejného atributu, v tomto případě prvku s jedinečnou lokalitou a zároveň šířkou 
bufferu (Toolbox > Analysis Tools > Statistics > Summary Statistics). Statistics Field 
bude plocha a její suma, Case Field bude kombinace dvou atributů, ID bodu a šířky 
Bufferu. 

 

Výsledná tabulka ukazuje plochu jedinečných kombinací bodu a bufferu. Pokud by 
vás zajímal podíl plochy, přidejte do atributové tabulky dvě pole, do jednoho 
vypočtěte celou plochu kruhu, do druhého pak podíl. 



 

Ke stejnému výsledku v přehlednější podobě dojdete v excelu, když použijete funkci 
kontingenční tabulka. Vyzkoušejte, *.dbf tabulku, náležící vrstvě intersectu, lze 
otevřít přímo v excelu. 
 
 
Tabulku s výsledky ve formátu *.xls a obrázek  vektorizovaných lesních porostů  
nahrajte do odevzdávárny na Isu.



4. Srážky v ČR (a okolí) 
 

Ze tří různých DB jste získali souřadnice s nálezy „vašeho“ druhu. Potřebujete k nim 
získat informace o úhrnu srážek na jednotlivé roční období (pracujete s hypotézou, že 
se v datech projeví kontinentalita polohy, hojnost druhu na lokalitě by mohla 
korelovat se vzdáleností od oceánu - a tedy srážkových úhrnech). Souřadnice jsou 
bohužel ve třech různých souřadných systémech. 
 

4.1. Sjednocení bodových vrstev 
V datech ke cvičení jsou tři .xls soubory (snimky1, snimky2, snimky3). Odhadněte 
 

v jakém souřadném systému jsou souřadnice, vytvořte z nich tři bodové vrstvy (Tools 
> Add XY Data), všechny převeďte na WGS84 (Toolbox > Data Management Tools > 
Projections And Transformations > Feature > Project) a spojte dohromady do jedné 
vrstvy 
 

(Toolbox > Data Management Tools > General > Merge). Kolik má výsledná vrstva 
bodů? Zkontrolujte, jestli všechny leží v ČR (pomocí vrstvy hrcr_wgs). 
 

4.2. Data Worldclim 
 

Vzhledem k tomu, že ne všechny body leží v ČR, budeme potřebovat klimatická data 
pro okolní státy. K Tomu se hodí data Worldclim, najděte je na internetu. Stahovat je 
nemusíte, mate je v datech ke cvičení (prec_16). Rastry reprezentují měsíční úhrny 
srážek, budete je muset posčítat po třech měsících (použijte Spatial Analyst > Raster 
Calculator a nebo Toolbox > Spatial Analyst Tools > Map Algebra > Single Output 
Map Algebra) 

 

4.3. Sample 
 

Pro přiřazení hodnot rastrů bodovým lokalitám použijte funkci Sample (Toolbox 
> Spatial Analyst Tools > Extraction > Sample) 
 
Symbolizujte bodovou vrstvu podle ročního úhrnu srážek (barva nebo třeba 
velikost symbolu) a odevzdejte jako obrázek do odevzdávárny na Isu. 
 

 
 
 

 


